Yorix - produkty

We are from czech republic YORIX s.r.o.
DHTML Menu / JavaScript Menu - Created Using NavStudio (OpenCube Inc.)
****JavaScript based drop down DHTML menu generated by NavStudio. (OpenCube Inc. - http://www.opencube.com)****

Regulace spotřeby přebytků z FVE

GreenBonO s příslušenstvím
GreenBonO - využití přebytků FVE takřka beze zbytku

GreenBonO - regulátor spotřeby přebytků elektřiny z FVE
s plynulým řízením výkonu v odběrných místech s režimem "zelený bonus"

Levný a velmi účinný přístroj, s nímž lze účelně využít veškerou elektřinu z FVE pro vlastní potřebu.

Podpůrné moduly pro rozšíření počtu vstupů a výstupů
volně programovatelných domovních automatů (Home & Building)

2P10/3
dvojice převodníků k ovládání 3-stavových pohonů ventilů
UDO4b
převod 1 AO na 4 reléové výstupy
UDO6
převod 1 AO na 6 reléových výstupů
UDI6
převod 6 digitálních vstupů na jeden analogový
V této sekci jsou umístěny I/O moduly, které umožňují libovolnému volně programovatelnému automatu transformovat jeden analogový výstup na několik digitálních výstupů, nebo několik digitálních vstupů na jeden analogový vstup. Není k tomu potřeba žádné speciální datové rozhraní - transformace se uskutečňuje na principu D/A nebo A/D převodu.
Moduly byly vyvíjeny pro podporu kontrolerů Honeywell řady 5000, proto veškerá softwarová podpora, která je součástí těchto stránek, je vypracována právě pro tyto kontrolery. Pro uživatele jiných řídících systémů je vždy uveden alespoň obecný algoritmus vysvětlující princip činnosti modulu, aby si k němu mohli sami napsat svůj ovladač.
warning Důležité:Popisované I/O moduly zpracovávají informaci ve formě analogového napětí a musí ho rozlišit s poměrně velkou přesností.
Je velmi snadné tuto informaci znehodnotit zavlečením cizího napětí do signálové smyčky. Je však také snadné tomu zabránit, pokud znáte a důsledně dodržujete
zásady pro připojování těchto přístrojů.

Opakovače a převodníky pro datové rozhraní RS485

Všechny naše přístroje z této kategorie jsou již léta úspěšně provozovány na sběrnici C-Bus fy Honeywell. Komunikace na sběrnici C-bus je charakteristická značnou netolerancí vůči timeoutům jednotlivých účastnických stanic a proto je klíčovou vlastností všech těchto přístrojů rychlá odezva. Lze tvrdit, že co funguje na C-Busu, to už funguje všude.
OP485
volitelně opakovač RS485 nebo adaptér RS232/RS485 bez galvanicého oddělení
OPG485
opakovač RS485 s galvanicky oddělenými obvody
OPGF - pro vyšší rychlosti
rychlejší varianta OPG485
BBM9600-modem se zpožděním 1Bd
modem 9600Bps pro nekomutovanou linku do 8 km
AG-Black - RS485/RS232
adaptér RS232/RS485 s galv.oddělenými obvody
AGF- pro vyšší rychlosti
rychlejší varianta AG-Blacku

TIP:

Pokud pracujete s výrobky fy Yorix a potřebujete "v terénu" nahlédnout do dokumentace, vyplatí se vám stáhnout si tyto stránky zkompilované do souboru standardní nápovědy os windows (yorix.chm). V jediném souboru je vše.

© Yorix s.r.o. Ing.Richard Trochta
Datum založení domény yorix.cz: 1998/05
Poslední aktualizace: 04.09.2009


YORIX-UDO4b

foto UDO4b (7 kbyte)

UDO4b

transformace 1AO đ 4 DO

princip funkce | zapojení svorek | technické parametry
software-submoduly XFM | nastavení modulu | připojení ke kontroleru | nejčastější závada

Použití:

Reléový modul UDO4b umožňuje transformovat jeden analogový výstup 0...10V libovolného kontroleru řady EXCEL 5000 na čtveřici plnohodnotných digitálních výstupů (16 možných stavů). Užití modulu zvyšuje mezní počet připojených akčních členů .

Princip funkce:

Od listopadu 2000 je tento modul dodáván s dvěma implementovanými režimy. Volba se provádí pomocí jumperu.

Základní režim UDO4b (původní-od uvedení na trh)

Jumper=OFF (=rozpojen; u UDO4b ani není součástí dodávky)
V principu se jedná o čtyřbitový A/D převodník s reléovými výstupy. Analogová váha nejvyššího bitu je zvolena 4.8V (odpovídá hodnotě 48% v programech CARE). Každý další bit má váhu rovnou poloviny předchozího, tedy 24, 12 a 6%. Každému z výstupů je přiřazen jeden bit, od nejvyššího bitu (výstup č.1) po nejnižší (výstup č.4). Řídící napětí pro ovládání modulu lze vyjádřit vztahem:

X[V] = K1*4.8 +K2*2.4 +K3 *1.2 + K4*0.6 + 0.3

kde proměnné K1...K4 mohou nabývat hodnot 0(=vypni) nebo 1 (=zapni)

offset Offset:
Konstanta 0.3V v předchozím výrazu představuje trvalý offset o velikosti jedné poloviny váhy nejnižšího bitu, sloužící k posunu řídícího napětí doprostřed mezi dvě rozhodovací úrovně pro zajištění max. stability výstupního stavu.

Všechny čtyři bity jsou tedy v aktivním stavu, pokud analogové řídící napětí má úroveň 4.8 + 2.4 + 1.2 + 0.6 + 0.3 = 9.3 V. Modul dále obsahuje pomocné obvody zabezpečující jeho korektní chování i v přechodných stavech, konkrétně těsně po připojení napájecího napětí a během změny vstupního řídícího napětí.

Popis celého procesu transformace 1AO ® 4 DO:

  1. Čtyři požadované DO jsou definovány v CARE jako dat. body typu VD
  2. Softwarový převodník D/A ( zde submodul XFM : udo4b.csd) zakóduje stav čtyř VD do analogové informace (viz.výraz výše) a vyvede ji na AO kontroleru
  3. Analogová informace (napětí) se vyvede na modul UDO4b
  4. Reléový modul UDO4b převede analogovou informaci zpět na 4 DO (4-bitový A/D převod)

animace funkce UDO4b (12 kbyte)
příklad - viz.animace na obrázku (s kontrolerem Honeywell Excel řady 5000);
- změna VD vyvolaná aplikačním programem kontroleru je akce,
- stav relé je následující reakce

Doplňkový režim: čtyřstupňová kaskáda (od listopadu 2000)
deska TR027 (1997..2005)
deska tr027 (1997..2005) 		deska TR040 (od r.2006)
deska TR040 (od r.2006)

Jumper=ON (propojen)(Na obrázcích je vyznačen červeně.)

V tomto režimu funguje UDO4b jako čtyřstupňová kaskáda řízená napětím O...10V s postupným spínáním relé, viz. převodová charakteristika na obr. níže. Relé spínají postupně zprava doleva, tedy nejprve K4,pak K3,K2 a nakonec K1. Hystereze je 1,2V, krok mezi sepnutím dvou relé je 1,8V.

převodová charakteristika kaskády
Přínosem tohoto režimu je, že nepotřebuje ovládání XFM submodulem, ale pouze spojitým analogovým signálem 0...10V, např. jakýmkoli PID a neomezuje se na použití s volně programovatelným automatem.
Pozn.: Použitím rozpínacích kontaktů lze charakteristiku obrátit na postupné odpínání.

Stav každého ze čtyř reléových výstupů je indikován diodou LED.

Zapojení svorek:

štítek přístroje (3 kbyte)

je patrné z vyobrazeného štítku přístroje. Na horní straně přístroje jsou 3 svorky pro připojení napájecího napětí 24V a řídícího napětí z kontroleru. Napájecí napětí 24V může být jak stejnosměrné, tak střídavé. Přístroj obsahuje jednocestný usměrňovač. Svorka 24V_GND je společná pro napájení i řídící signál (ground).

Důležité ! - pozor na kombinaci můstkového a jednocestného usměrňovače
Na dolní straně přístroje je 12 svorek pro kontakty relé.

Technické parametry

Napájecí napětí 20÷35V= nebo 16÷24V ~
Oteplení přístroje je úměrné napájecímu napětí! -viz. pozn.níže
Odběr ze zdroje 24V | 40÷100mA (podle počtu sepnutých relé)
Dovolený rozsah řídícího napětí | 0÷12 V=
Doporučený rozsah řídícího napětí | 0÷9.3 V=
Požadovaná rychlost přeběhu řídícího napětí | z 0 do 10 V za < 1 sec.
Vstupní odpor svorky řídícího napětí | > 25 kW
Výstup: 4 x přepínací kontakt 24 V~ / 2 A
Ochrana před nebezpečným dotykem živých a neživých částí (ČSN332000-4) | bezp.malým napětím:SELV
Doporučené prostředí (ČSN 33 2000-3) | třída AB4 (-5...40°C, 5...95% rel.vlhkosti)
Přípustné skladovací podmínky | -15...70°C, 5...95% rel.vlhkosti
Rozměry: rozměrový náčrtek přístroje (3 kbyte)
Pozn: Při napájení střídavým napětím dosahuje po usměrnění a filtraci vnitřní napětí přístroje téměř vrcholové hodnoty střídavého napájecího napětí. Proto je povolený rozsah napájecího napětí u AC hodnot zhruba 1,4 krát nižší, než u DC.
Oteplení přístroje je nejvíce ovlivňeno velikostí napájecího napětí a počtem sepnutých relé. Je proto vhodné:
  • pokud možno volit napájecí napětí v nižší polovině dovoleného rozsahu
  • kombinovat v modulu dvoustavové výstupy a pohony ventilů (ovládání ventilu spíná jen krátkodobě jedno ze dvou relé)

Software - Submoduly XFM

Pozn:
V následující tabulce budete přesměrováni na popis submodulů pro UDO6.
UDO4 berte při výkladu funkce jako podmnožinu UDO6 (odpadají poslední výstupy, pro které UDO4b již nemá relé).

Název a popis | funkce | download všech XFM submodulů, V 2.1 download
UDO4b.csd | čtyři digitální výstupy (4* VD)
UO4_1V2D.csd | jeden 3-bod.ventil + dva DO (1*VA + 2*VD)
UO4_2V.csd | Dva 3-bod.ventily (2*VA)
UDO6_MPX.csd (společný pro UDO4 i UDO6) | Postupné načtení 4 analog. čidel jedním AI

Nastavení modulu UDO4b

Žádné nastavování !

Je zcela zbytečné a vede k rozladění modulu.
  • Přístroj je velmi pečlivě nastaven z výroby. Velikost napěťového segmentu 600mV (6% napěťového rozsahu AO kontroleru) poskytuje dostatečně velkou toleranci k tomu, aby se do ní bezpečně vešel reléový modul i AO kontroleru bez nutnosti vzájemného seřizování.
  • Nastavení z výroby (pozice jezdce trimru) je vyznačeno fixem na plášti trimru. Po neoprávněné nebo nevhodné manipulaci stačí zpravidla vrátit jezdce trimru zpět na značku.
  • Nastavení je s časem stabilní (nedochází ke změně stárnutím), pokud se chování přístroje začne měnit, je chyba jinde; změna nastavení nic neřeší.
Pozn.:
Nová řídící deska TR040 již nastavování ani neumožňuje. Kalibrace A/D převodníku je provedena při výrobě, kalibrační konstanta je zapsána ve flash paměti mikroprocesoru.

© YORIX s.r.o., Ing.Richard Trochta, 7.2.2006


UDO6

transformace 1AO đ 6DO

princip funkce: režimy UDO6 a UDO6b rozložení svorek na přístroji

technické parametry

software: submoduly XFM

montáž

připojení ke kontroleru

obvyklé závady

Použití:

Reléový modul UDO6 umožňuje transformovat jeden analogový výstup 0...10V libovolného kontroleru řady EXCEL 5000 na šestici vzájemně nezávislých digitálních výstupů, nebo např. tři 3-bodové regulační ventily. Pro usnadnění práce aplikačního programátora je zdarma k dispozici řada submodulů XFM.
Stav každého ze šesti reléových výstupů je indikován diodou LED.

Princip funkce:

Od 15.10.1998 je modul UDO6 expedován v novém provedení:
dva volitelné režimy - UDO6 / UDO6b.

Přepínání mezi oběma režimy se provádí prostřednictvím kolíkové lišty a jumperu (na obr. rudý) umístěného na řídící desce. Deska je přístupná po sejmutí krytu se štítkem. Každý režim nutně vyžaduje odpovídající XFM submoduly!

Režim UDO6 (původní 6-bitový-neperspektivní)
deska TR027 (1997..2005)
deska tr027 (1997..2005) 		deska TR040 (od r.2006) deska TR040 (od r.2006)

Jumper=ON (propojen)(Na obrázcích je vyznačen červeně.)

V principu 6-bitový převodník đ musí rozlišit 26 = 64 možných stavů. Napětí 0...10V je rozděleno na 64 segmentů po 150 mV. Toto rozlišení již klade velmi vysoké nároky na přesnost a "čistotu" řídícího signálu.
K zajištění správné funkce je proto naprosto nezbytné dodržení zásad pro rozvod vodiče GND v rozvaděči.

Režim UDO6b (nový - 4-bitový) doporučený

Jumper = OFF (rozpojený)

V principu 4-bitový převodník (16 napěťových segmentů po 600mV), který potřebnou 6-bitovou informaci přenáší nadvakrát; V lichých cyklech programu je nastavována jedna trojice relé, v sudých cyklech druhá, a to následovně: tři významnější bity čtyřbitového slova modifikují trojici relé, nejméně významný bit určuje, která z obou trojic relé má být modifikována. (jeho hodnota {0,6V} je zakomponována v konstantě na konci první z níže uvedených rovnic; konstanta 0,3V je v obou rovnicích a představuje offset pro optimalizaci pracovního bodu)

Přednosti:

-Výrazně spolehlivější funkce (čtyřnásobně vyšší odolnost vůči napěťovým chybám a rušení)

Algoritmus řízení modulu
lze vyjádřit matematickým výrazem:

     U = K1*4,8 + K2*2,4 + K3*1,2 + K4*0,6 + K5*0,3 + K6* 0,15 + 0,075

kde: K1..K6 = požadovaný stav jednotlivých relé (1=sepnout, 0=vypnout)

Offset:
Konstanta 0,075 na konci předchozího výrazu představuje trvalý offset pro otimalizaci pracovního bodu. Její význam je vysvětlen v popisu přístroje UDO4b.
Algoritmus řízení modulu
lze vyjádřit matematickými výrazy:

Ovládání první trojice relé: 	U1 = K1*4,8 + K2*2,4 + K3*1,2 + 0,9
Ovládání druhé trojice relé: 	U2 = K4*4,8 + K5*2,4 + K6*1,2 + 0,3

kde: K1..K6 = požadovaný stav jednotlivých relé (1=sepnout, 0=vypnout)

Napětí U1 a U2 se musí cyklicky střídat, každé napětí musí zůstat držet alespoň 1 sec.

Rozložení svorek:

štítek UDO6 (1.7 kbyte)

je patrné z vyobrazeného štítku přístroje. Na horní straně přístroje jsou 3 svorky pro připojení napájecího napětí 24V a řídícího napětí z kontroleru. Napájecí napětí 24V může být jak stejnosměrné, tak střídavé (přístroj obsahuje jednocestný usměrňovač). Svorka 24V_GND je společná pro napájení i řídící signál (ground).

Důležité !
pozor na kombinaci můstkového a jednocestného usměrňovače

Na dolní straně přístroje je 12 svorek pro kontakty relé.

Technické parametry
Napájecí napětí20...35V= nebo 16...24V ~
Oteplení přístroje je úměrné napájecímu napětí! -viz.pozn.níže
Odběr ze zdroje 24V | 40...135mA (podle počtu sepnutých relé)
Dovolený rozsah řídícího napětí | 0...12 V=
Doporučený rozsah řídícího napětí | 0...9,55 V=
Požadovaná rychlost přeběhu řídícího napětí | z 0 do 10 V za < 1 sec.
Vstupní odpor svorky řídícího napětí | > 25 kW
Výstup:6 x spínací kontakt 24 V~ / 2 A
Ochrana před nebezpečným dotykem živých a neživých částí (ČSN332000-4) | bezp.malým napětím:SELV
Doporučené prostředí (ČSN 33 2000-3) | třída AB4 (-5...40°C, 5...95% rel.vlhkosti)
Přípustné skladovací podmínky | -15....70°C, 5...95% rel.vlhkosti
Rozměry: náčrtek přístroje (3 kbyte)
Pozn: Při napájení střídavým napětím dosahuje po usměrnění a filtraci vnitřní napětí přístroje téměř vrcholové hodnoty střídavého napájecího napětí. Proto je povolený rozsah napájecího napětí u AC hodnot zhruba 1,4 krát nižší, než u DC.
Oteplení přístroje je nejvíce ovlivňeno velikostí napájecího napětí a počtem sepnutých relé. Je proto vhodné:
  • pokud možno volit napájecí napětí v nižší polovině dovoleného rozsahu
  • kombinovat v modulu dvoustavové výstupy a pohony ventilů (ovládání ventilu spíná jen krátkodobě jedno ze dvou relé)

Software - Submoduly XFM

Všechny submoduly jsou aktualizovány v lednu 1999 (verze 2.1) Preferujte režim UDO6b - je odolnější!

Popis funkce submodulů XFM:
Režim UDO6 (jumper=ON) | funkce | Režim UDO6b (jumper=OFF)
UDO6.csd | šest digitálních výstupů (6* VD) | UDO6b.csd

UO6_1V4D.csd

jeden 3-bod.ventil + čtyři DO (1*VA + 4*VD)

UO6b1V4D.csd

UO6_2V2D.csd

dva 3-bod.ventily + dva DO (2*VA + 2*VD)

UO6b2V2D.csd

UO6_3V.csd

Tři 3-bod.ventily (3*VA)

UO6b3V.csd

UDO6_MPX.csd

Postupné načtení 6 analog. čidel jedním AI

UO6b_MPX.csd (říjen 99)

Download všech submodulů XFM, verze 2.1 (leden 99, říjen 99)

Předpis pro připojení a montáž

zavěšením na Din lištu. Moduly v případě zapojení podle varianty 2 (společné trafo) , resp.3 (interní zdroj) následujícího textu umístit co nejblíže ke kontroleru.

Připojení ke kontroleru

Pro zajištění spolehlivé funkce přístrojů je nutné znát a dodržovat zásady pro jejich připojování ke kontroleru!

© YORIX s.r.o., Ing. Richard Trochta, 02.02.2010


2P10-3

schema ovládání dvou 3b.ventilů (5 kbyte)

2P10/3 - reléový modul pro ovládání dvou 3stav.ventilů

princip funkce zapojení svorek

technické parametry

software

Použití:

Modul umožňuje připojit ke kontroleru Excel řady 5000 dva tříbodové servopohony tak, že simulují servopohony se spojitým ovládáním 0...10V.
K simulaci spojitého řízení 0...100% se přitom využívá standardní firmware citovaných kontrolerů fy Honeywell.

Hodí se všude, kde je z jakéhokoli důvodu použit třístavový servopohon. Tímto důvodem zpravidla bývá nižší cena kombinace tohoto modulu s třístavovým pohonem oproti pohonu se spojitým řízením.

Princip funkce:

Modul obsahuje (z důvodu plného využití plastové skříňky) dva samostatné, rovnocenné převodníky.
Každý z obou vestavěných převodníků sestává z napěťových komparátorů, ovládajících relé pro akční zásah "více" , resp. relé pro akční zásah "méně" podle následující tabulky:
0-2.5V | neutrální poloha
3-4.5V | poloha “méně”, relé K1 , zelená dioda LED
5-7V | neutrální poloha
7.5-10V | poloha “více”, relé K2 , rudá dioda LED

Uvedené napěťové úrovně respektují firmware firmy Honeywell, který je využíván kontrolery Excel 500, 100, 80, 50 a 20 pro přímou realizaci třístavových výstupů . Převodník se proto chová stejně, jako tříbodová část modulu Honeywell MCD3.
(Může však být použit pro kterýkoli volně programovatelný regulátor mající analogový výstup 0...10V; podmínkou je však vytvoření vlastního softwaru pro simulaci spojitého pohonu).

Zapojení svorek:

štítek přístroje (4 kbyte)

je patrné z vyobrazeného štítku přístroje. Na horní straně přístroje jsou 4 svorky. Krajní svorky slouží pro připojení napájecího napětí 24V, vnitřní dvě svorky (X1, X2) jsou "živé" svorky pro řídící napětí servopohonů. Čtvrtá svorka - 24V_GND je společná pro napájení i oba řídící signály (ground).

Napájecí napětí 24V může být jak stejnosměrné, tak střídavé, modul obsahuje jednocestný usměrňovač. Důležité ! - pozor na kombinaci můstkového a jednocestného usměrňovače

Na dolní straně přístroje je 12 svorek pro kontakty relé.

Funkce jednotlivých relé (pořadí dle vyobrazení na štítku přístroje):
K1.2 | Otvírá Ventil_1
K1.1 | Zavírá Ventil_1
K2.2 | Otvírá Ventil_2
K2.1 | Zavírá Ventil_2

Technické parametry

Napájecí napětí | 20...35V= nebo 16...24V ~
Odběr ze zdroje 24V | Max 60mA (podle počtu sepnutých relé)
Dovolený rozsah řídícího napětí | 0...12 V=
Doporučený rozsah řídícího napětí | 0...10 V=
Vstupní odpor svorky řídícího napětí | > 10 kW
Výstup: | 2x2 relé, každé s přepínacím kontaktem 24 V~ / 2 A
Ochrana před nebezpečným dotykem živých a neživých částí (ČSN332000-4) | bezp.malým napětím:SELV
Doporučené prostředí (ČSN 33 2000-3) | třída AB4 (-5...40°C, 5...95% rel.vlhkosti)
Přípustné skladovací podmínky | -15....70°C, 5...95% rel.vlhkosti
Rozměry: | rozměrový náčrtek přístroje (3 kbyte)

Software

(pro kontrolery Honeywell Excel 5000)

konfigurace fyzického výstupu (7 kbyte) Ve verzi Care 1.4.1 a vyšší není potřeba vytvářet žádný obslužný sw.

Stačí ve schematickém popisu datových bodů specifikovat výstup jako tříbodový (viz.obr), v editoru uživatelských adres je pak ještě nutno zadat přestavnou dobu otvírání a zavírání použitého ventilu.

Při splnění těchto podmínek využívá centrála svůj vlastní obslužný program (firmware), který si vypočítává a řídí potřebný čas k přestavení ventilu z původní polohy do nově vypočtené a poměrně věrně tak simuluje pohon se spojitým řídícím signálem. Firmware dokáže sepnout relé na libovolně krátkou dobu (narozdíl od submodulů XFM není doba sepnutí zdola limitována dobou jednoho cyklu aplikačního programu) a dokáže proto dobře řídit i ventily s krátkou celkovou přestavnou dobou.

© YORIX s.r.o., Ing. Richard Trochta 15.2.1999


YORIX-UDI6

foto UDI6 (9 kbyte)

UDI6

transformace 1AI đ 6DI

nové provedení (2006)

princip funkce | zapojení svorek | nastavení vlastností pomocí jumperů | technické parametry
software- submoduly XFM |  | Připojení ke kontroleru | Připojení čidel
dokumentace ke starému provedení (1995..2005)

Použití:

Modul UDI6 umožňuje načíst až šest vstupních veličin typu DI jedním analogovým vstupem libovolného volně programovatelného DDC automatu. Vlastně tím přemění jeden analogový vstup kontroleru na šestici digitálních vstupů. Předpokládá se užití jen takových vstupních signálů, u nichž dochází ke změně stavu v dlouhých časových intervalech (>10sec). Nejběžnější použití modulu bývá k indikaci poruchových stavů.

Princip funkce:

Stav šesti digitálních vstupů se převede v modulu UDI6 prostřednictvím šestibitového převodníku na analogovou informaci (napětí). Toto napětí se přivede do analogového vstupu kontroleru.
Pak stačí, aby sw aplikace kontroleru převedla analogovou informaci zpět na šestici digitálních hodnot.

Nejvyšší bit má váhu 48% (4.8V), další pak vždy polovinu předchozího.
Napěťová rozlišovací úroveň modulu (váha nejnižšího bitu) je 150mV.
Všechny vstupní svorky se spínají (buďto kontaktem, nebo tranzistorem s otevřeným kolektorem) proti společné svorce GND.
Aktivní stav (volitelně NO nebo NC, viz. Jumper1) každého digitálního vstupu modulu se na výstupní svorce přístroje projeví příslušným váhovým napětím, pasivní stav DI má na výstupu nulovou odezvu.
Je-li tedy všech 6 vstupů modulu v aktivním stavu, bude na výstupu přístroje napětí:

4.8 + 2.4 + 1.2 + 0.6 + 0.3 + 0.15 = 9.45 V

Modul musí rozlišit 26 = 64 možných stavů.

Toto napětí je pak potřeba vyhodnotit (převést zpět na šestici binárních hodnot) softwarem kontroleru.

Provedení, zapojení svorek:

štítek přístroje (2 kbyte)

je patrné z vyobrazeného štítku přístroje. Na horní straně přístroje jsou 3 svorky pro připojení napájecího napětí 24V a výstupního napětí pro kontroler. Napájecí napětí 24V může být jak stejnosměrné, tak střídavé. Svorka 24V_GND je společná pro napájení i řídící signál (ground).

Horní strana přístroje nově obsahuje ještě šestici žlutých LED k indikaci stavu DI. (r.2006)
LED svítí, když DI vyvolá příslušné váhové napětí na analogovém výstupu (viz Jumper1 níže)

Na dolní straně je 12 svorek pro šestici DI.

Volba parametrů digitálních vstupů pomocí jumperů :

Nové provedení přístroje (od 2Q r. 2006) umožňuje modifikovat význam a funkci šestice digitálních vstupů následovně:

jumpery
  • Jumper1: volba režimu NO/NC (zvolený režim platí pro všech šest digitálních vstupů)

    "Jumper1=ON" -> režim NC(normally closed) : sepnutý kontakt externího čidla nezpůsobí napěťovou odezvu na analogovém výstupu UDI6 (je pasivní). Odezva příslušné velikosti nastane po rozepnutí kontaktu.

    Jumper1="OFF" -> režim NO(normally open) : zde naopak rozepnutý kontakt externího čidla nezpůsobí napěťovou odezvu na analogovém výstupu UDI6. Odezva příslušné velikosti nastane po sepnutí kontaktu.

  • Jumper2: v pozici "ON" zrcadlově obrací původní význam vstupů. (jejich napěťovou váhu)
    DI1..DI6 jsou pak řazeny zleva doprava, obdobně jako je tomu u reléových výstupů DO1..DO6 modulu UDO6.
    První vstup zleva má pak váhu 4,8V a submodul XFM ho vyhodnotí jako DI1... Kdo si již navykl na LED diody u UDO6,ten tuto alternativu možná uvítá, bohužel pak nesouhlasí označení vstupů na štítku...

    pozn.:
    Jsou-li oba výše uvedené jumpery rozpojeny ("OFF"), chová se přístroj stejně, jako v původním provedení (1995..2005)
     Takto nastavený je přístroj také expedován.

Vysvětlivka k obrázku: pro jumpery je využit konektor sloužící k programování mikroprocesoru zaletovaného v desce. V levé části obrázku je popsán význam jednotlivých pinů konektoru při programování, v pravé části pak přiřazení jumperů za provozu přístroje.

pozn.1:
Test výstupního napětí- pokud se propojí piny SCK a MISO (7 a 9 - jumper nasvislo), pak na výstupu přístroje je napětí 9,45V (±20mV);simuluje tak aktivní úroveň všech šesti vstupů bez ohledu na jejich skutečný stav.

pozn.2:
V horní polovině desky je ještě jeden Jumper (na tříkolíkové liště). Ten slouží k přepnutí signálu (analogové napětí nebo data RS232) na výstupní svorku. Standardně jsou propojeny levé dva piny, pravý pin (pro RS232) je zatím pouze rezerva pro budoucí využití. Tento jumper je také nutný ke kalibraci přístroje.

Připojení UDI6 ke kontroleru

Drátovací předpis:

warning Pro správnou funkci modulu je nutné minimalizovat vliv cizího napětí, které vzniká na odporu vodiče GND mezi kontrolerem a modulem UDI6 průchodem napájecího proudu. K omezení cizího napětí na neškodnou úroveň je nutné i dostačující:
  • minimalizovat odpor vodiče GND (vodič co nejkratší, dostatečný průřez (1,5mm), cestou žádné svorky ani pojistky !!!)
  • minimalizovat napájecí proud vodičem GND (samostatný vodič GND od kontroleru k UDI6, žádné pokračování k dalším přístrojům).
Podrobněji je tato problematika popsána u přístroje UDO6.

Pozor také na kombinaci můstkového a jednocestného usměrňovače- nutno prověřit vnitřní zapojení kontroleru!

Připojení čidel k UDI6

štítek přístroje (2 kbyte) Na dolní straně přístroje je 12 svorek pro šestici digitálních čidel. Čidla jsou na štítku přístroje znázorněny jako kontakty K1÷K6. Předpokládá se přitom, že čidla mají buďto přímo kontaktní výstupy (viz štítek), nebo mají výstupy s tranzistorem NPN s otevřeným kolektorem, který spíná proti zápornému napájecímu napětí (viz. obr. vedle). | připojení s tranzistorem NPN
Složitější, leč také řešitelná situace nastává u čidel s tranzistorem PNP, spínajícím proti kladnému napájecímu napětí.Tam je třeba doplnit kolektorový zatěžovací odpor vhodné velikosti do vstupních svorek UDI6. Pořadavkům UDI6 i proudovým možnostem čidla by měla vyhovět hodnota zatěžovacího odporu v rozpětí od 1k do 10k. | připojení s tranzistorem PNP

Technické parametry

Napájecí napětí | 15..35V= nebo 12..24V ~
Odběr ze zdroje 24V | 40mA
Rozsah výstupního napětí | 0÷9.45 V= (podle počtu vstupů v aktivním stavu)
Závislost změny výst.napětí na teplotě | max. ±1mV/1ºC při výst. napětí 9.45V
Vstupy: | 6 x kontakt nebo tranzistor s otevřeným kolektorem
Odpor vstupních svorek jedn.dig.vstupů | > 10 kW
Ochrana před nebezpečným dotykem živých a neživých částí (ČSN332000-4) | bezp.malým napětím:SELV
Doporučené prostředí (ČSN 33 2000-3) | třída AB4 (-5...40°C, 5...95% rel.vlhkosti)
Přípustné skladovací podmínky | -15...70°C, 5...95% rel.vlhkosti
Rozměry: | rozměrový náčrtek přístroje (3 kbyte)

Software - Submoduly XFM

pozn:
Tato kapitola se týká pouze kontrolerů Honeywell řady EXCEL5000.

Programátoři ostatních kontrolerů

zde mají alespoň návod: (Algoritmus zpětného převodu ve formě vývojového diagramu) Tento algoritmus je použit v submodulech XFM. Pokud by si váš kontroler dokázal přebrat číslo typu integer na jednotlivé bity, pak je algoritmus převodu velmi jednoduchý:
je to celočíselný výsledek výrazu ( Ui[mV] + 75 ) / 150 v binárním tvaru; (75mV je offset popsaný ve vývojovém diagramu)

příklad pro Ui=5,4V :
(5400 + 75)/150 = 36 = 0b100100

Submoduly XFM

Oba uvedené submoduly jsou určeny k použití s hw modulem UDI6. Rozdíl v jejich použití je popsán níže.

Název | Funkce | Download
UDI6.csd | Šest digitálních vstupů (6* VD) | xfm2000.zip (říjen 99)
UDI5.csd | Pět digitálních vstupů (5*VD)

Submodul UDI6.csd

Použití submodulu XFM UDI6.csd - jeho připojení v sekci "Control strategy":
xfm 1. Analogový vstup submodulu - vstup "inp" submodulu se připojí na fyzický vstup kontroleru (viz. obr.: - modrá čára)

2. šestice digitálních výstupů submodulu
- kliknout na tlačítko “datapoints...” (viz. obr.) - otevře se seznam šesti virtuálních datových bodů
- kliknout na tlačítka “set” a "OK" ; datové body ze seznamu se automaticky umístí do volných polí dolní lišty sekce “control strategy”, kde je lze dle potřeby přejmenovat (klávesou F5).

Všech šest bodů je rovnou i připojeno, pouze toto připojení není graficky zobrazeno.

Submodul UDI5.csd

Pokud není k modulu UDI6 připojeno všech 6 vstupů, je lépe použít XFM submodul UDI5.csd. Narozdíl od UDI6.csd je ve schematu sekce "Control strategy" vidět připojení všech vývodů ze submodulu a projekt je přehlednější.
Omezení počtu vstupů modulu UDI6 přináší také zvýšení funkční spolehlivosti (odolnosti vůči cizím a chybovým napětím = vůči nedisciplinovanému rozvodu GND). Toho lze dosáhnout nevyužitím vstupů s nejnižší vahou při odpovídající úpravě ofsetu (parametru č.2):

Počet použitých vstupů | Vynechané vstupy | Ofset [%] (par.2)
5 | DI6 | 1,5
4 | DI6, DI5 | 3

Pozn:
Úprava ofsetu je sice možná i u submodulu UDI6.csd, ale v aplikaci, která jej používá, nelze smazat nepoužité datové body (jsou k němu nevratně připojeny příkazem SET). Tyto body se pak zbytečně objevují v seznamu bodů typu VD.

Submodul UDI5.csd má svých pět výstupů provedeno klasicky (jako vývody z ikony XFM - viz. obr.), případný nepoužitý výstup z ikony se prostě nikam nezapojí.

ÓYORIX s.r.o., Ing. Richard Trochta, 15.2.1999, poslední úprava 15.5.2006


OP485

Opakovač RS485
nebo
adaptér RS485/RS232
(bez galvanického oddělení)

Technické údaje | použití | volba funkce
provedení | Napájení | přenosová rychlost

Technické údaje:

rozsah přenosové rychlosti: | 4800...19200 Bd bez nastavování volby rychlosti
vstupní odpor: | 14kW (lze cca 10x paralelně; např.uzel hvězd.sítě)
výstupní odpor : | 200W (pouze při přenosu dat, jinak 3.stav)
přepínání směru toku dat: | automatické - odvozené od start bitu
zpoždění přenosu: | max. 0,5 baudu - podle zkreslení signálu
způsob vyhodnocení signálu: | komparátor (=bez vzorkování a časové refreshe)
přepěťová ochrana: | měkká (podélně R=47W, příčně transil) v obou směrech RS485
napájecí napětí: | 24...35V= nebo 20...24V~
galvanické oddělení: | pouze napájení 24V od elektroniky opakovače
indikace toku dat: | světelná-diody LED v obou směrech
rozměry: | rozměrový náčrtek

Použití:

Uvedený modul může pracovat v jednom z následujících dvou režimů:
opakovač na lince sériového rozhraní RS 485 (např. C-Bus pro komunikaci kontrolerů Honeywell řady 5000 a graf.centrály XBS, XBSi). Přenos signálu C-busu je elektrickými parametry kabelu omezen na délku segmentu cca 1.2 km. Opakovač vřazený do linky na hranici max. délky segmentu zopakuje přečtená data ( téměř bez čas. prodlevy!) a umožní tak přenos dat do dalšího délkového segmentu. (lze zopakovat 3÷4 x; přístroj pracuje pouze jako komparátor, nekoriguje šířku baudu, tato chyba se postupně kumuluje).

Pozn.:
Omezení počtu opakovačů na 4 není definitivní; opakovače OPG485 a OY485 umí napravit popisovanou chybu; provádí časovou korekci šířky baudu. Pokud je tedy některý z nich včas vložen do linky, obnoví signál do výchozího tvaru a lze za ním opět použít opakovače OP485. Minimální časové zpoždění všech opakovačů fy Yorix (vždy méně než 1 baud) umožňuje takto kombinované řazení v počtu až několika desítek ks.

Vždy je nutno dodržet polaritu vodičů; při měření linky C-Busu DC-voltmetrem se svorka A vůči svorce B vždy jeví jako kladná (4÷5V).

Použití přístroje v tomto režimu dnes již pozbývá významu, novější opakovač OPG485 jej svými vlastnosti značně překonává.

adaptér RS485/RS232 umožňující mj. připojení baseband modemu (dále jen BBM) s rozhraním RS232 do C-busu. Je-li potřeba převést C-bus linkou na vzdálenost větší, než 1.2 km a není možnost vřadit do linky opakovače, nezbývá než použít BBM s dosahem cca 10 km. (BBM: Nokia BB-2W typ DS 60120.)

Řešení s BBM je však vždy již pouhý kompromis, až ta poslední možnost!

Modem vnáší do přenosu již citelné zpoždění (cca 25bd). Absolutním limitem, který ještě C-bus snese, je kaskáda dvou modemových linek.

Značné problémy může způsobit také provozování více modemových linek paralelně, zejména je-li na jejich vzdálených koncích více stanic. Problém nastává hned na počátku komunikace při přihlašování stanic; časové zpoždění způsobuje, že stanice na konci dvou různých linek BBM se navzájem "slyší" se zpožděním, v důsledku toho se zpravidla pokusí přihlásit více stanic najednou (z každé linky jedna; sběrnice se jim jeví volná).

Při malém počtu stanic dochází ke znehodnocení určitého procenta ze všech paketů, postupným zvyšováním počtu stanic dojde až k úplnému zhroucení komunikace.

Volba funkce

Výběr pracovního režimu (opakovač / adaptér) se provádí jumperem pod dolním krytem svorkovnice.
(viz.nasvícená část dole uprostřed na vedlejší fotografii)

jumper Volba režimu je naznačena též na štítku přístroje.

Způsob sejmutí krytu je naznačen na animovaném obr. u OPG 485.

Provedení:

rozměrový náčrtek

Opakovač je zabudován do plastové skříňky Modulbox 4M předurčené k montáži na lištu DIN. Všechny přívodní vodiče se připojují do šroubových svorek.

Napájecí napětí a signály z obou směrů jsou indikovány diodami LED.
štítek Na štítku přístroje je vyobrazeno blokové schema opakovače a popis svorek.
U všech svorek je šipkami vyznačen směr toku dat (významné zejména pro RS232).

Jak je patrno z blok. schematu na štítku přístroje, jsou svorky A,B umístěné vedle napájecích svorek využity v obou variantách použití přístroje, zatímco z pětice svorek na pravé straně přístroje je využita vždy jen příslušná část podle použití (= podle polohy propojky).
Přístroj nemá galvanické oddělení mezi oběma signálními cestami, důsledně je však provedeno galv. oddělení všech signálních svorek od obou svorek napájení 24V.

Obvod napájení 24V

- obsahuje můstkový usměrňovač s vyhlazovacím filtrem a následný pulsní měnič 70 kHz s feritovým toroidním transformátorem - toto provedení umožňuje napájet přístroj zdrojem téměř libovolného napěťového průběhu s efektivní hodnotou okolo 24V.
Galvanické oddělení napájecích obvodů od ostatních okruhů opakovače umožňuje připojit opakovač ke stejnému transformátoru, jako přístroj, který je s opakovačem propojen datovým okruhem bez obav ze vzniku nežádoucích smyček.
Vinutí feritového transformátoru jsou zkoušena mezi sebou přiloženým napětím 3.75kV, 50Hz po dobu 1 minuty.

Přenosová rychlost:

Opakovač pracuje na principu analogového komparátoru s operačním zesilovačem. Z toho důvodu nepotřebuje žádné nastavování (ani přenosové rychlosti ani počtu přenášených bitů v bytu). Dokáže pracovat v celém rozsahu přenosových rychlostí od 2400 do 19200 [Bd/sec] (včetně zcela nestandardních rychlostí).

©Yorix.s.r.o., Ing.Richard Trochta, 16.5.1999


AG Black

Adaptér RS232/RS485 s galvanicky oddělenými obvody

Technické údaje | použití | popis funkce
provedení | přepěťová ochrana | nastavení

Technické údaje:

přenosové rychlosti: | 2400,4800,7200,9600, 14400,19200,25600,28800 dip switch
zpoždění přenosu: | 0.5 …1 Bd podle míry zkreslení (zaoblení hran) vst. signálu
vstupní odpor: | 15kW
výstupní odpor : | 200W (pouze při přenosu dat, jinak 3.stav)
přepínání směru toku dat: (volba jumperem uvnitř skříňky) | 1.(jumper=off)-automatické, odvozené od start bitu 2.(jumper=on)-řízené ext.signálem (RTS) ze strany RS232
přepěťová ochrana: | (pouze rozhraní RS485) bleskojistka 20kA/20A, následná měkká ochrana s transilem
napájecí napětí: | 9V@; externí zdroj MV903UGS 230V~/ 9V,300mA= (GM-electronic č. 751-344), je součástí dodávky adaptéru
galvanické oddělení | 2kV (obě signální strany mezi sebou i proti napájení)
rozměry: | 90 * 65 * 41 mm foto

Použití

Obecně k převodu rozhraní RS232 / RS485 na fyzické vrstvě protokolu. Stolní provedení spolu s galvanicky oddělenou (optickou) vazbou mezi oběma rozhraními jej předurčuje k bezpečnému propojení sériového rozhraní COMx počítačů PC se sběrnicí RS485. Volba způsobu řízení směru toku dat (jumper) umožňuje přizpůsobení prakticky libovolné PC aplikaci.

Popis funkce

Přístroj umožňuje volit jeden ze dvou režimů, podle způsobu řízení směru toku dat.
Volba se provádí jumperem, umístěným uvnitř přístroje (rudý obdélník uprostřed fotografie).
Jak zvolit režim popisuje kapitola nastavení-volba režimu.

1. Režim automatického přepínání směru toku dat (jumper=off)

  • V klidovém stavu jsou obě komunikační strany adaptéru přepnuty do režimu čtení.
  • V okamžiku příchodu dat z některé strany přepne adaptér protilehlou stranu na zápis a data odesílá. Každý baud vzorkuje v jeho předpokládaném středu (odvozeno od sestupné hrany start bitu), zjištěnou logickou úroveň okamžitě odesílá na výstupní straně s ostrými hranami a definovanou šířkou pulsu.
  • Po ukončení přenosu přechází adaptér opět do režimu monitorování obou signálních stran. V intervalu prvních 2 baudů bezprostředně po skončení přenosu je povolen přenos dat pouze směrem posledního uskutečněného přenosu, poté smí být přenos uskutečněn kterýmkoli z obou směrů.

    Pozn.: Nezávislost na řídících signálech:
    Zatímco v éře DOSu bylo použití sériového portu bez řídících signálů nemyslitelné (přinejmenším propojky), od doby Windows98 je situace naprosto odlišná.
    Celá řada PC aplikací si dnes vystačí s třemi vodiči sériového portu: (RxD,TxD,GND) - řídící signály nepotřebuje, ovšem často ani negeneruje. V takovém případě je schopnost adaptéru automaticky řídit směr toku dat naprosto nezbytná!

2. Režim řízení směru toku dat externím signálem (RTS) ze strany RS232 (jumper=on)

  • Přenos dat směrem RS232->RS485 je zde podmíněn externím signálem RTS (=napětím logické úrovně H (+9V) na pinu 8 konektoru CANNON9). Ostatní vlastnosti jsou shodné s prvním režimem.
    Pokud PC aplikace signál RTS negeneruje, data směrem RS232->RS485 neprojdou! S řadou nových aplikací proto tento režim nefunguje (viz.pozn.výše).

    Pozn.: Závislost na řídícím signálu RTS:
    Volba tohoto režimu je nutná při použití adaptéru u PC s grafickou centrálou Honeywell XBS. Centrála XBS pravidelně vysílá na TxD kromě datových paketů ještě sérii několika bajtů 0x00 při „shozeném" signálu RTS , které sice umožní užití signálu TxD jako zdroje napájení pro jednoduché přístroje připojené k portu, ale s vlastní komunikací nemají nic společného a nesmí projít na stranu RS485.

Bezpodmínečně nutné

je správně nastavit vlastnosti přenášených dat - přenosovou rychlost a celkový počet bitů v jednom přenášeném bajtu - viz. nastavení parametrů komunikace

Výstupní napětí na straně RS485 v klidovém stavu:

Svorka A má v klidu proti svorce B kladné napětí velikosti přibližně 0.5V. Ke stanovení polarity svorek na druhém konci kabelu toto napětí postačuje.

Provedení

foto

Adaptér je vestavěn do černé plastové skříňky rozměrů 65 * 41 * 90mm. Obsahuje tři konektory (viz. foto, zleva):

  1. napájecí (vidlice 2,1 mm) pro napájení z externího zdroje 9V
  2. 9-pin CANNON (zásuvka) pro RS232 ;adaptér je zařízení typu DCE (data communication equipment) đ Propojovací šňůra RS232 mezi PC a adaptérem musí mít na jednom konci zásuvku, na druhém vidlici a zajišťovat přímé spojení (minimálně propojení pinů 2-2, 3-3, 5-5, 8-8).
    Šňůru lze běžně zakoupit v prodejnách PC, je součástí dodávky adaptéru AG-Black.
  3. 3pin konektor pro RS485 –význam pinů zleva (od konektoru Cannon-viz foto) A(+), B(-), PE.
    Napájecí napětí a vysílané signály do obou směrů jsou indikovány diodami LED. Na štítku přístroje je vyobrazena tabulka nastavení přenosové rychlosti a počtu přenášených bitů. Štítek je na dolní straně skříňky.
Štítek přístroje je na spodní straně skříňky.

Význam LED diod

  • rudá - indikuje napájecí napětí
  • levá žlutá - indikuje tok dat směrem RS232 ï RS485
  • pravá žlutá - indikuje tok dat směrem RS232 đ RS485

facility

Příslušenství

  1. Externí zdroj MV903UGS 230V~ / 9V,300mA= (GM-electronic č. 751-344)
  2. Prodlužovací šňůra RS232 pro připojení k PC (propojí-li se oba konektory této šňůry do sebe, každý z 9 vodičů se uzavře do své vlastní smyčky.)
  3. Konektor pro připojení RS485

Galvanické oddělení

Přístroj obsahuje 2 navzájem galvanicky oddělené obvody:
  1. Společný obvod napájení 9V a rozhraní RS232 - obsahuje téměř celé elektronické vybavení adaptéru; můstkový usměrňovač s vyhlazovacím filtrem a stabilizátorem 5V, řídící obvody a budič RS232, dále pulsní měnič 70 kHz s feritovým toroidním transformátorem pro napájení strany RS485.
  2. Obvod sběrnice RS485 – obsahuje budič sběrnice, přepěťovou ochranu a vazební obvody galvanického oddělení

Vazba mezi galvanicky oddělenými obvody:

  1. napájení: indukční vazba - feritovým transformátorem s elektrickou pevností 2kV AC.
  2. řídící a datové signály: optická vazba - optrony s elektrickou pevností 2.5kV AC.
Nejmenší povrchová vzdálenost vodivých ploch na plošném spoji mezi galvanicky oddělenými obvody je 2mm , za sucha vyhoví zkoušce přiloženým napětím (2 kV, 50Hz, 1 minuta).

Přepěťová ochrana

schema přepěťové ochrany Je pouze na straně sběrnice RS485.
Schema zapojení je na obr.vpravo; První díl dvojité bleskojistky je zapojen přímo mezi svorky A a B. Druhý díl bleskojistky je zapojen mezi jednu datovou svorku a další, zcela samostatnou svorku, která je určena pro připojení na uzemnění nebo PE svorku silového rozvodu. V normálním stavu se neprojeví (R>50Mohm), při výskytu přepětí proti zemi omezí jeho velikost a tím také napěťovou zátěž obvodů v místě jejich galvanického oddělení.

Pin PE konektoru RS485:
Vzhledem k tomu, že rázová vlna od přímého či nepřímého účinku blesku nemá zpravidla výraznou velikost mezi piny A,B navzájem, ale právě proti zemi, je připojení tohoto pinu velmi důležité, zejména tam, kde sběrnice RS485 propojuje dva různé objekty (dvě různé budovy). Bleskojistka pak omezí na přijatelnou úroveň přepětí, které zatěžuje především galv.oddělovací obvody adaptéru a ohrožuje nejen samotný adaptér, ale i další přístroje za ním.

Elektronika adaptéru je pak ještě chráněna měkkou ochranou sestávající z rezistorů R1,R2 zapojených v obou větvích sběrnice a obousměrného transilu 5.8V (Vz1).

Nastavení parametrů komunikace (uvnitř skříňky)

Otevření skříňky - povolením jediného vrutu uprostřed její spodní strany.

Nastavení přenosové rychlosti (mini DIP switch)

Význam jednotlivých pozic spínačů je vyobrazen na štítku přístroje na spodní straně skříňky.

Dip spínače umožňují nastavit:

  • počet baudů na bajt (spínač.2) - devět nebo osm datových bitů na byte (v podstatě tedy přenos osmibitového slova s paritním bitem, nebo bez něho) Výraz "+2" na štítku přístroje(pokud tam je uveden) zahrnuje startbit a stopbit.
  • přenosovou rychlost (spínače 1,3,4) - jednu z přenosových rychlostí: 2400,4800,7200,9600,14400,19200,25600,28800

Pro C-bus Honeywell (kontrolery EXCEL řady 5000) je potřeba nastavit celkový počet baudů na 9+2 (8*data +parita, start,stop) a přenosovou rychlost shodně s rychlostí nastavenou v kontroleru.

Pozn:
Firmware adaptéru provádí pouze kontrolu počtu baudů mezi startbitem a stopbitem, nezajímá se o stav datových bitů ani parity. Aby tato kontrola vycházela úspěšně, je nutnou i postačující podmínkou správné nastavení přenosové rychlosti i počtu baudů

Nastavení - volba režimu řízení směru toku dat ( jumper uprostřed karty )

Vždy se jedná o přizpůsobení převodníku na konkrétní použitou PC aplikaci.
  1. JUMPER = OFF: Doporučený pracovní režim , přepínání směru toku dat si řídí AG-Black automaticky. Nepotřebuje k tomu žádné řídící signály, kabel RS232 si vystačí s 3 vodiči: RxD,TxD,GND.
    Kdy tento režim nefunguje: když PC aplikace užívá TxD ještě k jinému účelu, než je přenos dat k adresátovi (viz.další text).

  2. JUMPER = ON : (RTS_Control) Adaptér propustí pouze data stvrzená signálem RTS.
    Tento režim je nutný pouze při součinnosti s takovými PC aplikacemi, které na TxD vysílají nejen data určená k přenosu adresátovi (např. Honeywell XBS).
    PC aplikace pak signálem RTS určuje, která data mají pokračovat k adresátovi, a která naopak slouží pouze místnímu účelu (zdroj napájení, řídící povely pro modem apod.).
    Kdy tento režim nefunguje: U řady nových PC aplikací (po uvedení Windows98), které řídící signál RTS nenastavují. Pak je nutné jumper rozpojit!
Pozn.: Existují i takové PC aplikace, které fungují s oběma režimy; korektně nastavují řídící signály a současně na TxD vysílají pouze data pro adresáta. Jumper v takovém případě nemá na funkci sebemenší vliv.

Více informací viz. popis funkce

©Yorix.s.r.o., Ing.Richard Trochta, 4.4.2002


AGF - adaptér RS232 / RS485 pro vyšší přenosové rychlosti

foto

AGF

Adaptér RS232/RS485 s galvanicky oddělenými obvody
pro přenosové rychlosti 9600 ... 76800 Bd

Technické údaje | použití | popis funkce
provedení | přepěťová ochrana | nastavení

Technické údaje:

přenosové rychlosti: | 9600,14400,19200,28800,38400,57600,76800 dip switch
zpoždění přenosu: | 0.5 …1 Bd podle míry zkreslení (zaoblení hran) vst. signálu
vstupní odpor: | 15kW
výstupní odpor : | 200W (pouze při přenosu dat, jinak 3.stav)
přepínání směru toku dat: (volba jumperem uvnitř skříňky) | 1.(jumper=on)-automatické, odvozené od start bitu 2.(jumper=off)-řízené ext.signálem (RTS) ze strany RS232
přepěťová ochrana: | (pouze rozhraní RS485) bleskojistka 20kA/20A, následná měkká ochrana s transilem
napájecí napětí: | 9V@; externí zdroj MV903UGS 230V~/ 9V,300mA= (GM-electronic č. 751-344), je součástí dodávky adaptéru
galvanické oddělení | 1,5kV (obě signální strany mezi sebou i proti napájení)
rozměry: | 90 * 65 * 41 mm foto

Použití

Obecně k převodu rozhraní RS232 / RS485 na fyzické vrstvě protokolu. Stolní provedení spolu s galvanicky oddělenou (optickou) vazbou mezi oběma rozhraními jej předurčuje k bezpečnému propojení sériového rozhraní COMx počítačů PC se sběrnicí RS485. Volba způsobu řízení směru toku dat (jumper) umožňuje přizpůsobení prakticky libovolné PC aplikaci.

Popis funkce

Přístroj umožňuje volit jeden ze dvou režimů, podle způsobu řízení směru toku dat.
Volba se provádí jumperem, umístěným uvnitř přístroje (rudý obdélník uprostřed fotografie).
Jak zvolit režim popisuje kapitola nastavení-volba režimu.
Pozor- funkce jumperu je u AGF přesně opačná, než je u jeho "staršího bratříčka" AG-Blacku.

1. Režim automatického přepínání směru toku dat (jumper=on)

  • V klidovém stavu jsou obě komunikační strany adaptéru přepnuty do režimu čtení.
  • V okamžiku příchodu dat z některé strany přepne adaptér protilehlou stranu na zápis a data odesílá. Každý baud vzorkuje v jeho předpokládaném středu (odvozeno od sestupné hrany start bitu), zjištěnou logickou úroveň okamžitě odesílá na výstupní straně s ostrými hranami a definovanou šířkou pulsu.
  • Po ukončení přenosu přechází adaptér opět do režimu monitorování obou signálních stran. V intervalu prvních 2 baudů bezprostředně po skončení přenosu je povolen přenos dat pouze směrem posledního uskutečněného přenosu, poté smí být přenos uskutečněn kterýmkoli z obou směrů.

    Pozn.: Nezávislost na řídících signálech:
    Zatímco v éře DOSu bylo použití sériového portu bez řídících signálů nemyslitelné (přinejmenším propojky), od doby Windows98 je situace naprosto odlišná. Celá řada PC aplikací si dnes vystačí s třemi vodiči sériového portu: (RxD,TxD,GND) - řídící signály nepotřebuje, ovšem ani negeneruje. V takovém případě je schopnost adaptéru automaticky řídit směr toku dat naprosto nezbytná!

2. Režim řízení směru toku dat externím signálem (RTS) ze strany RS232 (jumper=off)

  • Přenos dat směrem RS232->RS485 je zde podmíněn externím signálem RTS (=napětím logické úrovně H (+9V) na pinu 8 konektoru CANNON9). Ostatní vlastnosti jsou shodné s prvním režimem.
    Pokud PC aplikace signál RTS negeneruje, data směrem RS232->RS485 neprojdou! S řadou nových aplikací proto tento režim nefunguje (viz.pozn.výše).

    Pozn.: Závislost na řídícím signálu RTS:
    Volba tohoto režimu je nutná při použití adaptéru u PC s grafickou centrálou Honeywell XBS. Centrála XBS pravidelně vysílá na TxD kromě datových paketů ještě sérii několika bajtů 0x00 při „shozeném" signálu RTS , které sice umožní užití signálu TxD jako zdroje napájení pro jednoduché přístroje připojené k portu, ale s vlastní komunikací nemají nic společného a nesmí projít na stranu RS485.

Bezpodmínečně nutné

je správně nastavit vlastnosti přenášených dat - přenosovou rychlost a celkový počet bitů v jednom přenášeném bajtu - viz. nastavení parametrů komunikace

Výstupní napětí na straně RS485 v klidovém stavu:

Svorka A má v klidu proti svorce B kladné napětí velikosti přibližně 0.5V. Ke stanovení polarity svorek na druhém konci kabelu toto napětí postačuje.

Provedení

foto

Adaptér je vestavěn do černé plastové skříňky rozměrů 65 * 41 * 90mm. Obsahuje tři konektory (viz. foto, zleva):

  1. napájecí (vidlice 2,1 mm) pro napájení z externího zdroje 9V
  2. 9-pin CANNON (zásuvka) pro RS232 ;adaptér je zařízení typu DCE (data communication equipment) đ Propojovací šňůra RS232 mezi PC a adaptérem musí mít na jednom konci zásuvku, na druhém vidlici a zajišťovat přímé spojení (minimálně propojení pinů 2-2, 3-3, 5-5, 8-8).
    Šňůru lze běžně zakoupit v prodejnách PC, je součástí dodávky adaptéru AG-Black.
  3. 3pin konektor pro RS485 –význam pinů zleva (od konektoru Cannon-viz foto) A(+), B(-), PE.
    Napájecí napětí a vysílané signály do obou směrů jsou indikovány diodami LED. Na štítku přístroje je vyobrazena tabulka nastavení přenosové rychlosti a počtu přenášených bitů. Štítek je na dolní straně skříňky.
Štítek přístroje je na spodní straně skříňky.

Význam LED diod

  • rudá - indikuje napájecí napětí
  • levá žlutá - indikuje tok dat směrem RS232 ï RS485
  • pravá žlutá - indikuje tok dat směrem RS232 đ RS485

facility

Příslušenství

  1. Externí zdroj MV903UGS 230V~ / 9V,300mA= (GM-electronic č. 751-344)
  2. Prodlužovací šňůra RS232 pro připojení k PC (propojí-li se oba konektory této šňůry do sebe, každý z 9 vodičů se uzavře do své vlastní smyčky.)
  3. Konektor pro připojení RS485

Galvanické oddělení

Přístroj obsahuje 2 navzájem galvanicky oddělené obvody:
  1. Společný obvod napájení 9V a rozhraní RS232 - obsahuje téměř celé elektronické vybavení adaptéru; můstkový usměrňovač s vyhlazovacím filtrem a stabilizátorem 5V, řídící obvody a budič RS232, dále pulsní měnič 70 kHz s feritovým toroidním transformátorem pro napájení strany RS485.
  2. Obvod sběrnice RS485 – obsahuje budič sběrnice, přepěťovou ochranu a vazební obvody galvanického oddělení

Vazba mezi galvanicky oddělenými obvody:

  1. napájení: indukční vazba - feritovým transformátorem s elektrickou pevností 2kV AC.
  2. řídící a datové signály: optická vazba - optrony s elektrickou pevností 1.5kV AC.
Nejmenší povrchová vzdálenost vodivých ploch na plošném spoji mezi galvanicky oddělenými obvody je 2mm , za sucha vyhoví zkoušce přiloženým napětím (2 kV, 50Hz, 1 minuta).

Přepěťová ochrana

schema přepěťové ochrany Je pouze na straně sběrnice RS485.
Schema zapojení je na obr.vpravo; První díl dvojité bleskojistky je zapojen přímo mezi svorky A a B. Druhý díl bleskojistky je zapojen mezi jednu datovou svorku a další, zcela samostatnou svorku, která je určena pro připojení na uzemnění nebo PE svorku silového rozvodu. V normálním stavu se neprojeví (R>50Mohm), při výskytu přepětí proti zemi omezí jeho velikost a tím také napěťovou zátěž obvodů v místě jejich galvanického oddělení.

Pin PE konektoru RS485:
Vzhledem k tomu, že rázová vlna od přímého či nepřímého účinku blesku nemá zpravidla výraznou velikost mezi piny A,B navzájem, ale právě proti zemi, je připojení tohoto pinu velmi důležité, zejména tam, kde sběrnice RS485 propojuje dva různé objekty (dvě různé budovy). Bleskojistka pak omezí na přijatelnou úroveň přepětí, které zatěžuje především galv.oddělovací obvody adaptéru a ohrožuje nejen samotný adaptér, ale i další přístroje za ním.

Elektronika adaptéru je pak ještě chráněna měkkou ochranou sestávající z rezistorů R1,R2 zapojených v obou větvích sběrnice a obousměrného transilu 5.8V (Vz1).

Nastavení parametrů komunikace (uvnitř skříňky)

Otevření skříňky - povolením jediného vrutu uprostřed její spodní strany.

Nastavení přenosové rychlosti (mini DIP switch)

štítek přístroje

Význam jednotlivých pozic spínačů je vyobrazen na štítku přístroje na spodní straně skříňky.

Dip spínače umožňují nastavit:

  • počet baudů na bajt (spínač.2) - devět nebo osm datových bitů na byte (v podstatě tedy přenos osmibitového slova s paritním bitem, nebo bez něho) Výraz "+2" na štítku přístroje(pokud tam je uveden) zahrnuje startbit a stopbit.
  • přenosovou rychlost (spínače 1,3,4) - jednu z přenosových rychlostí: 9600, 14400,19200,28800,38400,57600,76800

Pro C-bus Honeywell (kontrolery EXCEL řady 5000) je potřeba nastavit celkový počet baudů na 9+2 (8*data +parita, start,stop) a přenosovou rychlost shodně s rychlostí nastavenou v kontroleru.

Pozn:
Firmware adaptéru provádí pouze kontrolu počtu baudů mezi startbitem a stopbitem, nezajímá se o stav datových bitů ani parity. Aby tato kontrola vycházela úspěšně, je nutnou i postačující podmínkou správné nastavení přenosové rychlosti i počtu baudů

Nastavení - volba režimu řízení směru toku dat ( jumper uprostřed karty )

Vždy se jedná o přizpůsobení převodníku na konkrétní použitou PC aplikaci.
  1. JUMPER = ON: Doporučený pracovní režim , přepínání směru toku dat si řídí AG-Black automaticky. Nepotřebuje k tomu žádné řídící signály, kabel RS232 si vystačí s 3 vodiči: RxD,TxD,GND.
    Kdy tento režim nefunguje: když PC aplikace užívá TxD ještě k jinému účelu, než je přenos dat k adresátovi (viz.další text).

  2. JUMPER = OFF : (RTS_Control) Adaptér propustí pouze data stvrzená signálem RTS.
    Tento režim je nutný pouze při součinnosti s takovými PC aplikacemi, které na TxD vysílají nejen data určená k přenosu adresátovi (např. Honeywell XBS).
    PC aplikace pak signálem RTS určuje, která data mají pokračovat k adresátovi, a která naopak slouží pouze místnímu účelu (zdroj napájení, řídící povely pro modem apod.).
    Kdy tento režim nefunguje: U řady nových PC aplikací (po uvedení Windows98), které řídící signál RTS nenastavují. Pak je nutné jumper propojit!
Pozn.: Existují i takové PC aplikace, které fungují s oběma režimy; korektně nastavují řídící signály a současně na TxD vysílají pouze data pro adresáta. Dlužno poznamenat, že jumper v takovém případě nemá na funkci sebemenší vliv.

Více informací viz. popis funkce

© Yorix s.r.o. Ing.Richard Trochta
Datum založení domény yorix.cz: 1998/05
Poslední aktualizace: 02.06.2010 		Valid HTML 4.01 Transitional


OPG485

Opakovač RS485 s galvanicky oddělenými obvody

Technické údaje | Použití | Popis funkce
Provedení, galv.oddělení, přepěťová ochrana, napájení |  | Doporučené zapojení
Nastavení parametrů komunikace | Dosažitelná přenosová vdálenost | Typické závady

Technické údaje:

přenosové rychlosti: | 2400, 4800, 7200, 9600, 14400, 19200, (25600, 28800 ;tyto dvě bez záruky) mini DIP switch
zpoždění přenosu: | 0.5 …1 Bd podle míry zkreslení (zaoblení hran) vst. signálu
vstupní odpor: | 15kW
výstupní odpor : | 200W (pouze při přenosu dat, jinak 3.stav)
přepínání směru toku dat: | automatické, odvozené od start bitu
přepěťová ochrana: | bleskojistka 20kA/20A, následná měkká ochrana s transilem
napájecí napětí: | 24...35V= nebo 20...24V~ při poklesu napětí pod 22V= přestávají fungovat optrony
galvanické oddělení | 2kV (obě signální strany mezi sebou i proti napájení)
rozměry: | rozměrový náčrtek

Použití

Pro sběrnici RS485, speciálně vyvinuto pro C-Bus (Honeywell) s komunikačními moduly XD505 (4800,9600,19200 Bd).
  • Ke galvanickému oddělení kontroleru od sběrnice RS485
  • K rozdělení příliš dlouhé sběrnice na segmenty přijatelné délky (< 1.2km)
  • náhrada OY485 K rozbití hvězdicové topologie - jednotlivé kabely sběrnice nemají být spojeny v uzlu (impedanční nepřizpůsobení, kumulace odražených vln) opakovač vřazený mezi uzel a paprsek jej impedančně zcela oddělí.
Dva opakovače OPG485 jako rozbočovač
Zapojení dvou opakovačů k rozbočení signálu (=funkční obdoba opakovače OY485, ovšem zde s galvanickým oddělením !).
Na jedné straně (tedy v uzlu) lze paralelně spojit i 10 opakovačů.

Popis funkce

  • V klidovém stavu jsou obě strany opakovače přepnuty do režimu čtení.
  • V okamžiku příchodu dat z některé strany přepne opakovač protilehlou stranu na zápis a data odesílá. Každý baud vzorkuje v jeho předpokládaném středu (odvozeno od sestupné hrany start bitu), zjištěnou logickou úroveň okamžitě odesílá na výstupní straně s ostrými hranami a definovanou šířkou pulsu.
  • Po ukončení přenosu přechází opakovač opět do režimu monitorování obou stran sběrnice RS485.

Bezpodmínečně nutné je správně nastavit vlastnosti přenášených dat - přenosovou rychlost a celkový počet bitů v jednom přenášeném bajtu - viz. nastavení parametrů komunikace

Výstupní napětí v klidovém stavu

Svorka A má v klidu proti svorce B kladné napětí velikosti přibližně 0.5V. Ke stanovení polarity svorek na druhém konci kabelu toto napětí postačuje.
Menší klidové předpětí navíc méně ovlivňuje přenos dat na větší vzdálenosti a ve svém důsledku vede k mírnému zvýšení dosahu komunikace.

Dosažitelná přenosová vzdálenost

je nepřímo úměrná zvolené rychlosti. Obecně uváděná vzdálenost 1200 m je dosažitelná při přenosové rychlosti 9600 Bd. Pro ostatní přenosové rychlosti platí nepřímá úměra - kolikrát je rychlost vyšší, tolikrát se délkový segment zkracuje a naopak.

Je-li možnost kabelovou trasu rozdělit na segmenty, lze mezi jednotlivé segmenty vkládat OPG485 do celkového počtu 10..20 ks - závisí to na "trpělivosti" použitého protokolu. Na stole jsme odzkoušeli komunikaci mezi dvěma Excely50 přes kaskádu 26 ks OPG485.

Co když kabelový úsek je delší, než dosah opakovače?

Občas lze narazit na situaci, že kabel, který je nutno použít, je příliš dlouhý a dostupný pouze na obou koncích. Pro takový případ máme modem BBM-9600.

Provedení

foto

Vnější provedení

Opakovač je vestavěn do skříňky Modulbox 4M ( rozměry viz. rozměrový náčrtek). Napájecí napětí a vysílané signály do obou směrů jsou indikovány diodami LED.

Všechny přívodní vodiče se připojují do šroubových svorek.

Na štítku přístroje je vyobrazen popis svorek včetně tabulky nastavení přenosové rychlosti a počtu přenášených bitů.

Vnitřní provedení

Galvanické oddělení

Přístroj obsahuje 3 navzájem galvanicky oddělené obvody:
  1. Obvod napájení 24V-svorky 1,2 - obsahuje můstkový usměrňovač s vyhlazovacím filtrem a následný pulsní měnič 70 kHz s feritovým toroidním transformátorem - toto provedení umožňuje napájet přístroj zdrojem téměř libovolného napěťového průběhu s efektivní hodnotou okolo 24V.
    Galvanické oddělení napájecích obvodů od ostatních okruhů opakovače umožňuje připojit opakovač ke stejnému transformátoru, jako přístroj, který je s opakovačem propojen datovým okruhem bez obav ze vzniku nežádoucích smyček.
    Všechna 3 vinutí feritového transformátoru jsou zkoušena mezi sebou přiloženým napětím 3.75kV, 50Hz po dobu 1 minuty.

  2. Obvod pravé sběrnice RS485 - svorky 6,7 (8) svorkovnice. Tento okruh společný s řídícími obvody (mikroprocesor)- Svorka 8 není v normálním stavu galvanicky spojena s žádnou jinou (mezi svorkou 7 a 8 je pouze bleskojistka; pro U < 150V je bleskojistka izolantem)

  3. Obvod levé sběrnice RS485 - svorky 3,4 (5) svorkovnice. Tento okruh obsahuje minimum součástek, měl by být proto přednostně připojen k drsnější straně sběrnice. (mezi svorkou 4 a 5 je opět pouze bleskojistka)

Obvody 2 a 3 jsou galvanicky odděleny prostřednictvím optronů s elektrickou pevností 2.5kV AC.

Nejmenší povrchová vzdálenost vodivých ploch na plošném spoji mezi galv. odd. obvody je 2mm , za sucha vyhoví zkoušce přiloženým napětím 2 kV 50Hz.

Přepěťová ochrana

přepěťovka

Zapojení je na obr.vedle; První díl dvojité bleskojistky je zapojen přímo mezi svorky A a B. Druhý díl bleskojistky je zapojen mezi jednu datovou svorku a další, zcela samostatnou svorku, která je určena pro připojení na uzemnění nebo PE svorku silového rozvodu. V normálním stavu se neprojeví (R>50Mohm), při výskytu přepětí proti zemi omezí jeho velikost a tím také napěťovou zátěž obvodů v místě jejich galvanického oddělení.
Svorka PE - (ochrana obvodů galv. odd.)
Vzhledem k tomu, že rázová vlna od přímého či nepřímého účinku blesku nemá zpravidla výraznou velikost mezi svorkami A,B navzájem, ale právě proti zemi, je připojení této svorky velmi důležité, zejména na té straně opakovače, která je pripojena k dlouhému kabelu. Teprve pak může bleskojistka svést nežádoucí náboj do země a omezit tak přepětí na takovou úroveň, které již neohrozí galv.oddělovací obvody a OPG485 se tím stává velmi účinnou bariérou proti dalšímu šíření rázové vlny komunikační sítí.

Elektronika vlastního opakovače je pak ještě chráněna měkkou ochranou sestávající z rezistorů R1,R2 zapojených v obou větvích sběrnice a obousměrného transilu 5.8V (VZ1).

Doporučené zapojení

A.) OPG485 jako přepěťová ochrana kontroleru

doporučené zapojení

Účel - minimalizace škody při úderu blesku.

K levému rozhraní RS485 připojit kabel od vzdálených stanic. Toto rozhraní obsahuje minimum součástek, extrémní přepětí zde proto napáchá méně škod.

K pravému rozhraní RS485 připojit kontroler - protože toto rozhraní RS485 je galvanicky spojeno s většinou elektroniky opakovače, je vhodné připojit je k té straně sběrnice RS485, která bude méně vystavena atmosférickým vlivům. Míra ohrožení zevnitř rozvaděče je evidentně podstatně nižší, než zvenčí.

Obě uzemňovací svorky na OPG485 pospojit s kostrou rozvaděče!
Bez tohoto pospojení nemůžou správně fungovat interní svodiče přepětí! Rázová vlna by mohla překonat izolační bariéru optronů a proniknout i do kontroleru.

Napájení může být jak střídavé, tak stejnosměrné. (viz. vnitřní provedení)

B.) OPG485 jako opakovač mezi dvěma kabelovými segmenty

V tomto případě nelze zvolit méně ohroženou stranu, obě rozhraní RS485 jsou rovnocenné. I zde je přizemnění zemnících svorek opakovače žádoucí, slouží jak ochraně vlastního opakovače, tak zamezení šíření rázové vlny sítí RS485.

Stanovení polarity u vodičů kabelu vzdálené stanice

K určení, který vodič je který, stačí DC voltmetr; A je vždy kladný vůči B. Velikost napětí závisí na typu přístroje na druhém konci kabelu, u OPG485 se pohybuje od 0,5 do 1V, u karet Honeywell bývá téměř 5V.

Nastavení parametrů komunikace

štítek přístroje

se provádí nastavením mini DIP spínačů umístěných pod dolním krytem svorkovnice skříňky Modulbox.
Všechny možnosti nastavení spínačů jsou vyobrazeny na štítku přístroje.

DIP spínače umožňují nastavit:

  • počet bitů na bajt(druhý minispínač zleva)
    bits/byte - osm nebo devět datových bitů na bajt (v podstatě tedy přenos osmibitového slova s paritním bitem, nebo bez něho; typ parity se nerozlišuje).
    Výraz "+2" má pouze připomenout, že každý bajt povinně obnáší také startbit a stopbit.

  • přenosovou rychlost(ostatní tři minispínače)
    baudrate

Další přenosové rychlosti:

Počínaje zářím 2010 jsou opakovače OPG485 vybaveny jumperem umístěným vlevo od miniDip spínačů.
Spojený jumper sníží předvolenou přenosovou rychlost 8x.

Lze tak předvolit další přenosové rychlosti: 300, 600, 900, 1200, 1800, 3200 a 3600 Bd.

Příklad: Chci rychlost 1200 - nastavím miniDip na 9600 (8 x 1200) a spojím jumper.

Pozn:
Snížení komunikační rychlosti je sice nejsnazší a nejlevnější způsob, jak řešit problémovou komunikační linku, ale není jediný.
Tam, kde nefunguje rychlost 4800 nebo 9600 je velká šance, že to vyřeší nasazení našeho modemového páru do kritického kabelového úseku.

Jumper zařadí 8x nižší přenosovou rychlost.

Počet stopbitů se nenastavuje.
Opakovače OPG485, vyrobené po 2004/08 (od verze 3.71) jsou na počtu stopbitů nezávislé; umí cokoli. (s prvním stopbitem přechází do monitorovacího režimu, který trvá až do dalšího startbitu)
Starší výrobky umí pouze 1 nebo 2 stopbity. (vždy lze nechat u výrobce přepálit program uP do nové verze).

Pozn:
Firmware opakovače provádí pouze kontrolu počtu baudů mezi startbitem a stopbitem, nezajímá se o stav datových bitů ani parity, ani o počet stopbitů.
Správné nastavení přenosové rychlosti a počtu bitů na bajt je proto nutnou, ale i postačující podmínkou pro fungování přístroje.

Pro C-bus Honeywell (kontrolery EXCEL řady 5000) je potřeba nastavit celkový počet baudů na 9+2 (8*data +parita, start,stop) a přenosovou rychlost shodně s rychlostí nastavenou v kontroleru.
umístění mini DIP spínačů
umístění spínačů

Přístup k mini DIP spínačům

Kryt svorkovnice lze lehce sejmout, vloží-li se šroubovák do štěrbiny mezi tento kryt a skříňku a mírně zapáčí; viz.animace vpravo:
(váš web prohlížeč musí mít povoleno přehrávat animace, jinak vidíte pouze první snímek)

Typické závady

osazovací předpis

Velké atmosférické přepětí může někdy překonat bariéru přepěťové ochrany a způsobit zničení jednoho z integrovaných obvodů SN75176 (budič sběrnice RS485; na obr. zeleně).
Oba integrované obvody SN75176 jsou proto umístěny v precizní patici.

Pozor na starý firmware EXCELu50
V sítích, kde jsou starší podcentrály Honeywell XL50 s firmwarem < 02.02.03 dochází při použití OPG485 k občasnému zatuhnutí C Busu.
Tento problém vyřeší upgrade firmwaru EXCELu verzí 02.02.03 a vyšší.
© Yorix s.r.o. Ing.Richard Trochta
Datum založení domény yorix.cz: 1998/05
Poslední aktualizace: 08.02.2006 		Valid HTML 4.01 Transitional


OPGF

Rychlý opakovač RS485 s galvanicky oddělenými obvody

Technické údaje | Použití | Popis funkce
Provedení | Doporučené zapojení | Nastavení parametrů

Technické údaje:

přenosové rychlosti: | 9600,14400,19200,28800,38400,57600,76800) mini DIP switch
zpoždění přenosu: | 1 Bd
vstupní odpor: | 15kW
výstupní odpor : | 200W (pouze při přenosu dat, jinak 3.stav)
přepínání směru toku dat: | automatické, odvozené od start bitu
přepěťová ochrana: | bleskojistka 20kA/20A, následná měkká ochrana s transilem
napájecí napětí: | 24...35V= nebo 20...24V~ při poklesu napětí pod 22V= přestávají fungovat optrony
galvanické oddělení | 1,5kV AC (obě signální strany mezi sebou i proti napájení)
rozměry: | rozměrový náčrtek

Použití

Pro sběrnice RS485 s přenosovými rychlostmi do 76.8 kBd a vysokými nároky na rychlost odezvy.
Stejně jako ostatní opakovače fy Yorix i tento opakovač přenáší data po baudech (nečeká na celý bajt), dosahuje tak velmi nízkého zpoždění přenosu dat a je tak velmi přátelský i vůči "netrpělivým protokolům".

Omezení počtu použitých opakovačů

Míra trpělivosti protokolu je také jediným faktorem omezujícím počet těchto opakovačů řazených za sebou. Na C-Busu Honeywell, který patří právě mezi ty méně trpělivé protokoly, byla úspěšně odzkoušena kaskáda 26 opakovačů OPG485. (opakovač OPGF je obdobou opakovače OPG485, určenou pro vyšší přenosové rychlosti).

Proč použít opakovač:

  • Ke galvanickému oddělení kontroleru od sběrnice RS485
  • K rozdělení příliš dlouhé sběrnice na segmenty přijatelné délky (1.2km / 9600 Bd, s vyšší přenosovou rychlostí se délka segmentu přímo úměrně zkracuje )
  • náhrada OY485 K rozbití hvězdicové topologie - jednotlivé kabely sběrnice nemají být spojeny v uzlu (impedanční nepřizpůsobení, kumulace odražených vln) opakovač vřazený mezi uzel a paprsek jej impedančně zcela oddělí.
Dva opakovače OPGF jako rozbočovač
Zapojení dvou opakovačů k rozbočení signálu
Na jedné straně (tedy v uzlu) lze paralelně spojit i 10 opakovačů.

Popis funkce

  • V klidovém stavu jsou obě strany opakovače přepnuty do režimu čtení.
  • V okamžiku příchodu dat z některé strany přepne opakovač protilehlou stranu na zápis a data odesílá. Každý baud vzorkuje v jeho předpokládaném středu (odvozeno od sestupné hrany start bitu), zjištěnou logickou úroveň okamžitě odesílá na výstupní straně s ostrými hranami a definovanou šířkou pulsu.
  • Po ukončení přenosu přechází opakovač opět do režimu monitorování obou stran sběrnice RS485.

Bezpodmínečně nutné je správně nastavit vlastnosti přenášených dat - přenosovou rychlost a celkový počet bitů v jednom přenášeném bajtu - viz. nastavení parametrů komunikace

Výstupní napětí v klidovém stavu

Svorka A má v klidu proti svorce B kladné napětí velikosti přibližně 0.5V. Ke stanovení polarity svorek na druhém konci kabelu toto napětí postačuje.
Menší klidové předpětí navíc méně ovlivňuje přenos dat na větší vzdálenosti a ve svém důsledku vede k mírnému zvýšení dosahu komunikace.

Provedení

foto

Vnější provedení

Opakovač je vestavěn do skříňky Modulbox 4M ( rozměry viz. rozměrový náčrtek). Napájecí napětí a vysílané signály do obou směrů jsou indikovány diodami LED.

Všechny přívodní vodiče se připojují do šroubových svorek.

Na štítku přístroje je vyobrazen popis svorek včetně tabulky nastavení přenosové rychlosti a počtu přenášených bitů.

Vnitřní provedení

Galvanické oddělení

Přístroj obsahuje 3 navzájem galvanicky oddělené obvody:
  1. Obvod napájení 24V-svorky 1,2 - obsahuje můstkový usměrňovač s vyhlazovacím filtrem a následný pulsní měnič 70 kHz s feritovým toroidním transformátorem - toto provedení umožňuje napájet přístroj zdrojem téměř libovolného napěťového průběhu s efektivní hodnotou okolo 24V.
    Galvanické oddělení napájecích obvodů od ostatních okruhů opakovače umožňuje připojit opakovač ke stejnému transformátoru, jako přístroj, který je s opakovačem propojen datovým okruhem bez obav ze vzniku nežádoucích smyček.
    Všechna 3 vinutí feritového transformátoru jsou zkoušena mezi sebou přiloženým napětím 3.75kV, 50Hz po dobu 1 minuty.

  2. Obvod pravé sběrnice RS485 - svorky 6,7 (8) svorkovnice. Tento okruh obsahuje všechny řídící obvody (mikroprocesor atd.)
    - Svorka 8 není v normálním stavu galvanicky spojena s žádnou jinou (mezi svorkou 7 a 8 je pouze bleskojistka; pro U < 150V je bleskojistka izolantem)

  3. Obvod levé sběrnice RS485 - svorky 3,4 (5) svorkovnice. Tento okruh obsahuje minimum součástek, měl by být proto přednostně připojen k drsnější straně sběrnice. (mezi svorkou 4 a 5 je opět pouze bleskojistka)

Obvody 2 a 3 jsou galvanicky odděleny prostřednictvím optronů s elektrickou pevností 2.5kV AC.

Nejmenší povrchová vzdálenost vodivých ploch na plošném spoji mezi galv. odd. obvody je 2mm , za sucha vyhoví zkoušce přiloženým napětím 2 kV 50Hz.

Přepěťová ochrana

přepěťovka

Zapojení je na obr.vedle; První díl dvojité bleskojistky je zapojen přímo mezi svorky A a B. Druhý díl bleskojistky je zapojen mezi jednu datovou svorku a další, zcela samostatnou svorku, která je určena pro připojení na uzemnění nebo PE svorku silového rozvodu. V normálním stavu se neprojeví (R>50Mohm), při výskytu přepětí proti zemi omezí jeho velikost a tím také napěťovou zátěž obvodů v místě jejich galvanického oddělení.
Svorka PE - (ochrana obvodů galv. odd.)
Vzhledem k tomu, že rázová vlna od přímého či nepřímého účinku blesku nemá zpravidla výraznou velikost mezi svorkami A,B navzájem, ale právě proti zemi, je připojení této svorky velmi důležité, zejména na té straně opakovače, která je pripojena k dlouhému kabelu. Teprve pak může bleskojistka svést nežádoucí náboj do země a omezit tak přepětí na takovou úroveň, které již neohrozí galv.oddělovací obvody a opakovač se tím stává velmi účinnou bariérou proti dalšímu šíření rázové vlny komunikační sítí.

Elektronika vlastního opakovače je pak ještě chráněna měkkou ochranou sestávající z rezistorů R1,R2 zapojených v obou větvích sběrnice a obousměrného transilu 5.8V (VZ1).

Doporučené zapojení

A.) OPGF jako přepěťová ochrana kontroleru

doporučené zapojení

Účel - minimalizace škody při úderu blesku.

K levému rozhraní RS485 připojit kabel od vzdálených stanic. Toto rozhraní obsahuje minimum součástek, extrémní přepětí zde proto napáchá méně škod.

K pravému rozhraní RS485 připojit kontroler - protože toto rozhraní RS485 je galvanicky spojeno s většinou elektroniky opakovače, je vhodné připojit je k té straně sběrnice RS485, která bude méně vystavena atmosférickým vlivům. Míra ohrožení zevnitř rozvaděče je evidentně podstatně nižší, než zvenčí.

Obě uzemňovací svorky na OPGF pospojit s kostrou rozvaděče!
Bez tohoto pospojení nemůžou správně fungovat interní svodiče přepětí! Rázová vlna by mohla překonat izolační bariéru optronů a proniknout i do kontroleru.

Napájení může být jak střídavé, tak stejnosměrné. (viz. vnitřní provedení)

B.) OPGF jako opakovač mezi dvěma kabelovými segmenty

V tomto případě nelze zvolit méně ohroženou stranu, obě rozhraní RS485 jsou rovnocenné. I zde je přizemnění zemnících svorek opakovače žádoucí, slouží jak ochraně vlastního opakovače, tak zamezení šíření rázové vlny sítí RS485.

Stanovení polarity u vodičů kabelu vzdálené stanice

K určení, který vodič je který, stačí DC voltmetr; A je vždy kladný vůči B. Velikost napětí závisí na typu přístroje na druhém konci kabelu, u OPGF se pohybuje od 0,5 do 1V, u karet Honeywell bývá téměř 5V.

Nastavení parametrů komunikace

se provádí nastavením mini DIP spínačů umístěných pod dolním krytem svorkovnice skříňky Modulbox.
Všechny možnosti nastavení spínačů jsou vyobrazeny na štítku přístroje. štítek přístroje

DIP spínače umožňují nastavit:

  1. počet bitů na bajt (druhý minispínač zleva)
    bits/byte - osm nebo devět datových bitů na bajt (v podstatě tedy přenos osmibitového slova s paritním bitem, nebo bez něho; typ parity se nerozlišuje).
    Výraz "+2" má pouze připomenout, že každý bajt povinně obnáší také startbit a stopbit.
  2. přenosovou rychlost (ostatní tři minispínače)

Počet stopbitů se nenastavuje.

Pozn:
Firmware opakovače provádí pouze kontrolu počtu baudů mezi startbitem a prvním stopbitem, nezajímá se o stav datových bitů ani parity, ani o počet stopbitů.
Správné nastavení přenosové rychlosti a počtu bitů na bajt je proto nutnou, ale i postačující podmínkou pro fungování přístroje.

Pro C-bus Honeywell (kontrolery EXCEL řady 5000) je potřeba nastavit celkový počet baudů na 9+2 (8*data +parita, start,stop) a přenosovou rychlost shodně s rychlostí nastavenou v kontroleru.

umístění mini DIP spínačů
umístění spínačů

Přístup k mini DIP spínačům

Kryt svorkovnice lze lehce sejmout, vloží-li se šroubovák do štěrbiny mezi tento kryt a skříňku a mírně zapáčí; viz.animace vpravo:
(váš web prohlížeč musí mít povoleno přehrávat animace, jinak vidíte pouze první snímek)

Typické závady

osazovací předpis

Velké atmosférické přepětí může někdy překonat bariéru přepěťové ochrany a způsobit zničení jednoho z integrovaných obvodů SN75176 (budič sběrnice RS485; na obr. zeleně).
Oba integrované obvody SN75176 jsou proto umístěny v precizní patici.

© Yorix s.r.o. Ing.Richard Trochta
Datum založení domény yorix.cz: 1998/05
Poslední aktualizace: 02.06.2010 		Valid HTML 4.01 Transitional


BBM

BBM-9600

jednoduchý modem pro zvýšení dosahu sběrnice RS485
na nekomutovaných linkách

Technické údaje | Použití
Popis funkce | Provedení, galv.oddělení, přepěťová ochrana, napájení
Zapojovací předpis | Nastavení modemu před spuštěním

Technické údaje:

přenosová rychlosti: | 9600
zpoždění přenosu: | < 1 Baud
Rozhraní: | datová strana-RS485 Linka - modulace sinusovým napětím 9600Hz, 200mV
režim přenosu : | poloduplex
přepínání směru toku dat: | automatické
závislost na polaritě vodičů linky: | ano
maximální dosah: | cca 8 km
přepěťová ochrana: | bleskojistka 20kA/20A, následná měkká ochrana s transilem
napájecí napětí: | 24...35V= nebo 20...24V~ při poklesu napětí pod 22V= přestávají fungovat optrony
galvanické oddělení | ano, s elektrickou pevností 2kV AC (obě signální strany mezi sebou i proti napájení)
rozměry: | rozměrový náčrtek

Použití

Když už opakovač nestačí!

Díky rychlé odezvě se tento modemový pár jeví na sběrnici RS485 stejně jako kterýkoli náš opakovač, ovšem zásluhou použité sinusové modulace na linkové straně má výrazně větší dosah.
Hodí se proto k propojení dvou segmentů jedné sběrnice RS485 linkou délky až 8 km.
Vždy je nutné použít modemový pár, každý z obou modemů je k dlouhé lince připojen linkovou stranou.
Dva segmenty sběrnice RS485 takto propojené spolu komunikují s minimálním časovým zpožděním ( 1,5 baudu).
Minimální časové zpoždění garantuje, že modemový spoj se navenek jeví téměř jako drátová propojka. Žádnému protokolu proto nečiní potíže.

Popis funkce

  • V klidovém stavu jsou obě strany modemu přepnuty do režimu čtení.
  • V okamžiku příchodu dat z některé strany přepne modem protilehlou stranu na zápis a data odesílá.
  • Po ukončení přenosu přechází modem opět do režimu monitorování obou stran.

Linková strana je modulována sinusovým signálem bez ss složky, aby zkreslení tvaru signálu bylo co nejméně závislé na délce linky.

Délka linky pak ovnivňuje především amplitudu signálu. To však lze napravit nastavením zesílení přijímacích obvodů modemu. Nastavení je nutno provést před spuštěním "ostrého provozu".

Provedení

foto Pozn.:
Modem je odvozen od opakovače OPG485 - opakovač v nezměněné podobě je zde doplněn o modulační kartu, která podporuje pouze přenosovou rychlost 9600 Bps.
Proto jsou vnější vzhled, rozmístění svorek, galvanické oddělení a přepěťová ochrana totožné s vlastnostmi opakovače OPG485.
Proto také některé další kapitoly jsou téměř shodné s dokumentací k opakovači OPG485.

Vnější provedení

Modem je vestavěn do skříňky Modulbox 4M ( rozměry viz. rozměrový náčrtek). Napájecí napětí a vysílané signály do obou směrů jsou indikovány diodami LED.

Všechny přívodní vodiče se připojují do šroubových svorek.

Vnitřní provedení

Galvanické oddělení

Přístroj obsahuje 3 navzájem galvanicky oddělené obvody:
  1. Obvod napájení 24V-svorky 1,2 - obsahuje můstkový usměrňovač s vyhlazovacím filtrem a následný pulsní měnič 70 kHz s feritovým toroidním transformátorem - toto provedení umožňuje napájet přístroj zdrojem téměř libovolného napěťového průběhu s efektivní hodnotou okolo 24V.
    Galvanické oddělení napájecích obvodů od ostatních okruhů opakovače umožňuje připojit opakovač ke stejnému transformátoru, jako přístroj, který je s opakovačem propojen datovým okruhem bez obav ze vzniku nežádoucích smyček.
    Všechna 3 vinutí feritového transformátoru jsou zkoušena mezi sebou přiloženým napětím 3.75kV, 50Hz po dobu 1 minuty.

  2. Obvod s modulací pro linku - svorky 6,7 (8) svorkovnice. Svorka 8 není v normálním stavu galvanicky spojena s žádnou jinou (mezi svorkou 7 a 8 je pouze bleskojistka; pro U < 150V je bleskojistka izolantem)

  3. Obvod sběrnice RS485 - svorky 3,4 (5) svorkovnice. (mezi svorkou 4 a 5 je opět pouze bleskojistka)

Obvody 2 a 3 jsou galvanicky odděleny prostřednictvím optronů s elektrickou pevností 2.5kV AC.

Nejmenší povrchová vzdálenost vodivých ploch na plošném spoji mezi galv. odd. obvody je 2mm , za sucha vyhoví zkoušce přiloženým napětím 2 kV 50Hz.

Přepěťová ochrana

přepěťovka

Zapojení je na obr.vedle; První díl dvojité bleskojistky je zapojen přímo mezi svorky A a B. Druhý díl bleskojistky je zapojen mezi jednu datovou svorku a další, zcela samostatnou svorku, která je určena pro připojení na uzemnění nebo PE svorku silového rozvodu. V normálním stavu se neprojeví (R>50Mohm), při výskytu přepětí proti zemi omezí jeho velikost a tím také napěťovou zátěž obvodů v místě jejich galvanického oddělení.

Svorka PE - (ochrana obvodů galv. odd.)
Vzhledem k tomu, že rázová vlna od přímého či nepřímého účinku blesku nemá zpravidla výraznou velikost mezi svorkami A,B navzájem, ale právě proti zemi, je připojení této svorky velmi důležité, zejména na té straně opakovače, která je pripojena k dlouhému kabelu. Teprve pak může bleskojistka svést nežádoucí náboj do země a omezit tak přepětí na takovou úroveň, které již neohrozí galv.oddělovací obvody a přístroj se tím stává velmi účinnou bariérou proti dalšímu šíření rázové vlny komunikační sítí.

Za bleskojistkou následuje ještě měkká ochrana sestávající z rezistorů R1,R2 zapojených v obou větvích sběrnice a obousměrného transilu 5.8V (VZ1).

Zapojení

  • Na polaritě signálu záleží !
    a to na obou datových rozhraních modemu.
    Strana RS485 obsahuje ss složku trvale, takže stačí ji kdykoli ověřit voltmetrem.
    Na linkové straně lze v nastavovacím režimu pustit do linky ss napětí z libovolného modemu a na protilehlé straně ho pak změřit a správně připojit.
    Při uvedeném postupu bude na obou stranách svorka "A" kladná proti svorce "B".

  • Přizemnění svorek PE je žádoucí !
    (aby vestavěné bleskojistky svedly do země každé napětí nad 150V)
    Slouží jak ochraně vlastního modemu, tak zamezení šíření rázové vlny sběrnicí RS485.

Nastavení modemu před spuštěním

Je vhodné provádět dvěma pracovníky s mobilními telefony.

Postup:

  1. Odpojení RS485:
    na obou stranách musí zůstat rozhraní RS485 odpojené po celou dobu nastavování, aby nerušilo !

  2. Stanovení polarity u vodičů kabelu vzdálené stanice:

    vysílání DC napětí k určení polarity linky V modemu na jedné straně linky přepnout mini dip spínače 1 a 2 do polohy off. Modem v tomto nastavovacím režimu pouze nastaví ss napětí na svorky linky. Na protilehlé straně změříme ss voltmetrem odpojenou linku - A je vždy kladný vůči B.

  3. Nastavení zesílení přijímací části modemu:
    • vysílání testovacího paketu:
      vysílání testovacího paketu
      V prvním modemu       přepnout mini dip spínač 4 do polohy off (ostatní spínače do polohy "on") - tím se tento modem přepne do nastavovacího režimu jako vysílač - cyklicky pak vysílá do linky pevně nastavený 20-ti bajtový paket.

    • nastavení zesílení:
      nastavení zesílení přijímače
      V druhém modemu přepnout mini dip spínač 1 do polohy off (ostatní spínače do polohy "on") - tento modem se přepne do nastavovacího režimu jako přijímač - přijímá pakety od prvního modemu, porovná je s předlohou ve své paměti a pokud se neshodují, problikne levou žlutou LEDkou.).
      Pravá žlutá LED indikuje příjem dat z linky .
      K nastavení správného zesílení pak vyhledáme v přijímači takovou polohu trimru, kdy levá led ani neblikne! (bliká-li pouze pravá, máme jistotu, že data přicházejí a shodují se s předlohou)

  4. Krok 3 je nutno provést obdobným postupem i v opačném směru; druhý modem přepnout na vysílání testovacího paketu a v prvním nastavit zesílení.

  5. Volba "ostrého režimu":

    pracovní režim-spínač 2 je v poloze ON, jak to vyžaduje C-Bus fy Honeywell
    Mini Dip spínači navolit u obou modemů pracovní režim - spínače 1 a 4 musí být v poloze ON, spínač 2 určuje stejně jako u OPG485 celkový počet bitů na bajt (10 nebo 11, rozumí se včetně start a stop bitů), spínač 3 nemá vliv.

  6. Připojení RS485:
    Nakonec již zbývá jen připojit oba modemy k jejich sběrnicím RS485. Svorka A je kladná vůči B.

Přenosová rychlost

je pevně dána - 9600 Bps.
Pozn.: úprava na nižší rychlost je možná (při výrobě) - vyžaduje drobné změny v hw a fw.

počet bitů na bajt (mini DIP spínač 2)
bits/byte - osm nebo devět datových bitů na bajt (v podstatě tedy přenos osmibitového slova s paritním bitem, nebo bez něho; typ parity se nerozlišuje).
Výraz "+2" má pouze připomenout, že každý bajt povinně obnáší také startbit a stopbit.
Do počtu bitů se započítává pouze jeden stopbit. Modem v tu chvíli považuje bajt za ukončený a je mu jedno, kolik dalších stopbitů následuje.

Pozn:
Firmware přístroje provádí pouze kontrolu počtu baudů mezi startbitem a stopbitem, nezajímá se o stav datových bitů ani parity, ani o počet stopbitů.
Správné nastavení počtu bitů na bajt je proto nutnou podmínkou pro fungování přístroje.

Pro C-bus Honeywell (kontrolery EXCEL řady 5000) je potřeba nastavit celkový počet baudů na 9+2 (8*data +parita, start,stop) tj MiniDip 2 = ON.

umístění mini DIP spínačů
umístění spínačů

Přístup k mini DIP spínačům

Kryt svorkovnice lze lehce sejmout, vloží-li se šroubovák do štěrbiny mezi tento kryt a skříňku a mírně zapáčí; viz.animace vpravo:
(váš web prohlížeč musí mít povoleno přehrávat animace, jinak vidíte pouze první snímek)
© Yorix s.r.o. Ing.Richard Trochta
Datum založení domény yorix.cz: 1998/05
Poslední aktualizace: 02.06.2010 		Valid HTML 4.01 Transitional


test_OPG

TestOpg

PC program pro kontrolu opakovačů a adaptérů s rozhraními RS232,RS485

použití | Technické požadavky na PC | popis funkce
propojení opakovačů s porty PC | připojení RS485 k portu PC | měření přístrojů bez galv.oddělení
download

Použití

Program umožní prověřit funkci jednoho, nebo kaskády několika přístrojů typu opakovač RS485 či adaptér RS232/RS485 "na stole".

Technické požadavky na PC

Použitý počítač musí nutně obsahovat:
  • Dva volné sériové porty COM1 a COM2.
  • 32-bitový operační systém Windows (Windows95 a novější)

Popis funkce

okno programu
  • Po startu očekává program od uživatele nejprve nastavení parametrů komunikace a následné spuštění testu tlačítkem "spusť test".
  • Bezprostředně po spuštění testu program zjistí časovou periodu, s níž mu jádro operačního systému přiděluje pracovní čas. Tato perioda je pak zobrazena v hranatých závorkách v titulku okna programu a slouží programu k synchronizaci rychlosti testu podle výkonu použitého PC. (určení počtu datových rámců, které může na daném PC v tomto časovém intervalu odeslat.)
  • Pak již cyklicky generuje pětici náhodných čísel typu int (32bit), které odešle jako 20-bytový paket jedním portem, načte protilehlým portem a prověří shodu. Vysílací a přijímací port si s každým paketem mění úlohu.

    Pokud se odeslaný a přijatý paket neshodují, jsou oba hexadecimálně zobrazeny v "memo" komponentě okna programu, nejprve vždy odeslaný, pak přijatý.
    Dále je inkrementován čítač všech chybných paketů a čítač chybných paketů vztažený k právě vysílající straně. Tyto hodnoty jsou též zobrazovány v okně programu.

  • Test se zastavuje dalším stiskem téhož tlačítka.

    Tlačítko "čti verzi"

    Všechny opakovače a adaptéry fy Yorix, které obsahují mikroprocesor ATMEL umožňují zobrazit krátký textový údaj o verzi firmwaru. Vyslání těchto dat z opakovače je vyvoláno vždy se změnou stavu jeho miniDIP spínače a je vysláno s komunikačními parametry "9600 8 N 1" na všechny jeho výstupy. Je to vidět na diodách LED opakovače.
    Program test_OPG po stisku tlačítka "čti verzi" nastaví COM1 na výše uvedené parametry a čeká na data. Libovolné přepnutí miniDIP v opakovači pak vyvolá zobrazení údajů o verzi.

    Pozn.: Když je na testeru připojeno více přístrojů v kaskádě, je nutno pamatovat na to, že celá cesta od sledovaného opakovače k portu COM1 počítače musí být nastavena na předepsané komunikační parametry ("9600 8 N 1") dříve, než dojde k přepnutí spínače na sledovaném opakovači. Jinak budou data cestou znehodnocena a PC vypíše pouze nesmysly.

Propojení opakovačů a adaptérů s porty PC

Rozhraní RS232

Pro kontrolu adaptérů s funkcí automatického řízení toku dat stačí propojovací šňůra se signály RxD,TxD,GND.
Pokud adaptér pracuje v režimu vnějšího řízení toku dat, pak přibývá ještě signál RTS.
Tento režim lze v testovacím programu nastavit zaškrtávacím políčkem "PC nastavuje RTS".

Datové signály a jejich význam na straně PC
Název | Význam | PC - CANNON 9 | PC - CANNON 25
RxD | přijímaná data | 2 | 3
TxD | vysílaná data | 3 | 2
GND | signálová zem | 5 | 7
RTS | požadavek na vysílání | 8 | 4

Přímé připojení rozhraní RS485 k sériovému portu PC

Při dodržení jistých podmínek lze rozhraní RS485 připojit přímo na port rozhraní RS232. Využívá se přitom následujících skutečností:
  1. garantovaná funkce v rozsahu amplitud signálu RS232 je 3...15V, u RS485 je to 1,5 ... 5V; rozsah 3...5V mají společný
  2. formát signálu (=pořadí bitů a tvar napěťového signálu) mají shodný, pouze s opačnou polaritou
Pokud signál RS485 má napětí 3..5V a obrátí se jeho polarita, je čitelný i v RS232.
V opačném směru signál z portů PC je (přinejmenším ve všech přístrojích fy.Yorix) omezen měkkými přepěťovými ochranami na úroveň vyhovující RS485.

připojení Propojení je pak následovné:

  • Signály RxD a TxD na straně PC (obecně na straně RS232) vzájemně propojit a připojit na svorku "B(-)" rozhraní RS485
  • Signál GND na straně PC připojit na svorku "A(+)" rozhraní RS485
Pozn.: Vzájemné propojení signálů RxD a TxD nezpůsobuje žádnou kolizi, neboť jak testovací program, tak měřené přístroje pracují v poloduplexním režimu s předností pro zápis.

Testování galvanicky neoddělených přístrojů

Popis problému

Testování ve výše uvedeném propojení má smysl pouze u přístrojů s galvanicky oddělenými okruhy. U přístrojů bez galvanického oddělení se může stát:
  • že dojde k přímému drátovému propojení mezi oběma COMy PC a test je pak vždy úspěšný bez ohledu na opakovač (př.test OP485 v režimu opakovače; GND obou portů PC je zpravidla společný, datové signály jsou přivedeny do svorek "B", které jsou zase společné v OP485)
  • že dojde k vyzkratování datového signálu proti GND (příklad: test OP485 v režimu adaptéru RS232/485; v tomto přístroji je na společném potenciálu RS232:GND a RS485:B)

Jak na to

Tyto problémy lze obejít dodatečným galvanickým oddělením: použitím galvanicky odděleného, zaručeně funkčního přístroje zapojeného v kaskádě s testovaným přístrojem.
©Yorix.s.r.o., Ing.Richard Trochta, 18.5.2005


GreenBonO - regulátor pro úplné využití přebytků FVE

Důležité upozornění majitelům letitých regulací- co je třeba rychle udělat, když vám distributor vymění elektroměr

V roce 2015 došlo v celé republice k výměně elektroměrů. Všichni majitelé FVE, kteří měli ještě součtové elektroměry, dostali elektroměry měřící každou fázi zvlášť. O tom, jaké jsou důsledky této výměny, a co je třeba udělat co nejrychleji, čtěte zde:
2015 - konec součtové regulace konec součtové regulace

regulátor GreenBonO - plynulá regulace spotřeby FVE
využití přebytků FVE

( Green Bonus Optimizer )

Regulátor s plynulou regulací výkonu
pro dokonalé využití přebytků FVE

Použití | Technické údaje | vliv elektroměrů na výsledek regulace |  | popis funkce
zpětný vliv na síť-flikr | Provedení | Kabeláž | Předpis 1f zapojení | Předpis 3f zapojení
když slunce nesvítí | doporučené externí přístroje | volitelné příslušenství | komunikace s PC | most do poč.sítě
firmware | uvedení do provozu | Záloha konfigurace | Provoz | reference
opatření proti zatuhávání regulátoru |  | co dělat když GBO přestane fungovat |  | jak objednávat

Úvod

GreenBonO je na trhu od prosince 2010. Za tu dobu zůstal jeho hardware beze změny, zato firmware prošel bouřlivým vývojem a vždy se dokázal přizpůsobit novým podmínkám, vyplývajícím ze změn energetické legislativy a s tím souvisejících změn chování fakturačních elektroměrů, s jejichž funkcí je účinnost regulace přebytků úzce svázána. Nové požadavky na regulaci nikdy nezaskočily GreenBonO natolik, aby musel být odstaven na smetiště dějin a nahrazen novějším modelem.
Také ve schopnosti regulovat velké střešní FVE s velkým počtem spotřebičů přebytků těžko najde rovnocennou konkurenci. Zkuste zajistit např. regulaci tohoto rozsahu, nebo tohoto libovolným konkurenčním výrobkem!

Následující text slouží jako průvodní dokumentace k regulátoru GreenBonO.
Další informace jsou ve formě souborů typu "pdf" k dispozici v sekci DOWNLOAD. Schémata konkrétních realizací jsou v souboru greenbono_schemata.zip, dostupné firmwary a jejich popis v souboru GreenBonO-firmware.zip.

Použití

Regulátor GreenBonO je určen k dosažení maximálního možného využití vlastní vyrobené elektřiny v místech s fotovoltaickou elektrárnou připojenou k veřejné síti.
Regulátor řídí spotřebu elektřiny uvnitř objektu tak, aby minimalizoval přetok elektřiny do sítě. Obvykle k tomu využívá spotřebičů nočního proudu. Tyto spotřebiče musí mít schopnost akumulovat energii načerpanou v době nočního proudu tak, aby byly schopny vykrýt potřeby domácnosti po zbytek dne. Vesměs jsou to elektrotepelné spotřebiče: bojlery k ohřevu TUV, topná tělesa akumulačního ústředního vytápění, elektrické podlahové topení, akumulační kamna a přímotopy. Vzhledem k tomu, že v době mimo interval nízkého tarifu původně napájeny vůbec nebyly, je u nich napájení přebytky z FVE vždy jen něco navíc a jakkoli proměnlivá intenzita tohoto napájení přitom není ničemu na závadu. Výsledkem je vždy jen částečné či úplné načerpání potřebné energie v časovém předstihu a výhradně z vlastních zdrojů, kterému pak odpovídá úměrné snížení nákupu nočního proudu. Vhodnost těchto spotřebičů vyplývá také z faktu, že se drtivou měrou podílí na celkové energetické náročnosti domácnosti a jsou proto velkým zásobníkem pro ukládání přebytků energie.

Významným přínosem regulace přebytků je také omezení nárůstu síťového napětí, které přetoky zákonitě vyvolávají. Tato vlastnost nabývá významu s rostoucím počtem instalovaných FVE.

Následující levý graf dokumentuje celkovou výrobu FVE v době před a po nasazení regulátoru, rozčleněnou na spotřebu v místě výroby a přetoky do sítě. První zima byla bez regulace, zatímco v následujícím zimním období byla již spotřeba v místě výroby v režii regulátoru GreenBonO. ( podklady pro grafy pochází výhradně z fakturačních elektroměrů)

Kliknutím na graf ho zobrazíte v plném rozlišení.
celková výroba rozčleněná na vlastní spotřebu a odvod přebytků do sítě celková spotřeba RD rozčleněná na vlastní elektřinu a elektřinu nakupovanou ze sítě

Z prvého grafu je jasně vidět, že s nasazením regulátoru významně pokleslo množství elektřiny dodávané do sítě.
V druhém grafu je pak vidět, jak o stejnou hodnotu také poklesla spotřeba nakupované elektřiny.

Technické parametry:

Napájecí napětí:230V 50Hz (nutné je připojení na tu fázi, na kterou je vyvedena FVE)
Povolené napětí na svorkovnicích: - horní svorkovnice (vedle LED diod): 5V DC

- dolní svorkovnice (napájení regulátoru a kontakty relé): 250V 50Hz
(jediná fáze na všech svorkách!)
analogové vstupy:3 vstupy, rozsah {-2,5V ... +2,5 V DC} (proti svorce Vcc/2 ) 10 bit D/A převod, pro externí proudové transformátory

+ volitelně: jeden vestavěný proud. transformátor 0 ... 12A~ (pro jednofázovou verzi)

digitální výstupy pro plynulé řízení výkonu:
výstupy SSR 		3 výstupy s řídícím signálem 5V/20mA: (pro externí SSR)

1.) (standardně) pro SSR (solid state relay) se spínáním v nule (pulsní modulace, spíná po jednotlivých, celých sinusových periodách (vždy obě půlvlny - bez ss.složky a vf.rušení, ale zdroj flikru))
2.) nebo (pomocí firmwaru "phctrl") pro SSR s okamžitým spínáním (fázové řízení (*) - toto provedení vyžaduje odrušovací filtr proti vf rušení, nevytváří flikr)

každý jeden výstup může ovládat 2 SSR doporučeného typu (s odběrem řídící elektrody 8,5mA/5V), a dokáže tak symetricky řídit 3-fázový spotřebič
reléové výstupy:
výstupy relé 		celkem 5 relé, každé se spínacím kontaktem 230V~/5A:

4 x relé pro postupné připojování zátěže

1 x relé (K5) s volitelnou funkcí: spínací hodiny nebo páté relé kaskády

datové rozhraní pro komunikaci s PC: RS485, protokol MODBUS, (9600,8,N,1)
regulace spotřeby přebytků z FVE: v prvním stupni plynulé řízení příkonu 0 ... 100% (v jednofázové verzi až kaskáda tří plynule řízených spotřebičů)
v dalších stupních připínání neregulovaných spotřebičů se současnou regulací v prvním stupni
galvanické oddělení: elektrická pevnost mezi elektronikou (5V DC - horní svorkovnice) a silovou částí (230v AC - dolní svorkovnice): 4kV 50Hz, 1 minuta
stupeň krytí (ČSN EN 60529): IP 20
Doporučené prostředí (ČSN 33 2000-3):třída AB4 (-5...40°C, 5...95% rel.vlhkosti)
Přípustné skladovací podmínky:-15...70°C, 5...95% rel.vlhkosti
rozměry [mm] (š,v,hl): 105 x 95 x 59 (skříňka MODULBOX 6M)

(*) Pozn:
Řídící signál pro fázové řízení má charakter PWM 100Hz a lze ho případně použít k převodu na DC výstup 0..5V (RC členem), nebo na DC výstup 0..10V (převodníkem PWM/DC) (řídící impulz je vždy ukončen těsně před koncem půlperiody síťového napětí, šířka impulzu je řízena od nuly do téměř celé šířky půlperiody)
DC výstup 0..5V lze vytvořit i ve standardním režimu "spínání v nule", ale pouze na výstupu DO6 zde popsaným postupem

Cena a obchodní podmínky: viz. ceník fy Yorix

Vliv elektroměrů na výsledek regulace

Úvodem této kapitoly je potřeba zdůraznit, že výsledek regulace přebytků je závislý na tom, jakým způsobem zaznamená a vyhodnotí naměřenou elektřinu elektroměr na hranici veřejné sítě. Technická dokumentace elektroměrů tuto vlastnost označuje jako pracovní mód elektroměru a každá regulace přebytků, má-li dosahovat požadovaného efektu, se musí tomuto módu přizpůsobit. U prvních dvou níže popisovaných algoritmů se jedná o čtyřkvadrantové elektroměry, které umí rozlišit směr toku elektřiny a jsou povinně nasazeny u všech licencovaných elektráren.
Algoritmus, často používaný u nelicencovaných FVE, je blíže popsán v bodě 3 následujícího textu.

Měřící módy čtyřkvadrantových elektroměrů

1. Starý mód - měření jediné (součtové) hodnoty - končí v roce 2015!

Tento čtyřkvadrantový elektroměr vychází z chování klasického kotoučového elektroměru. Průběžně měří tok energie v každé fázi. V krátkých časových intervalech takto vždy naměří tři malá energetická kvanta, která následně (s ohledem na znaménka!) sečte do jediné hodnoty a tuto výslednou sumu přičte k obsahu akumulačního registru.
Tento registr kumuluje hodnotu naměřené energie tak dlouho, až dosáhne úrovně odpovídající jednomu impulsu pro počítadlo - podle toho, zda dosáhl kladné či záporné hodnoty poté vyšle impuls k inkrementaci počítadla odběru či spotřeby a sám se vynuluje.
Dokud hodnota registru nedosáhne kladné nebo záporné meze pro generaci impulsu, může podle směru toku elektřiny cvičit nahoru-dolu, aniž by to mělo vliv na fakturační údaj elektroměru (počet impulsů se nemění - je to podobné, jako když kotoučový elektroměr cuká střídavě doleva-doprava, ale nikdy se neotočí).
K zastavení tohoto elektroměru není tedy nutné zajišťovat nulový proud ve všech vodičích, ale stačí udržovat energetickou rovnováhu mezi celkovým tokem energie do objektu a z objektu. Když např. v jedné fázi ze sítě odebíráme 20A a v jiné fázi zase 20A do sítě dodáváme, tento elektroměr vyhodnotí nulu.
Rozsah mezních hodnot akumulačního registru navíc umožňuje účinně provozovat pulsní regulaci, při níž se (v našem speciálním případě, kdy je v přípojném místě zdroj elektřiny) v krátkých časových intervalech střídá odběr s dodávkou.
Tento (součtový) algoritmus elektroměru se dnes však stává již pouhou historií a nakonec bude i v místech, kde je dosud nasazen, nahrazen elektroměrem s novým algoritmem, viz. dále. Výslovně to nařizuje vyhláška 82/2011 v §6, odst.6.

2. Nový mód - měření a účtování elektřiny v každé fázi samostatně (od.r.2012, v r. 2015 definitivně nasazen u všech FVE)

Zásadní rozdíl: K zastavení tohoto elektroměru je nutné zajišťovat energetickou rovnováhu v každém fázovém vodiči.

nálepka s trojúhelníkem identifikuje měření každé fáze zvlášť Od roku 2012 je nutno počítat s tím, že u každé nové FVE bude elektroměr s tímto novým algoritmem. Rozdíl oproti předchozímu algoritmu je z technického hlediska nepatrný - tři naměřené hodnoty se zde nesečtou do jediné, ale uloží se do tří samostatných registrů a pak se také samostatně vyúčtují.
Toto se děje uvnitř elektroměru, který byl konstruován pro součtový algoritmus, takže má na displeji jen jeden vektorový kříž - indikátor směru toku elekřiny. Tento kříž dokáže zobrazit pouze jedinou hodnotu, a zobrazuje (jak jinak) - tu součtovou, která je zde již nejen bezcenná, ale dokonce matoucí.
Na území spravovaném společností E.On bývají tyto elektroměry označeny nálepkou s trojúhelníkem - viz obr. vpravo. (elektroměry bez nálepky nebo s kolečkem měří součet).

Přechod na účtování podle nového algoritmu je pro distributory vždy výhodný, a pro majitele FVE je vždy nevýhodný. Ve srovnání se starým měřením zde dochází k dalšímu okleštění dosažitelné vlastní spotřeby.

Regulace přebytků podle nových pravidel je technicky i finančně náročnější, než regulace podle původních pravidel: zdaleka již nestačí pouhá celková energetická rovnováha, ale musí být zajištěna energetická rovnováha v každé fázi. To s sebou přináší nutnost regulovat každou fázi samostatně (což není zas takový problém - stačí nahrát do GreenBona nový program), ale je nutno také zajistit pro každou fázi dostatek spotřebičů a přizpůsobit zapojení novým podmínkám.

Velmi nepříjemná situace pak nastává, když je elektroměr s novým algoritmem nasazen do přípojného místa s regulací přebytků určenou k původnímu elektroměrovému algoritmu. Regulace se stává nejen neúčinnou, ale dokonce prodělečnou. Pak je nutno rychle provést přizpůsobení regulačního algoritmu GreenBona novému měření a obvykle i nemalé zásahy do původního zapojení regulace (rozložení spotřebičů přebytků do jednotlivých fází).
Řešení je popsáno v dokumentu 2015 - konec součtové regulace konec součtové regulace.

3. Další mód (už nikoli 4-kvadrantový) zazamenávající absolutní hodnoty průtoku elektřiny (FVE bez licence a dotací)

Nová legislativa (Slovensko 2015, Česko 2016) již nevyžaduje licenci u malých výrobců, ale také nepředepisuje distributorům povinný odkup přebytků a tím pádem ani nutnost jejich měření; původně navrhovaný zákaz budoucím malým výrobcům dodávat elektřinu do sítě v jakémkoli okamžiku nakonec sice neprošel, takže přetok do sítě nebude trestným činem, ale nadále zůstane vnímán jako nežádoucí: "Výroba je určena především pro krytí vlastní spotřeby". Způsob vypořádání přetoků mezi výrobcem elektřiny a správcem sítě legislativa neřeší a není vyloučeno, že distribuční společnosti budou přetoky penalizovat. To pak mohou řešit kupř. nasazením elektroměru s módem, který registruje absolutní hodnotu naměřené elektřiny, takže bez ohledu na skutečný směr toku elektřiny vždy zaznamená odběr a také ho vyúčtuje.

V důsledku toho:

  • Za elektřinu, kterou pustíte do sítě, zaplatíte "pokutu" stejně velikou, jako by jste totéž množství elektřiny ze sítě odebrali.
  • Pulsní regulace pomocí SSR spínaných v nule (dosud používaná všemi výrobci regulátorů přebytků) s takovým elektroměrem nezabírá! Je na něj příliš pomalá!
Existuje na to řešení? Inu ano, ale vyžaduje rychlejší pulsní modulaci, než je spínání v nule. Ani seberychlejší digitální elektroměr totiž nedokáže vzájemně rozlišit činnou a jalovou složku z kratšího intervalu, než je jedna perioda (nebo alespoň půlperioda) základní harmonické. Musí tedy zaznamenat "časové okno" o délce jedné sinusové periody, z něho určit činnou a jalovou složku a teprve pak může z výsledku udělat absolutní hodnotu. (Obdobně jako v našem případě současné dodávky kombinované s pulsním odběrem, tak i při čistě kapacitní či induktivní zátěži se uvnitř jedné půlperiody střídá odběr s dodávkou {součin u*i střídá znaménko po čtvrtperiodách} a každý elektroměr při tom musí zaznamenat pouze jalovou složku a nikoli zároveň činnou dodávku a odběr).

Fázové řízení

Nejjednodušší regulací, která zde obstojí, je pak fázové řízení (tyristorů, triaců, nebo SSR spínaných okamžitě). Když pak regulace střídá odběr s dodávkou shodných velikostí uvnitř každé půlperiody, je naměřená činná elektřina nulová. Nenulová je jalová elektřina (dá se trochu kompenzovat kondenzátory, jako třeba v zářivkách). Nepříjemnou vlastností je generování vyšších harmonických a rádiového rušení. Regulace se proto neobejde bez odrušovacího filtru.

Pozn.:
Bod 3 této kapitoly je zatím spíše teoretickou úvahou typu co by...kdyby. Po zkušenostech s výměnou elektroměrů však už dobře víme, že nejen my, ale i distribuční firmy optimalizují peněžní toky technickými prostředky a úvahy o tom, kterým směrem by se mohl ubírat příští vývoj, se lze dočíst v jednom z dokumentů z konference ČEZu 2015. Z našeho pohledu stojí za pozornost zejména Závěry na str.25 a obzvlášť jejich poslední bod.

Popis funkce regulátoru

Pulsní regulace v rozsahu 0...100% jmenovitého příkonu spotřebičů

blokové schéma plynulé regulace přebytků FVE
Aby bylo možno kdykoli spotřebovávat veškeré přebytky z FVE, je nutno plynule přizpůsobovat okamžitý příkon určených spotřebičů velikosti přebytků.
Plynulou regulaci zajišťuje regulátor GreenBonO řízením výkonové tyristorové součástky - polovodičového relé SSR (Solid State Relay).

Samotný regulační proces má na starosti proporcionálně-integrační (PI) regulátor (ve schématu zelený). Ten průběžně měří činnou složku regulovaného proudu, tekoucí mezi odběrným místem a veřejnou sítí a snaží se ji udržovat na žádané hodnotě, která je obvykle nula.

Výstupní signál PI regulátoru (ve schématu rudá přerušovaná čára) řídí hustotu spínání jednotlivých celých sinusových period pomocí polovodičového relé SSR a umí touto formou zajistit řízení příkonu spotřebičů napojených na výstup SSR v plném rozsahu jejich jmenovitých hodnot (0...100%).

Příklad:
předpokládejme přebytky z FVE 100W, první spotřebič s jmenovitým příkonem 500 W
Výstup regulátoru se záhy ustálí ve stavu, kdy SSR spíná každou pátou síťovou periodu, v níž si spotřebič vezme 100W z FVE a 400W ze sítě. V následujících 4 periodách je pak spotřebič odpojen a FVE posílá v každé periodě 100W do sítě.
Spotřebič odebírá po dobu 20% celkového času svůj plný výkon, což je totéž, jako kdyby po celou dobu odebíral 20% svého jmenovitého výkonu, tedy 100W.
Mezi sítí a objektem přitom nastává energetická rovnováha; odběr 400W v první periodě je vykompenzován dodávkou 100W v následujících 4 periodách.

Druhý řídící signál (ve schématu modrá přerušovaná čára) zajišťuje postupné připojování spotřebičů. Jakmile regulátor dosáhne saturace v jedné z obou mezních hodnot svého výstupu, je jasné, že plynulá regulace se ocitla mimo řiditelný rozsah a automaticky se po stanovené době nepřetržitého trvání tohoto stavu (2s) provede korekce připojeného počtu spotřebičů (buď přidá další spotřebič sepnutím relé, které je právě na řadě, nebo odebere spotřebič vypnutím posledního sepnutého relé). Pokud poté saturace trvá, algoritmus korekce počtu spotřebičů se opakuje (připojí či odpojí další stupeň).
Tento prostý algoritmus je velmi účinný a zajišťuje správnou funkci regulace bez toho, že by přístroj musel znát velikost jednotlivých spotřebičů. Správně reaguje i na všechny změny odběru elektřiny v přípojném místě - ať již jsou to náhodně připojované spotřebiče nebo např. odpojení bojleru termostatem po jeho nahřátí.

Priorita spínání spotřebičů

priorita ovládaných spotřebičů vyplývá z popsaného algoritmu : nejvyšší prioritu má spotřebič připojený přímo na výstup SSR (v blok.schématu spotřebič Z0), postupně následují spotřebiče spínané kontakty GreenBona v pořadí K1, K2...K5 (ve schématu spotřebiče Z1 .. Z4). Priorita je tedy jednou provždy dána zapojením.
Všechny spínací kontakty mají shodné parametry a samostatné vývody, u každého z nich lze podle místní situace zvolit, k čemu bude použit. Blokové schéma, jakož i v dalších schémata uvedená níže, proto chápejte pouze jako příklad zapojení - jednu z mnoha možností. Kterýkoli regulační stupeň lze vynechat, regulátor se s tím bezpečně vyrovná.
Nutno přitom dodat, že absolutně nejvyšší prioritu mají nakonec stejně vždy běžné spotřebiče domácnosti, které majitel zapíná kdy se mu zlíbí, a které GreenBonO neovládá, zato vždy na ně reaguje příslušnou korekcí spotřeby "svých spotřebičů".

Plynule řízené versus neřízené (pouze připojované) spotřebiče

Pulsní regulace je přípustná pouze na elektrotepelných spotřebičích! V žádném případě nezkoušejte na řízenou větev připojit motor (brzy by shořel), ani cívku stykače nebo relé (záhy se umlátí).
Aby bylo možné spojité řízení odběru v celém rozsahu výkonu FVE, musí SSR v každém okamžiku regulace plynule řídit minimálně jeden spotřebič a zároveň musí být rozsah spojitého řízení alespoň stejně velký, jako největší možný skok v zátěži (=výkon dalšího spotřebiče připínaného natvrdo, bez regulace).
Zároveň je nutno pamatovat na to, že např. bojler tuto funkci nedokáže vykonávat po celý den z toho důvodu, že může dojít k jeho nahřátí a odpojení termostatem. Takovou situaci je nutno řešit přepojením (komutací) pulsní regulace na jiný spotřebič.
Komutace pulsně regulovaného výstupu (viz. schéma na str.2 dokumentu na tomto odkazu) je zajišťována v každém stupni regulace pomocí stykače s kontakty "31" (tři spínací, jeden rozpínací).

Komutace pulsně regulovaného výstupu přináší čtyři velké přednosti:

  • není nutné použít pro nejvyšší prioritu nejsilnější spotřebič
  • vždy je zajištěna zátěž pro pulsní regulaci
  • každý spotřebič má garantován svůj stupeň priority
  • vždy stačí plynule regulovat jediný spotřebič a omezit tak flikr na minimální úroveň dosažitelnou s danými spotřebiči

"Spínání v nule", flikr a jeho omezování

Charakter řídícího signálu z regulátoru GreenBonO vyžaduje, aby polovodičový spínač byl typu SSR-ZS (solid state relay – zero switch) – triak s funkcí spínání v nule (a také s bezpečným galvanickým oddělením řídícího okruhu od silového; el.pevnost 4kV !).

Způsob řízení spínáním v nule byl zvolen proto, že je ze všech forem pulsní regulace nejjednodušší, zároveň z hlediska elektromagnetické kompatibility patří k těm šetrnějším a byť nejpomalejší ze všech modulací, je 4q elektroměrem ještě akceptován.

Má však i jeden velmi závažný nedostatek:

Zpětný vliv na síť - Flikr

Pulsní regulace střídá stavy "spotřebič připojen" se stavy "spotřebič odpojen", vyvolává tím skokové změny v proudovém odběru, které zákonitě vyvolávají změny úbytku napětí na přívodním vedení. Výsledkem je kolísání napětí sítě, které, byť tak malé, že na osciloskopu je obvykle nerozpoznatelné, u klasických žárovek a zářivek vyvolává blikání, které je velmi intenzívně (a negativně) vnímáno lidským okem (nejvýrazněji okolo 9Hz) a u řady lidí vyvolávající bolesti hlavy. Tento jev je nazýván flikr ( amplitudová modulace síťového napětí o velikosti desetin až jednotek Voltů a frekvenci tisícin až desítek Hertzů).
Právě neblahý vliv na fyziologii člověka byl v minulých desetiletích shledán natolik závažným, že kvůli němu vznikly nové a velmi přísné evropské elektrotechnické normy. Proto je nezbytné tento jev co nejvíce omezit - předem s ním počítat a včas volit vhodné řešení.

Elektrické parametry ovlivňující velikost flikru

Velikost flikru je:
  • přímo úměrná jmenovitému výkonu regulovaného spotřebiče (lineární funkce: poloviční výkon = poloviční flikr)
  • přímo úměrná impedanci sítě v místě připojení (lineární funkce: poloviční impedance = poloviční flikr)
  • nepřímo úměrná frekvenci spínání (s třetí odmocninou: poloviční frekvence = 80% původní míry flikru; nebo jinak: půl flikru = 8x snížit frekvenci)

Impedance sítě se může ve dvou různých přípojných místech navzájem lišit i více než desetinásobně. V místech s měkkou sítí pak bývá flikr velký problém - překračuje přísné meze stanovené evropskými harmonizovanými normami.

S impedancí sítě nic nenaděláme (výkon FVE ji příliš neovlivní a správce sítě kvůli nám hned tak elektrické vedení posilovat nebude), takže nakonec můžeme účinně omezit flikr pouze omezením výkonu pulsně řízeného spotřebiče. Proto je velmi špatným řešením použít jediný velký spotřebič a spoléhat na to, že pulsní regulace si s tím poradí.
Nejúčinnějším řešením je rozložit spotřebu přebytků do většího počtu menších spotřebičů a v každém okamžiku v každé regulované fázi pulsně řídit jen jeden spotřebič - ostatní připínat natvrdo. Ideálně rozpočítat celkový výkon FVE na celkový počet regulačních stupňů regulátoru a na každý regulační stupeň připojit jeden malý spotřebič. 8 stupňů regulace, které GreenBonO poskytuje, není samoúčelná snaha překonat konkurenci větším počtem výstupů, ale cesta k co nejjemnější a nejšetrnější regulaci. (proto ani u 1f. FVE není od věci použít bojler s 3f. topným tělesem (původní výkon rozložený do 3 malých spirál)- pro 3.stupňovou regulaci)

Samotný regulátor GreenBonO může ke snížení míry flikru přispět pouze snížením frekvence spínání. K tomu účelu má na záložce "konfigurace relé" možnost volby "pomalá modulace". Do jisté míry to ke snížení flikru přispěje (k dosažení polovičního flikru je nutné osminásobné zpomalení spínání), ale zpomalování (což je vlastně prodlužování stavů sepnuto/vypnuto) nejde donekonečna - velmi brzo ho přestane akceptovat elektroměr a začne měřit současný odběr i dodávku - regulace tím přestane plnit svůj účel (projeví se to zrychleným blikáním LED elektroměru, indikující impulsy činné energie [kWh]). Proto je vždy nutno při navolení tohoto režimu sledovat elektroměr a případně korigovat míru zpomalení změnou integrační konstanty PI regulátoru. (na záložce "okamžité hodnoty", CTRL + klik na obr. PI regulátoru zviditelní nastavovací prvky, zmenšování integrační konstanty "kI" zpomaluje přepínání-snižuje flikr)
Zde je také nutno konstatovat, že zpomalování modulace má určitý smysl pouze u elektroměrů, registrujících 500 imp/kWh. Elektroměry s vyšším počtem imp/kWh jsou k výše popsané pulsní modulaci značně netolerantní. Tam nezbývá než zůstat u rychlé modulace, nebo dokonce začít uvažovat o fázovém řízení.

Podpůrné funkce - dobíjení spotřebičů elektřinou ze sítě v době nízkého tarifu

Virtuální spínací hodiny SH1 k omezení spínání nízkého tarifu v nežádoucích časových intervalech
Je-li důvodný předpoklad, že přebytky elektrické energie z FVE nahradí část nakupovaného nočního proudu, může být v určitých časech vhodné zamezit sepnutí některých spotřebičů signálem z HDO a zajistit tak "úložný prostor" pro přebytky vlastní elektřiny. GreenBonO je pro tento účel vybaven softwarovým submodulem, plnícím funkci spínacích hodin SH1 s výstupem na relé K5.

Příklad:
akumulační nádrž pro vytápění RD je vybavena 3fázovou topnou vložkou ovládanou nočním proudem a zároveň druhou, původně záložní vložkou, která je nyní použita jako doplňková zátěž ke spotřebě přebytků. Obě vložky sdílejí stejnou nádrž, relé K5 se může hodit k omezení času sepnutí hlavní topné vložky.

Virtuální spínací hodiny SH2 pro kombinované řízení spotřebičů regulátorem přebytků i signálem nočního proudu
Existují ale i přístroje, u nichž je žádoucí, aby se účastnily spotřeby přebytků, ale zároveň je nutné zajistit zásobu energie nezávisle na slunci. Typickým příkladem je bojler. Často má jedinou spirálu, která musí zároveň být k dispozici při regulaci přebytků a zároveň musí reagovat na ovládání signálem nočního proudu, aby bylo dostatek teplé vody i ve dnech slabé sluneční aktivity. K tomu účelu slouží virtuální spínací hodiny SH2 a konfigurační program umožňující zvolit, která relé mají na signál těchto hodin reagovat.

Komunikace s okolím
GreenBonO nemá vlastní klávesnici ani displej. Má ale sériové datové rozhraní RS485, které umožňuje uživateli propojení přístroje s PC a následnou konfiguraci přístroje úpravou dostupných parametrů či sledování měřených veličin v reálném čase. PC-program k tomu určený funguje ve všech verzích OS Windows (od verze 98) a je zde volně ke stažení.

Jednofázová a třífázová verze

Podle počtu měřených fází podporuje (jeden a týž) přístroj tři verze použití (s různým firmwarem):
  • Jednofázová verze:
    Uvnitř přístroje je vestavěn měřící proudový transformátor s lineárním rozsahem 0-12A. Tento rozsah měření proudu je dostačující pro FVE do výkonu okolo 5 kWi (pro větší výkon lze použít externí měřící transformátor s větším proudovým rozsahem). Jednofázová verze vyžaduje, aby byl k dispozici dostatek jednofázových spotřebičů. Měří a řídí se ta fáze, na níž je FVE. Ostatní dvě fáze nejsou měřeny, takže jejich proud není zohledněn při regulaci a je vždy nakupován ze sítě. Proto je v této verzi žádoucí přepojit co nejvíce jednofázových okruhů odběrného místa na tuto (měřenou) fázi, jinak regulace nemá žádaný efekt.

  • Třífázová verze: (pouze ke starým elektroměrům)
    Přístroj také může měřit všechny 3 fáze pomocí tří externích měřících transformátorů připojených k jeho analogovým vstupům. V takovém případě může GreenBonO ovládat jednofázové i třífázové spotřebiče. Třífázové měření přitom spolehlivě zajistí zohlednění veškeré spotřeby domácnosti. Výkon FVE v této verzi může být podstatně vyšší (stovky kW), podmínkou je pouze přiměřené dimenzování periférií regulátoru GreenBonO: proudových měřících transformátorů a spínacích přístrojů.
    (Díky převodu I/U zajištěnému proudovým transformátorem s odporovou zátěží je na vstupu regulátoru vždy střídavé napětí s rozsahem 0..1,5V. Výstup je pak vždy dán vzájemným poměrem sepnutých a nesepnutých period síťového napětí) takže chování samotného regulátoru pramálo záleží na velikosti výkonu, který řídí. U velkých výkonů spíše přestává stačit velikost reléové kaskády, což lze řešit použitím tří regulátorů - pro každou fázi samostatně, případně doplněním rozšiřujících modulů, s nimiž lze vytvořit až 50-stupňovou reléovou kaskádu.)

  • Tříregulátorová verze:
    Tato verze je určena pouze pro 3f. FVE, a to do odběrných míst s elektroměrem, který (podle nové energetické vyhlášky) vyhodnocuje (a účtuje) tok elektřiny každou fází samostatně. V takovém odběrném místě vzniká nutnost samostatně v každé fázi řídit také spotřebu přebytků. Firmware regulátoru GreenBonO, určený pro tuto verzi, je proto vybaven třemi samostatnými PI regulátory. Každý PI regulátor samostatně řídí odběr ve své fázi (prostřednictvím svého SSR). Také každé z pětice relé má pevně určeno, který PI regulátor jej bude ovládat a musí pak spínat stykač přídavné zátěže napájené z přidělené fáze. Řízení spotřebičů v každé fázi samostatně zde vede k požadavku používat jednofázové spotřebiče, nebo třífázové spotřebiče zapojené do hvězdy, kde uzel hvězdy musí být nulován. Také nutnost spravedlivě rozdělit relé z kaskády všem 3 fázím zde radikálně sníží počet stupňů regulace, jehož důsledkem je vyšší poměr pulsně řízené spotřeby vůči spojité spotřebě a tím také více flikru (blikání žárovek). Proto by se použití této verze mělo omezit jen do míst s malou 3f FVE. V místech, kde výkon 3f. FVE přesahuje 10 kW, je již nutným řešením použití 3 ks regulátoru GreenBonO.

Provedení

Veškeré funkce přístroje zajišťuje software použitého mikrokontroléru Atmel ATMega16L. Hardware je proto relativně jednoduchý a omezuje se na zajištění nutného fyzického rozhraní s okolím přístroje.

Vnější provedení

Regulátor GreenBonO je vestavěn do skříňky Modulbox 6M, uzpůsobené k montáži na DIN lištu. Rozmístění V/V svorek a jejich význam je patrný ze štítku přístroje.
Horní strana přístroje (s diodami LED) je vyhrazena pro svorky elektroniky s bezpečným malým napětím (5V).
štítek přístroje Všechny horní svorky jsou galvanicky odděleny od sítě s elektrickou pevností 4kV~. (mezi sebou navzájem již galvanicky oddělené nejsou).
Galvanické oddělení horní svorkovnice od sítě musí zůstat navěky - nikdy nespojujte žádnou z těchto svorek se síťovými vodiči - ani se středním, ba ani s ochranným vodičem PE! Potenciál elektroniky musí zůstat plovoucí, aby při galvanickém propojení s PC došlo k hladkému vyrovnání potenciálů obou zařízení.
  • na první dvě svorky zleva je vyvedeno rozhraní RS485 sériové komunikace.

  • Dalších šest svorek slouží jako analogové vstupy pro měření střídavého napětí (ze sekundárů proudových transformátorů). Aby unipolární A/D převodník mikroprocesoru (0...5V) mohl měřit analogové hodnoty obou polarit, je společná svorka všech analogových vstupů posunuta na napěťovou hladinu 2,5V (svorka Vcc/2). Měřitelný rozsah bipolárních analogových hodnot je pak -2,5V … +2,5V. Vstupy AI4,AI3,AI2 jsou určeny pro měření proudu fází L1, L2, L3 třemi externími proudovými transformátory, AI1 (původně rezerva) je překonfigurován na výstupní a je určen k řízení třetího SSR, vstup AI0 je využit pro získání informace z HDO o právě běžícím tarifu nakupované elektřiny. (kontakt relé bez cizího napětí, zapojený mezi tento vstup a GND ( GND (ground)společný potenciál celé elektroniky)

  • Poslední tři svorky obsahující dva digitální výstupy 0/5V a jejich společný potenciál GND ( GND (ground)společný potenciál celé elektroniky ). Jsou zdrojem řídícího signálu 5V,20mA pro řízení polovodičových spínačů SSR (Solid State Relay). SSR doporučená v jiné části tohoto dokumentu mají odběr řídících obvodů 8,5mA/5V a galvanicky oddělené silové obvody s optickou vazbou a dostatečnou elektrickou pevností. Jedním výstupem regulátoru GreenBono proto lze řídit dvě tato SSR. Celý regulátor však "utáhne" maximálně 3 SSR. Na více již nestačí interní zdroj +5V.
průvlak silového vodiče jádrem měřícího transformátoru (náhled do odkrytého přístroje)
průvlak provádějte vždy lankem!
Pro snadné provlečení sejměte štítek a krytky svorkovnic.
Pozn.:
Uvnitř přístroje je umístěn ještě jeden analogový vstup – měřící transformátor TM1 s lineárním rozsahem 0 … 12A, který je určen pro jednofázovou verzi regulace a zajišťuje v této verzi, že jediným nutným periferním obvodem regulátoru GreenBonO je spínač SSR, (samozřejmě kromě připojovaných spotřebičů).
K vytvoření kompletního proudového snímače pak stačí izolovaný silový vodič protékaný měřeným proudem provléci otvorem v jádru měřícího transformátoru TM1.
Tento vodič prochází svisle vnitřkem přístroje, mezerou mezi první a druhou čtveřicí svorek v dolní i horní svorkovnici (na fotografii vpravo je to tlustý rudý vodič). Izolace vodiče je nutná! (Aby se uvnitř přístroje nedalo sáhnout na jiné, než malé napětí, galvanicky oddělené od sítě).

Dolní strana přístroje je vyhrazena pro silové svorky (jsou, či mohou být galvanicky spojené s napětím rozvodné sítě 230V~).
  • Svorky L1 (fáze) a N (střední vodič) slouží k napájení přístroje. K zajištění správné funkce přístroje je nutné, aby se jednalo o stejnou fázi, na níž je připojen výstup z měniče fotovoltaické elektrárny. Toto napětí totiž slouží jako referenční hodnota při stanovení fázových posuvů všech ostatních měřených analogových hodnot.

  • Na svorkové páry označené K1..K5 jsou vyvedeny spínací kontakty stejnojmenných relé. Zatížitelnost kontaktů je 5A~. Pokud je těmto kontaktům předřazen polovodičový spínač SSR, probíhá spínání kontaktů bez zatížení a nedochází k jejich opotřebení (před změnou stavu relé zablokuje GreenBonO řídící signál do SSR, po dokončení změny zase řídící signál do SSR uvolní). Relátka bez předřazeného SSR tuto ochranu nemají a pro zamezení jejich předčasného opotřebení je proto vhodné spínat jimi zátěž nepřímo-přes přídavný stykač.
POZOR ! Dolní svorkovnice je určena pro napětí 230V, nikoli 400V! Smí tam být všude pouze jediná fáze!

Vnitřní provedení

obrazec plošného spoje

Galvanické oddělení

Veškerá elektrická výbava přístroje je umístěna na jediné desce dvoustranného plošného spoje, obsahující

  1. jak obvody malého napětí (5V pro mikroprocesor, 18V pro cívky relé), viz. horní část obrázku,

  2. tak i silové obvody s napětím 230V~ (svorkovnice, kontakty relé, primár napájecího transformátoru), v dolní části obrázku

Oba uvedené druhy napětí jsou od sebe vzájemně galvanicky odděleny.
Elektrická pevnost mezi silovou a řídící částí přístroje (vyhoví zkoušce přiloženým napětím 4 kV~ po dobu 1 minuty) je zajištěna následovně:
  • Na obou stranách desky plošného spoje odděluje oba potenciály více než 15mm široký pruh bez mědi (viz. obr.)
  • Součástky uvnitř přístroje, které jsou připojeny k oběma potenciálům (použitá relé a napájecí transformátor) mají oba potenciály vzájemně galvanicky oddělené s elektrickou pevností 4kV~ garantovanou jejich výrobci.
Totéž se vyžaduje i od periférií připojených k řídícím svorkám (měřících transformátorů a spínačů SSR); přístroje doporučené v tomto dokumentu tuto podmínku splňují

Popsané rozvržení součástek na desce plošného spoje zajišťuje při přístupu omezeném jen na stranu součástek ochranu před nebezpečným dotykem stupněm krytí IP20. Po sejmutí čelního krytu (s nalepeným štítkem) nelze nikde uvnitř nasahat nebezpečné napětí.

Předepsané zapojení

Zajištění odolnosti GreenBona proti rušivým vlivům okolí

Striktně oddělujte silovku od elektroniky!

Kabeláž:

Vodiče elektronické části - tedy vše, co je připojeno do horní svorkovnice (snímače proudu, signál NT z bezpotenciálového kontaktu stykače, řídící výstup 5V pro SSR), nesmí být v souběhu se silovými kabely, a už vůbec ne spolu se silovými vodiči uvnitř jednoho vícežilového kabelu nebo v jednom vodičovém svazku či žlabu!

Proč?

Zejména u souběhu se spínanými silovými vodiči (kde se napětí mění skokem z nuly na 300V) hrozí zavlečení velkých napěťových špiček do elektronické části, což způsobuje nepředvídatelné chování mikroprocesoru - chyby komunikace, náhodný přepis jeho pamětí či úplné zatuhnutí programu a v extrémním případě může dojít i ke zničení mikroprocesoru. Pokud se nelze souběhu kabelů vyhnout, pak alespoň maximalizujte vzájemnou vzdálenost (aspoň 5cm), pro elektroniku použijte stíněný kabel a jeho stínění přitom zásadně připojujte jen na straně GreenBona, do svorky GND( GND (ground)společný potenciál celé elektroniky) GreenBona.

V rozvaděči: (silovka nalevo, slaboproud napravo!)

Zapomeňte na eleganci a dejte přednost spolehlivosti. Stíněný kabel nikdy nerozholujte již u vývodky na vstupu do rozvaděče (to se dělá u silových kabelů, ale zde je to zcela nevhodné), ale až těsně u GreenBona, žíly kabelu připojte rovnou do svorek GreenBona a nezapomeňte připojit i stínění.
Ostatním slaboproudým vodičům (jedná-li se o krátkou trasu pouze uvnitř rozvaděče) dopřejte vždy samostatný svazek, umístěný mimo žlab se silovkou - buď v samostatném žlabu, nebo prostě jen svazek natažený nejkratší cestou a co nejdále od silových vodičů.

Rozvod nulového vodiče provádějte zásadně paprskovitě od nulového můstku: každý jeden nulový vodič vede z nulového můstku k jedinému el.zařízení - bez odboček a rozvětvování cestou! A nezapomeňte do nulového můstku přivést to nejdůležitější - pořádnou nulu přívodním kabelem.

Minimalizujte plochy indučních smyček- pamatujte, že fázový a k němu příslušející nulový vodič spolu vytvářejí indukční smyčku vyzařující elektromagnetické pole, přímo úměrné velikosti této smyčky. Proto se snažte tyto vodiče umísťovat blízko sebe, v ideálním případě je vzájemně zkroutit do sebe (u vzájemně zkroucených vodičů (twist) vznikají velmi malé indukční smyčky, každé překroucení obrátí polaritu elm.pole, takže pole sousedních smyček se navzájem odečítá.)

Hlavní zásady lze nakonec shrnout do parafráze oblíbeného povelu z autobusových výletů:

Silovka nalevo, slaboproud napravo!

Jednofázová verze (použitelná pouze s 1f FVE, měření i regulace na jediné fázi)

V jednofázové verzi provádí GreenBonO měření i regulaci spotřeby pouze v jedné fázi.
Nutnou podmínkou je, aby právě na této fázi bylo připojeno vše, co regulaci ovlivňuje; výstup z FVE, napájení regulátoru GreenBonO, všechny spotřebiče určené k účelné spotřebě a konečně i všechny náhodně připojované spotřebiče v domácnosti, má-li být jejich odběr zohledněn při regulaci. S ohledem na efektivitu regulace je proto ideálním řešením přepojit na tuto fázi všechny jednofázové jističe v hlavním rozvaděči domácnosti. Pokud by po takové úpravě hrozilo přetížení hlavního jističe, lze určitě vytipovat silné spotřebiče obvykle používané mimo dobu sluneční aktivity (moc elektřiny se tím na nich neušetří; např. vysoušeč vlasů) a příslušné jističe ponechat na jiné fázi.

Výhody:

  • jednoduché zapojení, obvykle s využitím vestavěného proudového transformátoru
  • jediným nutným externím přístrojem je jedno SSR

Nevýhody:

  • úspory se netýkají proudu v ostatních fázích (což je u nových elektroměrů již beztak pasé); do jisté míry lze tento nedostatek řešit v domovním rozvaděči přepojením vybraných okruhů na měřenou fázi.
  • k řízení účelné spotřeby nelze použít spotřebiče napájené z více fází

Schéma zapojení:

jednofázové provedení s komutací SSR Elektrické zapojení - schema s postupnou komutací pulsního výstupu na každý spotřebič
Postupná komutace pulsně modulovaného výstupu na všechny spotřebiče není vždy nutná. Jejím cílem je zajistit v každém okamžiku pulsní řízení jednoho spotřebiče. Pokud jsou např. všechny spotřebiče v jediné akumulační nádrži, takže termostat je odpojí všechny najednou, pak je komutace bezpředmětná; stačí řídit přes SSR jen první spotřebič a ostatní připínat na plné fázové napětí.

Pozor!
Kontakty relé regulátoru mohou spínat proud do 5A, tj. zátěž do 1 kW. Pokud je zátěž větší, je nutno spínat ji přes přídavný stykač.
Cívka stykače musí být ovládána plným jmenovitým napětím, pro které je určena - nikdy ne modulovaným napětím z výstupu SSR - to pak stykač spustí rachot a dlouho nevydrží!
Na silové kontakty stykače pak už lze přivést jak modulované napětí z výstupu SSR, tak plné napětí z libovolné fáze (samozřejmě přes správně dimenzovaný jistič).

Signál "N-Tarif" pro GreenBonO musí být bez jakéhokoli vnějšího napětí a galvanicky oddělený od sítě (!) - propojuje dva vývody mikroprocesoru.
V žádném případě nepřipojujte signální vodič NT od HDO přímo do GreenBona! Nejen, že to nefunguje, ale navíc byste zavlekli do GreenBona nulák a zrušili tím galvanické oddělení elektroniky GreenBona od sítě!

Rudý jumper na levé straně desky převrací polaritu měřeného napětí
Průvlak provádějte vždy lankem! 6mm² trvale snese 58A.
(Drátem vylomíte snímač a nevratně utrhnete jeho vývody!)

Zajištění správné polarity proudu vůči napětí

Pro správnou funkci regulátoru je nutná správná polarita měřeného proudu ve vztahu k měřenému napětí (zda spolu budou ve fázi či protifázi). Ta závisí na orientaci průvlaku primárního vodiče jádrem měřícího transformátoru. U interního snímače je orientace průvlaku jasná - dolní strana směřuje do sítě, horní do objektu.

Jumper pro obrácení polarity
Při použití externího snímače (natož pak snímače jiného typu a výrobce) však jsou vždy dvě možnosti - vyjde to správně, nebo obráceně.
Aby v případě, že zafungují Murphyho zákony, nebylo nutné složitě obracet orientaci průvlaku, umí GreenBonO zajistit stejný výsledek tím, že si obrátí polaritu naměřeného napětí.
Pokyn mu k tomu dáte tím, že propojíte jumperem piny 7 a 8 na osmipinové kolíkové liště umístěné na levé straně přístroje.
(rudý jumper na fotografii demonstruje popsané propojení; normálně je jumper nasazen jen na jednom pinu jako záloha pro případné použití.)

Pozn:
V nouzi lze stejného efektu dosáhnout i bez jumperu a to vzájemným prohozením napájecích vodičů (L1 a N) GreenBona. Rozpor mezi označením na štítku a skutečností je pak pro elektrikáře (pravidelně cipovaného školením z vyhlášky č.50) sice trochu drsný, ale bez vlivu na bezpečnost zařízení; svorky L1,N vedou uvnitř přístroje pouze na primární vinutí napájecího transformátoru jištěné skleněnou pojistkou.

Správnou polaritu určíte monitorováním proudu pomocí PC připojeného k regulátoru rozhraním RS485. (vhodným spotřebičem k vyvolání dobře pozorovatelných proudových změn je rychlovarná konvice.)

Je-li orientace průvlaků správně:

  • pak PC zobrazuje proud jako kladný při nadvýrobě FVE a jako záporný při odběru ze sítě.
  • LED na SSR při nadvýrobě bliká, při odběru ze sítě je trvale zhasnuta.

Třífázová verze (pro 3f FVE, 3f měření, regulace podle elektroměru distibutora)

POZOR - od r.2012 jsou nové elektroměry, které účtují každou fázi samostatně.
Tyto elektroměry jsou dnes u nových FVE bez výjimek zaváděny všemi distributory. Zatímco u FVE bez regulace výrazně snižují dosažitelnou míru využití vlastní elektřiny, regulaci zase komplikují a prodražují.

Dříve k dokonalému výsledku regulace přebytků stačila jediná, relativně jednoduchá a univerzální verze regulace (níže uvedená pod bodem 1). Nyní je nutné vyhodnotit celou řadu kritérií (velikost FVE, typy spotřebičů a jejich vliv na symetrii toku elektřiny v jednotlivých fázích, požadovanou míru využití přebytků), dobře navrhnout zapojení a
vybrat nejvhodnější firmware pro GreenBonO:

  1. jednoregulátorový součtový algoritmus - regulace na energetickou rovnováhu (firmware:"GreenBonOXXXX_upg.hex")- první, dnes již klasická verze, výhradně používaná v letech 2010 a 2011.
    V odběrných místech s původním (součtovým) elektroměrem dosahuje dokonalých výsledků. Na jmenovité napětí, topologii spotřebičů a symetrii odběru zde nejsou kladeny žádné zvláštní požadavky.
    V odběrných místech s novým elektroměrem je situace značně odlišná - nesmírně zde totiž záleží na symetrii výroby i spotřeby elektřiny ve všech fázích. Pokud v odběrném místě je měnič FVE, vyrábějící do každé fáze stejné množství elektřiny a zároveň třífázové symetrické spotřebiče připojené ke GreenBonu, pak jsou výsledky regulace opět dokonalé. Pokud však nastane nesymetrie ve výrobě nebo odběru, projeví se odchylka od symetrie současným odběrem v jedné fázi a dodávkou v jiné fázi. Tato nesymetrická složka odběru (nikoli celý odběr) se pak majiteli prodraží téměř plnou nákupní cenou elektřiny. Výrazný problém je to zejména u jednofázového bojleru, který vnáší do regulace velkou a dlouhodobou nesymetrii a dokáže tento regulační algoritmus znehodnotit až do čistého prodělku. Proto je tento algoritmus u nových elektroměrů zcela nevhodný.
    Elektrické zapojení

  2. jednoregulátorový algoritmus - regulace podle nejslabší fáze (firmware:"GreenBonOXXXX_Hodice_upg.hex") - jedná se o drobnou úpravu předchozího algoritmu, ovšem v případě nového elektroměru a nesymetrického odběru velmi významnou: algoritmus si vstupní hodnotu vybere z té fáze, v níž jsou přebytky nejmenší a tu udržuje na žádané hodnotě. U této regulace se předpokládá výrazná převaha třífázových, symetricky řízených spotřebičů - spotřeba řízená GreenBonem je v takovém případě shodná ve všech fázích; ta část přebytků, o něž zbývající dvě fáze převyšují nejslabší fázi, odchází do sítě. Výsledkem je kompromis, kdy část přebytků odejde do sítě, ale většina zůstane doma. Pokud jsou výroba i odběr symetrické, pak jsou spotřebovány všechny přebytky. Tento algoritmus dosahuje dobrých výsledků u větších FVE s výraznou převahou symetrických třífázových spotřebičů, přesto je to jen kompromis - daň za jednoduchost - jediný regulátor řídí shodně všechny tři fáze. Algoritmus vznikl v roce 2012 pro instalace, původně určené ke starým elektroměrům, u nichž se nečekaně objevil elektroměr s novým měřícím módem.
    Elektrické zapojení.

  3. tříregulátorový algoritmus - regulace na nulu v každé fázi zvlášť (firmware:"GreenBonOXXXX_3PI_upg.hex") firmware GreenBona zde obsahuje tři samostatné PI regulátory (= v jedné krabičce jsou tři shodné prográmky), každý z nich měří a reguluje svou fázi. Dokáže tak nekompromisně spotřebovat všechny přebytky, samostatná regulace každé fáze však s sebou přináší nutnost používat spotřebiče výhradně o jmenovitém napětí 230V (mohou být třífázové, ale v zapojení do Y a s povinně nulovaným uzlem, k nimž budeme přistupovat jako k jednofázovým). Toto omezení nutně vede k potřebě odlišného (složitějšího) zapojení než v předchozích dvou variantách.
    Protože je však počet výstupů určených k řízení spotřeby nutno rozdělit mezi tři fáze a navíc spotřebiče musí být pouze jednofázové, hodí se pouze pro menší FVE s malým počtem spotřebičů přebytků.
    Přidělení výstupů jednotlivým fázím:
    • L1: SSR1 řízený ze svorky DO0 + kaskáda relé K1 a K2
    • L2: SSR2 řízený ze svorky DO6 + relé K3
    • L3: SSR3 řízený ze svorky AI1 + relé K4 +(volitelně konfigurací) relé K5

    Elektrické zapojení - obecné schema pro využití až osmi jednofázových spotřebičů
    příklad zapojení tříregulátorové regulace s 3f. topným tělesem.
    příklad zapojení tříregulátorové regulace s 3f. bojlerem.(uzel těles uvnitř bojleru musí být připojen na pracovní nulu)

  4. Tři regulátory GreenBonO, každý s jednofázovým měřením a klasickým algoritmem (viz.bod 1) (firmware:"GreenBonOXXXX_upg.hex") - jedná se vlastně o hardwarovou obdobu třetího algoritmu, ovšem s podstatně větším počtem připojitelných spotřebičů. Každé GreenBonO má k dispozici kaskádu až 3 SSR a následující kaskádu 5 relé - 8 stupňů regulace. S takovým zařízením lze regulovat na nulu i velké FVE bez kompromisu a bez závislosti na měřícím algoritmu elektroměru. Opět je zde však omezení na spotřebiče přebytků výhradně o jmenovitém napětí 230V. (nebo třífázové, v zapojení do Y a s povinně nulovaným uzlem, k nimž budeme přistupovat jako k jednofázovým)
    Elektrické zapojení pro velké FVE - osmistupňová kaskáda v každé fázi
Společné pravidlo pro všechny verze: k třífázové elektrárně patří třífázový bojler. U prvních dvou algoritmů se chová jako symetrický spotřebič, u dalších dvou pak (coby spotřebič obvykle s nejvyšší prioritou) zajistí spotřebu i malých přebytků, ať už jsou v kterékoli fázi.

Pozn.:
Ne vždy jsou u algoritmů 3 a 4 k dispozici spotřebiče výhradně na 230V. Pokud se vyskytne potřeba připojit 3f. spotřebič zapojený do trojúhelníku, pak by měl být ovládán výstupem s nejnižší prioritou regulátoru té fáze, která má nejméně přebytků. Další podmínkou je, že fázový proud tohoto spotřebiče musí být menší, než jmenovitý proud spotřebičů, ovládaných pomocí SSR.

Měření proudu

Zajišťuje externí měřící modul s třemi měřícími transformátory.

Polarita proudových snímačů

I zde samozřejmě záleží na orientaci průvlaků jádry měřících transformátorů. Nutnou podmínkou je zde zajistit shodnou orientaci (jak průvlaků, tak sekundárních vinutí) u všech tří měřících transformátorů.

Kontrola a případná náprava polarity je shodná jako v jednofázové verzi.

U modulu 3f snímačů, dodávaného jako volitelné příslušenství je vše předem dáno a vyznačeno nalepenými štítky.

Sled fází

V obou níže popsaných verzích měří regulátor GreenBonO napětí jen na jedné fázi - k níž má připojené napájení. Průběh tohoto napětí slouží jako fázová reference, z níž se pak odvozuje okamžitý fázový úhel a potažmo i napětí ostatních fází. K získání správných hodnot u 3f. verze je proto bezpodmínečně nutné, aby spolu vzájemně korespondovalo napětí s proudem u každé fáze!

Proto je nutno dodržet následující postup zapojení proudových a napěťových vstupů:

Fáze L1
je pro nás zásadně vždy ta fáze, u níž měříme obě veličiny: napětí i proud.

a.) její vodič je provlečen proudovým transformátorem č.1
b.) z této fáze musí být napájen regulátor GreenBonO.

Pokud je FVE jednofázová, musí být také připojena na tuto fázi.

Fáze L2 a L3
U dalších dvou fází nám pak stačí zajistit shodu mezi sledem fází u měřených hodnot proudu a sledem fází u vypočteného napětí:
provlečeme zbývající dva vodiče zbývajícími dvěma proudovými snímači (a zřejmě přitom zachováme stávající sled fází v rozvaděči, abychom měli v GreenBonu shodné značení s rozvaděčem).
Při tom mohou nastat jen dvě možnosti:
  • buďto nám vyšel správný sled fází a vše je OK
  • nebo nám to nevyšlo a pak je třeba zaškrtnout v konfiguraci proudových snímačů zatržítko opačný sled fází měřených proudů
    (dát GreenBonu pokyn, že má vzájemně prohodit vypočtená napětí U2,U3)

Postup stanovení sledu fází zkoušečkou

vývody zkoušečky pro určení sledu fází vývody zkoušečky pro určení sledu fází Sled fází lze určit pomocí (dnes již historické) zkoušečky pro nízké napětí ZN1, kterou dosud vlastní řada starších elektrikářů, nebo novější, v současnosti běžně dostupné zkoušečky Z10.
Postup je u obou citovaných zkoušeček naprosto shodný:

Pevný i pohyblivý hrot musí být u ZN1 připojeny do levé poloviny zkoušečky (viz obr. vlevo). U Z10 se toto řešit nemusí.

Pro toto měření je naprosto nezbytný ještě třetí vývod - je tvořen kovovým dotykem na zadní straně zkoušečky (viz obr. vpravo) a při měření se jej musíme dotýkat rukou! (stejně jako když testujeme fázové napětí doutnavkou) Přiložení pevného hrotu na předbíhající fázi a pohyblivého hrotu na následující fázi je pak indikováno svitem doutnavky, v opačném sledu doutnavka nesvítí.

V našem případě tedy přiložíme pevný hrot zkoušečky na L1 a zároveň se držíme dotyku na zadní straně - doutnavka již svítí, i když jsme ještě nepoužili pohyblivý hrot. Pohyblivým hrotem pak zkusíme zbývající dvě fáze. Zatímco na fázi L2 doutnavka zůstane svítit (a jeden neví, zda tam vůbec něco naměřil), zhasnutí doutnavky bezpečně označí L3.

Kontrola shody sledu fází

Kontrolu provedeme pomocí regulátoru GreenBonO a jeho monitorovacího PC-programu.
Opačný sled fází způsobí fázový posun mezi napětím a proudem o +120°, nebo -120°. V obou případech to změní účiník (cos ø) z hodnoty 1 na hodnotu -0,5 a to se projeví změnou polarity a poloviční velikostí v grafickém zobrazení monitorovacího programu.(viz obrázky vpravo)
Stačí tedy zapnout v domácnosti velký, symetrický třífázový spotřebič a přitom na PC sledovat, co GreenBonO naměřil.
Naměřil-li shodný odběr ve všech fázích, pak je zapojení správně.
Naměřil-li ve fázích L2 a L3 proud poloviční a opačného směru, pak je sled fází u proudu opačný, než u napětí a k nápravě stačí obrátit sled fází u napětí zaškrtnutím konfiguračního parametru "opačný sled fází" na záložce "konfigurace proudových snímačů" PC-programu.

Pozn.:
Není-li k dispozici 3f spotřebič, splní stejnou funkci i velký 1f spotřebič, např. rychlovarná konvice. Konvici postupně připojíme do každé ze tří fází. Její připojení by mělo být v PC programu indikováno v příslušné fázi změnou proudu o cca 5A směrem do mínusu. Opačný sled fází by se projevil ve fázích L2 a L3 poloviční změnou směrem do plusu.

Zobrazení odběru při symetrické 3-fázové zátěži:
shodný sled fází u napětí i proudu | opačný sled fází
velký 3f spotřebič při správném sledu fází | velký 3f spotřebič při opačném sledu fází

Chování GreenBona při rozdílném sledu fází:

Charakteristickým rysem rozdílného sledu fází u měřených hodnot napětí a proudu je také aktivita regulátoru po západu slunce: odběr elektřiny ve fázích L2 a L3 je (vlivem jejich vzájemného prohození) v GreenBonu naměřen jako přebytek o poloviční velikosti a GreenBonO spustí regulaci, třebaže FVE zaručeně nevyrábí...
Přitom přes den se může regulace chovat zdánlivě normálně, protože jak odběr, tak výroba jsou v té době běžně se vyskytujícími stavy.

Osciloskop

Od verze 2.036 je v GreenBonu implementována funkce jednoduchého 4-kanálového osciloskopu. Jeho úkolem je zobrazení fázových posuvů měřených proudů vůči napětí U1 GreenBona. To pak umožňuje odhalit chyby při komplikovaném zapojení vstupních obvodů. Každá křivka je sestavena ze 16 vzorků, takže průběhy křivek neoplývají přílišnou elegancí, ale k zjištění fázových poměrů to bohatě postačí.

Popis funkce:
Po obdržení požadavku na nový záznam vyčká GreenBonO na nejbližší začátek sinusovky napětí U1, poté zaznamená do paměti současně vzorky všech 4 měřených veličin (U1,I1,I2,I3), vše v intervalu jediné sinusové periody. Nakonec záznam odešle do PC.
Na tomto záznamu jsou pak vidět vzájemné fázové posuvy všech měřených veličin. Protože však spínání SSR ovlivňuje polaritu proudu (takže dva po sobě zachycené záznamy při regulaci mohou mít navzájem opačnou polaritu-záleží na tom, zda SSR bylo právě sepnuto či rozepnuto) a jalová zátěž zase zkresluje fázové posuny, je pro získání relevantní informace potřeba tyto vlivy eliminovat;

očekávaný průběh Předpis způsobu měření:
osciloskopický záznam je nutno provést v době, kdy FVE nevyrábí a současně je zajištěn relativně velký odběr ze sítě ryze ohmického charakteru (v provozovnách obvykle večer, kdy je tam klid strojů; ). Oscilogram na obrázku ukazuje očekávaný průběh při zapnutém třífázovém topném tělese a správném sledu fází.

v zachyceném průběhu je důležité:

  • aby proud I1 byl ve fázi s napětím U1 (je-li ve fázi s U1 proud jiné fáze, pak napájíte GreenBonO z nesprávné fáze a je nutno napájení přepojit na L1)
  • všimněte si, že na vodorovné ose jsou barevně vyznačeny tři intervaly délky 60°; každá proudová křivka by měla tuto osu protínat v místě shodné barvy. Je-li tomu tak, je sled fází správný.
  • pokud jsou I2 a I3 prohozené (protínají vodorovnou osu v místě jiné barvy), je potřeba zaškrtnou zatržítko "opačný sled fází" v záložce "konfigurace proudových snímačů" monitorovacího programu a novou hodnotu odeslat do GreenBona.
Účel použití:
Tento osciloskop může velmi usnadnit zprovoznění regulace hlavně při složitějším způsobu měření proudu v objektech s velkým jističem. Tam je proud obvykle měřen velkými proudovými transformátory In/5A a teprve sekundární proud tohoto trafa je snímán proudovým snímačem GreenBona. Tam lze snadno ztratit přehled a dopustit se záměny vodičů jednotlivých fází nebo vzájemné záměny dvou konců jednoho vodiče (obrácení polarity). Oscilogram zaznamenaný výše předepsaným způsobem takové chyby bezpečně odhalí.

Schéma zapojení: (pro oba jednoregulátorové součtové algoritmy)

Pozn.:
Toto schéma je pouze obecné - naznačuje, jak připojit ovládání jednofázových a třífázových spotřebičů.
V sekci "Download" na tomto webu je k dispozici soubor greenbono_schemata.zip s řadou schémat použitých v realizovaných akcích. Soubor je rozdělen do adresářů podle typu a velikosti FVE a každý by v něm měl najít přinejmenším inspiraci pro svou konkrétní potřebu.

GreenBonO: 3f. schéma regulace přebytků FVE

Kontakt "N-Tarif" - viz. pozn. výše.

Doporučené externí přístroje

SSR - Solid state relay

doporučený typ SSR Polovodičový spínač musí splňovat následující tři parametry:
  1. spínání v nule (*) zajištěné vnitřní logikou SSR
  2. řídící obvody galvanicky oddělené od silových s elektrickou pevností 4KV~
  3. řídící obvody musí reagovat na signál 4,5V/10mA
Těmto podmínkám vyhoví celá řada SSR. Dalším důležitým parametrem ovlivňujícím typ SSR a velikost chladiče je pak maximální spínaný proud.
Pestrým sortimentem vhodných typů SSR i k nim použitelných chladičů v Česku disponuje firma Enika zastupující výrobní firmu Carlo Gavazzi.

V první aplikaci regulátoru GreenBonO ( k FVE 4,2KW, proud SSR tam nepřekročí 12A) bylo použito SSR typu RM1A40D50 spolu s chladičem RHS100 (součástí tohoto chladiče je rovnou i adaptér na DIN lištu RHS00). Značné předimenzování (napěťové, proudové jakož i volba motorového typu kvůli vestavěné přepěťové ochraně a schopnosti bezpečně vypnout i jalovou zátěž) bylo záměrné a výsledek je více než uspokojivý. Regulace funguje znamenitě, chladič se neohřeje ani na 40°C a rušení žádné.

Upozornění: sestava SSR+RHS100 je pro zátěž do 20A a to pouze při zajištění dostatečné výměny vzduchu v okolním prostoru!

Samotné SSR RM1A40D50 je sice dimenzováno na 50A, ale s mnohem větším chladičem, nežli je RHS100. Chladič RHS100 je poměrně malý, má tepelný odpor 3 K/W a dokáže uchladit SSR při trvalém proudu okolo 15...20A (při teplotě okolního vzduchu do 40°C). Jak již bylo mnohokrát ověřeno, tento rozsah pro složku zátěže s plynulou regulací bohatě stačí.
Předimenzování SSR přesto není samoúčelné; uvedená sestava SSR+RHS100 krátkodobě snese 50A, což je důležité zejména při připojení studeného topného tělesa, které má v tom okamžiku podstatně nižší odpor, než po nahřátí na pracovní teplotu.

(*) Spínání v nule:
Sepnutí SSR nastává až při současném splnění dvou podmínek:
- podmínka 1: na řídících svorkách je napěťový signál (+4 ... +32V; je to povel "zapni"- na konkrétní velikosti tohoto napětí pak už nezáleží)
- podmínka 2: napětí na silových svorkách SSR právě prochází nulovou hodnotou
Výsledkem je, že při sepnutí nedochází ke skokové změně proudu silového obvodu a tím pádem ani k rušení.

Měřící transformátory

snímač proudu firmy PMEC
Problém s galvanickým oddělením u měřících transformátorů není - otvorem v jádru se provleče izolovaný silový vodič a je vystaráno.

Rozhodujícím parametrem je zde potřebný lineární rozsah proudového měření, který je závislý na typu regulace (podle počtu fází), na výkonu spotřebičů a fotovoltaické elektrárny. Zatímco jednofázová regulace (i 3 fázová regulace "na každé fázi zvlášť") si vystačí s rozsahem odpovídajícím proudu největšího spotřebiče, 3f součtová verze musí měřit přesně až do jmenovitého proudu hlavního jističe.

Pro měřící rozsah do 100A

Drtivá většina střešních FVE si nakonec vystačí s proudovým rozsahem do 100A. Tento rozsah zvládají malé měřící transformátory typů PT3 a PT4 firmy PMEC, které jsou použity v 3f měřících modulech, nabízených jako volitelné příslušenství k regulátoru GreenBonO.

Pro měřící rozsah nad 100A

Pro měření proudů řádu stovek ampérů lze použít vhodné násuvné měřící transformátory proudu sekundár na 1A .
  • varianta 1: měřící trafo se sekundárním proudem 1A, zatížené v sekundáru rezistorem 1,5 Ohmu.
    Napětí na zatěžovacím odporu se vede do vstupu GrenBona. Rezistor musí být dimenzován nejméně na 2W
    Ale pozor!
    Za provozu nesmí ani na okamžik dojít k rozpojení zatěžovacího rezistoru!
    Měřící transformátor proudu nikdy nesmí běžet naprázdno - rozpojené sekundární vinutí je zdrojem tak vysokého napětí, že samotnému transformátoru hrozí mezizávitový průraz.
    Ani GreenBonO není zátěž (vstupy mají odpor několik kiloOhmů), takže připojení nezatíženého měřícího trafa do svorek GreenBona znamená okamžitou likvidaci GreenBona.    .
  • varianta 2: měřící trafo se sekundárním proudem 5A spolu s naším modulem proudových snímačů (viz. níže) upraveným pro rozsah 5A.
    Dvojí transformace - do průvlaku modulu proudových snímačů je zaveden sekundární proud měřícího transformátoru. I zde samozřejmě platí, že sekundární okruh měřícího trafa musí být vždy uzavřen a je přitom lhostejno, zda to bude do krátka, nebo do zátěže typu ampermétr, wattmetr či elektroměr.
    Pokud tedy již v objektu vhodná proudová trafa jsou, lze je využít, vodič od jejich sekundáru se pouze protáhne průvlakem snímače. Pak je tato varianta levnější než varianta 1, navíc je i snazší na montáž a také bezpečnější. Pokud jsou měřící trafa určena pouze pro GreenBonO, pak je průvlakem snímače provlečen vodič, který pouze zkratuje pětiampérový sekundár proudového měřícího trafa .
    Úprava modulu proudových snímačů spočívá ve změně velikosti zatěžovacích odporů na desce plošného spoje modulu. Pokud je vyžádána v objednávce, je provedena rovnou při výrobě.

Volitelné příslušenství

Měřící moduly proudu

kompletní 3f snímač 50A
rozměry: 67x82x55mm (š,v,h), průvlaky d=6mm

Modul 3f proudového snímače do 50A

orientace průvlaků 3f modul na DIN lištu je k dispozici jako volitelné příslušenství regulátoru GreenBonO.

Průvlaky měřícími transformátory neprovádějte drátovými vodiči, ale lanky průřezu 6 mm²! Lanko H07V-K (CYA) 6 mm² trvale snese 58A a má průměr 5mm. (viz. katalogové listy Kabla Vrchlabí na str.55)
Měřící transformátory totiž mají otvor o průměru 6mm a nejsou příliš mechanicky odolné. Manipulace s tvrdými či tlustými vodiči často vyžaduje užití značné síly, při čemž snadno dojde k vylomení transformátorů z plošného spoje a utržení jejich sekundárních vývodů (zalitých v pryskyřici-oprava je obvykle nemožná).
Lanko je ve srovnání s tvrdým drátem výrazně ohebnější a nevyžaduje násilí, přitom elektrickými parametry se od drátu nijak neliší (srovnej katalogové listy vodičů H07V-K a H07V-U na výše uvedeném odkazu).

Předepsaná orientace průvlaků je znázorněna na obrázku vlevo (předpokládá se přitom rozpojený jumper uvnitř regulátoru GreenBonO.)

Modul 3f proudového snímače do 100A

3f snímač 100A
rozměry: 82x82x55mm (š,v,h), průvlaky d=10mm
je obdobou předchozího modulu, používá ovšem větší proudové transformátory s otvorem d=10mm, celkově je o 15mm širší a o dvě stovky dražší.

Rozšiřující reléový modul

Když nestačí základní 5-stupňová reléová kaskáda regulátoru GreenBonO, lze ji rozšířit přídavnými moduly.
Přídavné moduly jsou zase regulátory GreenBonO, ale vybavené jiným firmwarem. Jsou s hlavním regulátorem propojeny sběrnicí RS485 po níž dostávají od hlavního regulátoru pokyny, kolik svých relé mají sepnout a také aktuální hodnotu výstupu PI regulátoru hlavního GreenBona, aby synchronně s ním mohly řídit další SSR.
K hlavnímu regulátoru lze připojit až 10 rozšiřujících modulů.

Karta reálného času

Cílem této karty je zachovat existenci reálného času v regulátoru i při výpadku napájecího napětí.
Nově také zajišťuje funkci "externí watchdog" (hardwarová ochrana před zatuhnutím přístroje) a je proto standardně dodávána s každým novým přístrojem.

2m šňůra s převodníkem USB/RS232

Více informací najdete v následující kapitole.

Komunikace s PC

Pro účely konfigurace parametrů, monitorování měřených hodnot v reálném čase a pro aktualizaci firmwaru je zde volně ke stažení PC-program (pro OS windows98 a novější, nyní již také pro Linux s programem Wine) GreenBonO_HMI.exe.
Tento program je průběžně aktualizován, aby vždy korespondoval se všemi funkcemi nejnovějšího firmwaru regulátoru GreenBonO, přitom si neustále zachovává zpětnou kompatibilitu vůči všem starším firmwarům. Proto zejména ti, kdo přicházejí do styku s více regulátory GreenBonO, by si měli aktualizaci PC programu stahovat pravidelně. Po stažení se nespouští žádná instalace - stačí vybalit kompletní obsah "zipu" včetně adresářové hierarchie do libovolného adresáře. (\help musí být jeho podadresářem, jinak nebude fungovat nápověda)

Popis tohoto programu a návod k použití je zdokumentován v jeho nápovědě, která je součástí zipu v právě zmíněném adresáři \help jako samostatný soubor typu chm (Microsoft html help).

Použité fyzické rozhraní

Regulátor GreenBonO je vybaven sériovým rozhraním RS485 s napětím signálu 5V.
Rozhraní RS485 je dvoužilová datová sběrnice (kroucená dvoulinka), která může dosahovat délky až 1,2 km a lze na ni "pověsit" několik desítek přístrojů.

Sběrnice RS485 spolu s otevřeným protokolem MODBUS RTU, který je v regulátoru implementován, umožňují vytvořit nejen poměrně dlouhé propojení PC s regulátorem, ale poskytují i základy k vytvoření celé sítě prostředků domovní regulace stažené jedinou kroucenou dvoulinkou do domácího PC, nebo pomocí převodníku Secure iWifi do domácí počítačové sítě.

Propojení PC s regulátorem jednoduchou šňůrou

šňůra RS232/RS485 V praxi je daleko častějším případem pouze příležitostné přímé připojení PC k regulátoru.

Protože rozhraní RS485 je na fyzické vrstvě velmi podobné rozhraní RS232 (sériové porty COMx v PC), stačí k propojení sériového portu PC s regulátorem (čili k fungujícímu převodu RS232/RS485) jednoduchá dvoužilová šňůra, vybavená konektorem CAN9Z (zásuvka s pájecím žlábkem) na straně RS232. Signál TxD (vývod 3) je nutno změkčit odporem 560...680 Ohm) - viz. obr. vpravo. Šňůra vrací echo, ale s ním konfigurační program počítá a odfiltruje ho.

Šňůra může být dlouhá do 100m, což uvnitř jednoho objektu postačí a spolehlivě zajistí komunikaci PC s nejméně třemi přístroji na sběrnici.
šňůra pro připojení do sériového portu PC
Tato šňůra v délce cca 0,5m je automaticky dodávána spolu s regulátorem GreenBonO. K vytvoření funkčního spojení GreenBona s PC pak stačí připojit ji do sériového portu PC, nebo do převodníku USB/RS232 - viz. popis níže.
V případě potřeby se prodlužuje zásadně na straně RS485 - tedy dvoulinka s vývody A,B. Konektor Cannon zůstává u PC.
Pro plnohodnotnou sběrnici RS485, nebo k propojení dvou samostatně uzemněných stavebních objektů je však nutno použít převodník pro RS485 s galvanicky oddělenými obvody.

Využití USB portů (když PC nemá sériový port k dispozici)

převodník USB/RS232 převodníky USB/RS232 a USB/RS485 s čipem FTDI Na trhu je v současnosti celá řada převodníků USB/RS485 (připojí se k regulátoru přímo), nebo USB/RS232 (jsou levnější než převodníky USB/RS485, ale k převodu na RS485 vyžadují použít ještě výše popsanou dvoužilovou šňůru).
Každý takový převodník, zapojený do USB portu, přidá k PC nový sériový port.

Převodní šňůry fy FTDI

Nejrozšířenější (a nejpropracovanější) jsou šňůry od britské firmy FTDI. K nim se musí použít driver fy FTDI typu VCP (=Virtual Com Port). Když je počítač připojen na internet, OS Windows obvykle najde a nainstaluje správný driver automaticky, po prvním připojení šňůry do USB portu počítače.

Převodní šňůry fy Prolific

Častým problémem u šňůr Prolific je ztráta funkčnosti driveru, obvykle po upgradu operačního systému. Funkční drivery pro čipy Prolific (pro starší verze windows a také pro linux) najdete zde.
Pro windows 8 a 10 je driver ke stažení zde, a návod na celou jeho instalaci (jak se zbavit chyby "code 10") najdete na tomto odkazu.

Zde jsou odkazy na několik ověřených převodníků (všechny mají čip FTDI a umí i Windows 7,8,10):

  • Premium Cord převodník USB/RS232 bez galv. oddělení krátký (čár.kód.: 8592220000455)
  • Premium Cord převodník USB/RS232 bez galv. oddělení 2m (čár.kód.: 8592220001698)
  • Premium Cord převodník USB/RS485 krátký (čár.kód.: 8592220007010)
  • převodník USB/RS485 s galvanickým oddělením

Šňůra USB/RS232 jako volitelné příslušenství

Abychom své zákazníky uchránili před loterií, zda koupí funkční či nefunkční šňůru, zařadili jsme mezi volitelné příslušenství regulátoru GreenBonO ověřenou 2m šňůru Premium Cord (druhá na seznamu výše, s čipem FTDI a podporou windows 8 i 10).
Drivery jsou na CD, dodávaném spolu se šňůrou.

Použití šňůry USB/RS232 v Linuxu

Zde je návod na vytvoření virtuálního sériového portu COM1 do prostředí Wine v Linuxu (pro Windows aplikace).
ke spojení přes místní síť stačí Secure iWifi u GreenBona

TCP Socket - most do počítačové sítě

K regulátoru GreenBonO (nebo ke sběrnici RS485 s více přístroji) lze připojit téměř libovolný převodník typu "serial to TCP-IP", který přenáší zcela beze změny veškerá data mezi sériovým portem a aplikační vrstvou protokolu TCP-IP. Z pohledu počítačové sítě se chová jako TCP socket server.
zobrazit v plné velikosti Monitorovací PC-program pro GreenBonO je proto od verze 1.035 vybaven funkcí TCP socket client, umožňující komunikovat s převodníkem přímo po počítačové síti.

TCP socket v PC programu se nakonfiguruje a aktivuje v záložce "adresace Modbus". Konfigurace spočívá v zadání IP adresy a použitého portu převodníku serial to TCP-IP , aktivace se provede zaškrtávacím políčkem.
(viz. obr. vpravo; po rozkliknutí se zobrazí v plné velikosti)

Samotná komunikace PC programu s regulátorem GreenBonO se pak z pohledu uživatele nijak neliší od komunikace po sériovém portu.
Od verze 1.037 PC-programu funguje i v Linuxu (s podporou API Wine).

Ověřené převodníky

Následuje přehled tří typů převodníků serial to TCP-IP, s GreenBonem úspěšně odzkoušených (první dva v r.2016, třetí v r. 2012):
  1. nejnovější a nejlevnější, jednoduchý, použitelný pro LAN i Wifi, bez skříňky, nabízený na ebay - HLK-RM04
  2. také nepříliš drahý, jednoduchý, pouze pro LAN, bez skříňky, v nabídce sos electronics - Wiznet WIZ110SR
  3. nejdražší, nejsložitější (v mnoha funkcích nevyužitý), zabudovaný ve skříňce a nejstarší (od r.2012 používaný řadou majitelů GreenBona) - Secure iWiFi nebo Secure iLAN ( v provedení pro RS232!), nebo novější model iChip Net box firmy Connect One, každý nakonfigurovaný do pracovního režimu SerialNet pomocí utility iChipConfig.
Zde je ke stažení konfigurační soubor pro Secure iWifi se základním nastavením a návod na přizpůsobení tohoto nastavení konkrétní místní síti.

Převodníky Secure iWifi jsou v Česku nabízeny pro tři různá rozhraní, pro náš účel zásadně použijte provedení pro RS232! - Naším cílem je sice rozhraní RS485, ale převod do něho zajistí v naší aplikaci dvoulinka s jediným odpůrkem snáze a levněji, nežli převodník Secure iWifi v provedení "RS485 dvoudrát".
Navíc samotná konfigurace tohoto převodníku se uskutečňuje přes jeho implementované rozhraní a je mnohem snazší použít ke konfiguraci šňůru RS232 (která je součástí dodávky převodníku), než si k tomu pořizovat převodník RS232/RS485.(zde již dvoulinka s odpůrkem nestačí, protože program iChipConfig neodfiltrovává echo.) kliknutím zvětšíte obrázek na plnou velikost

propojení GreenBona s převodníkem Secure iWiFi pro RS232:
(viz. foto vpravo - pro detailní náhled klikněte na obrázek - otevře se v plné velikosti)

  • Šňůra (s funkcí jednoduchého převodu RS485/RS232) k musí mít konektor CAN9V
  • červený vodič na pin 5
  • černý vodič na pin 3
  • rezistor 680R mezi piny 2 a 3

Dálkový přístup

V okamžiku, kdy dostanete data z GreenBona do své lokální počítačové sítě (LAN), máte obvykle k dispozici i technické prostředky k tomu, abyste mohli ke GreenBonu přistupovat i odkudkoli z internetu. Je to již čistě záležitost konfigurace rozhraní mezi lokální sítí a internetem. Vyžaduje to mít přípojku k internetu s neměnnou IP adresou a povolit přístup z internetu do LAN pro vybranou lokální IP adresu a port. To se dělá nastavením NAT (Nerwork address translation) modemu napojeného na internet.
Některé modemy striktně vyžadují zabezpečenou lokální bezdrátovou síť - dokud nenastavíte šifrování a filtr MAC adres, modem přístup zvenčí neumožní.

Dálkový přístup je pak obdobný, jako přístup přes LAN, pouze v nastavení socketu PC programu zadáváte globální IP adresu - svého přípojného místa k internetu.
Odezva na dálku ale trvá několikrát déle, než při místním připojení, takže od odeslání povelu k potvrzení o jeho provedení uběhne i více, než 5s.

Firmware

Rozmanitost realizovaných zakázek často přináší nové požadavky na rozšíření původní funkcionality přístroje. Výhodou zařízení, obsahující mikroprocesor je, že tyto změny lze jednoduše zakomponovat do programového vybavení, bez nutnosti zasahovat do hardwaru.

Také firmware regulátoru GreenBonO prošel (a stále prochází) tímto vývojem. Postupem času se původně jediný firmware regulátoru rozvětvil do tří modelových řad (stále je řeč o softwaru):

  • "klasická jednoregulátorová verze" - původní varianta, tak jak je popsaná v předchozích kapitolách této stránky

  • rozšiřující modul - v této verzi funguje GreenBonO jako externí doplňkový modul, sloužící k rozšíření reléové kaskády o dalších 5 stupňů. Pětici svých relé spíná podle povelů nadřazeného regulátoru, které dostává po sběrnici RS485. K hlavnímu regulátoru lze připojit až 11 externích modulů a vytvořit tak 60 stupňovou reléovou kaskádu. Obvykle se však využije jeden až dva moduly, a to pouze v místech s výkonnou FVE a požadavkem na jemné stupňování spotřeby přebytků.

  • tříregulátorová verze - tuto verzi si vynutila nová legislativa v roce 2012, umožňující (a od roku 2015 nařizující) distributorům měřit a účtovat elektřinu v každé fázi zvlášť. Regulaci pak nezbývá, nežli uplatnit stejnou metodiku. GreenBonO v této verzi obsahuje tři PI regulátory (tři samostatné, vzájemně nezávislé instance programu), každý pro jednu fázi.

    Rozdělení regulace na tři větve s sebou však přináší nutnost spravedlivě rozdělit mezi jednotlivé fáze také reléovou kaskádu. Regulátor každé fáze zde proto má podstatně omezenější prostředky k zajištění stupňovitého řízení spotřeby přebytků: pulsní modulace přebírá značnou část regulovaného příkonu, což nutně vede k výraznějším projevům flikru. monitorovací PC program pro 3-regulátorovou verzi

    Rozložení relé do jednotlivých fází:

    • L1: SSR1 řízený ze svorky DO0 + kaskáda relé K1 a K2
    • L2: SSR2 řízený ze svorky DO6 + relé K3
    • L3: SSR3 řízený ze svorky AI1 + relé K4 +(volitelně konfigurací) relé K5

    příklad zapojení tříregulátorové regulace s 3f. topným tělesem.
    Protože se reguluje každá fáze samostatně, je nutno, aby řízené spotřebiče byly připojeny na fázové napětí (230V). U třífázových spotřebičů je nutné zapojení do hvězdy s povinně nulovaným uzlem! (přebytky budou značně nesymetrické)

    Tato tříregulátorová verze se uplatní pouze u nejmenších třífázových FVE v místech, kde distributor elektřiny uplatní měření podle nové legislativy.

    U výkonnějších FVE bude zpravidla technicky mnohem výhodnějším a přitom nákladově srovnatelným řešením použití tří regulátorů GreenBonO v klasické verzi a jednofázovém provedení, které umožní regulovat každou fázi s dostatečně velikou reléovou kaskádou.

    Aktualizace firmwaru

    Od fw.verze 2.001, zveřejněné v polovině června 2011, má regulátor GreenBonO rozdělenou paměť firmwaru na dva bloky: aplikační a bootovací. Bootovací blok je v paměti nahrán natrvalo v chráněném režimu - bez možnosti ho upravovat, nebo z něho číst. Tento blok obsahuje veškerý kód nutný k sériové komunikaci, k modifikaci aplikačního bloku paměti Flash a celou řadu dalších funkcí, u nichž se již nepředpokládá další vývoj.
    Na aplikační blok paměti pak již zbývá pouze kód, u něhož lze očekávat změny a postupné rozšiřování. Tento kód je sám o sobě nefunkční (nutně potřebuje součinnost s funkcemi bootovacího bloku), jeho smysluplné využití je omezeno pouze na legálně vyrobený regulátor GreenBonO. V této formě je volně poskytován ke stažení v sekci download.

    PC program má k tomu účelu záložku "aktualizace firmwaru", z níž je možno nahrát jakýkoli zveřejněný firmware (novější i starší) prostřednictvím implementovaného sériového rozhraní (RS485).

Postup při konfiguraci a uvedení do provozu

Samotnou konfiguraci regulátoru lze provést předem, na stole. Stačí k regulátoru připojit pouze napájení 230V a propojit ho šňůrou sériové komunikace s PC, v němž je nainstalován a spuštěn program GreenBonO_HMI.exe (v dalším textu již jen PC-program).

Zejména při prvním setkání s regulátorem GreenBonO může být tento postup užitečný. Umožní Vám v klidu se s regulátorem seznámit a připravit si tak půdu pro hladký průběh dokončovacích prací (už víte, co můžete očekávat a kam máte sáhnout). Při uvádění zařízení do provozu pak již bude zbývat pouze provést kalibraci a kontrolu orientace proudových čidel.

Zatímco následující text sekvenčně popisuje celý postup uvedení do provozu a předpokládá tedy již kompletní zapojení celé regulace,
zeleným textem jsou vyznačeny jen ty kroky, které nevyžadují úplné zapojení a lze si je předem přichystat na stole.

  • virtuální LED diody indikující oba směry komunikace Je-li v horní komunikační liště PC-programu správně zvolen použitý sériový port, pak přístroje zahájí komunikaci okamžitě po spuštění programu, což je indikováno dvěma virtuálními LED diodami PC-programu, umístěnými vedle roletového menu pro volbu sériového portu.(viz. obr. vpravo)

  • nastavení použitého způsobu měření proudu Nastavení konfigurace proudových snímačů
    V PC-programu otevřte kartu "Konfigurace-proud.snímače". Na této kartě v bloku "měření proudu" zvolte tu variantu, kterou jste ve své aplikaci skutečně použili.
    Po provedení volby se aktivuje tlačítko "Odeslat" a po jeho odkliknutí je informace odeslána do regulátoru. Po úspěšném odeslání se tlačítko zablokuje a potvrdí tak úspěšný přenos dat do regulátoru.

    (aktivní tlačítko vždy signalizuje nesoulad mezi obsahem paměti regulátoru a navoleným stavem v PC-programu; upozorňuje uživatele, že zřejmě v průběhu sezení provedl změnu, kterou ještě neodeslal)

  • Zapojení a kontrola proudových snímačů:
    je podrobně rozepsána v prvních dvou etapách montážního předpisu [image] .

  • kalibrace proudových snímačů
    Standardní měřící moduly fy. Yorix se nekalibrují - výchozí výrobní hodnoty jsou dostatečně přesné.

    Kalibrace slouží k převodu bezrozměrných hodnot získaných A/D převodem do standardních měrných jednotek (voltů,ampérů), které se posléze zobrazují na monitorovací kartě PC-programu. Protože algoritmy regulátoru GreenBonO využívají přímé hodnoty z A/D převodníků, tato kalibrace nemá vliv na regulaci a slouží pouze k normalizaci zobrazení naměřených hodnot v PC-programu. Nejsou-li např. zrovna k dispozici měřidla nutná k změření skutečných hodnot, nestane se vynecháním tohoto kroku nic horšího, než že PC nebude zobrazovat proudové hodnoty zrovna přesně v ampérech.
    Kalibraci provádějte zásadně v době, kdy nespíná SSR. Jinak vaše měřidlo nenaměří správné hodnoty.

    Postup kalibrace:
    kalibrace proudu I1

    • V PC-programu vybereme monitorovací kartu ("Okamžité hodnoty") a současně měříme externím měřidlem (klešťovým ampérmetrem) veličinu, kterou chceme kalibrovat.
    • Ve chvíli, kdy měřená hodnota dosáhne ustáleného stavu při rozumné velikosti (co možná největší hodnotě uvnitř lineárního rozsahu snímače), přepneme program na druhou kartu: "Konfigurace-proud.snímače". (V tom okamžiku se jednorázově načtou hodnoty měřených veličin získané v regulátoru A/D převodem a zobrazí se v kolonkách "A/D převodník")
    • Hodnotu, kterou jsme právě naměřili externím měřidlem vyplníme (s přesností na jedno desetinné místo) do příslušné bílé kolonky "naměřená hodnota" a odklikneme tlačítko "Vypočíst a odeslat KK". Tím je kalibrace této veličiny hotová a na první, monitorovací kartě programu se od té chvíle budou zobrazovat její správné hodnoty.
    Obdobně provedeme kalibrace ostatních veličin.

    Pod blokem "měření proudu" je ještě blok "Jmenovité proudy" pro zadání dvou proudových hodnot.

    1. První z nich - "měřící transformátory" slouží k stanovení měřícího rozsahu při grafickém zobrazení měřených proudů na první kartě programu. Hodnota, kterou zde zadáte, bude představovat plnou výchylku na grafickém indikátoru proudu. Jiný účel neplní, na samotnou regulaci nemá vliv.
    2. Druhá hodnota - "hlavní jistič" je pro zadání jmenovitého proudu hlavního jističe. Zatím je to pouze rezerva k možnému využití v dalších verzích.

  • konfigurace relé a nastavení spínacích hodin
    Následující funkce mají již pouze podpůrný charakter a zatímco mnohdy možná ani nebudou využity, jinde budou využívány velmi často podle potřeb daného ročního období. Uplatnění najdou zejména v odběrných místech plně zavedených na elektřinu. Tam bude často docházet ke sdílení zásobníků energie stálými i doplňkovými spotřebiči a bude nutno koordinovat jejich společnou činnost.     karta s měřenými hodnotami
  1. Prvním funkčním blokem na třetí kartě PC-programu je blok konfigurace relé, který povoluje/zakazuje funkci jednotlivých vestavěných relé a dále definuje vazby těchto relé na ovládací signály z obou implementovaných spínacích hodin.
    Pozn.:
    Blokové schéma je zde vyvedeno ve dvou barvách vodičů - zatímco černé drátování zobrazuje regulaci přebytků,     červeným vodičem jsou vyznačeny okruhy, sloužící k doplnění energie ze sítě ve dnech, kdy na to slunce nestačilo. Tato konfigurace zajišťuje, že u spotřebičů závislých na elektřině ze sítě není nutné žádné dodatečné drátování v rozvaděči, ale stačí na to pár kliknutí myší.
    Význam jednotlivých konfiguračních bitů je patrný ze schematického znázornění.
    1. Dolní řada zaškrtávacích políček umožní úplný zákaz či povolení kteréhokoli relé. Nejspíš se bude hodit po skončení topné sezóny, k letnímu odstavení spotřebičů sloužících k vytápění.
    2. Horní řada zaškrtávacích políček umožní "natvrdo" sepnout vybraný spotřebič v době, kdy jsou současně aktivní spínací hodiny SH2 i povel NT (kontakty obou jsou v sérii). Časový interval sepnutí je pak podmnožinou intervalu "nočního proudu" spínaného signálem HDO - aby bylo možno omezit nežádoucí nákup elektřiny, např. před východem slunce. Typickým příkladem použití je spínání bojleru TUV v zimním období, kdy je celá řada dnů s nedostatečným slunečním svitem, takže je obvykle nutné dobít bojler ze sítě.
    Tlačítko "odeslat" slouží k odeslání upravených dat do regulátoru GreenBonO. Normálně je pasivní, je-li něco nového k odeslání, přejde do aktivního stavu.

  2. Druhým blokem je nastavení reálného času v regulátoru. V tomto bloku je zobrazen jak čas v regulátoru, tak čas v PC. Pokud se navzájem liší o více než 10 sekund, tlačítko "seřídit podle PC" přejde do aktivního stavu a celý blok bliká žlutě. Jedním kliknutím se pak nastaví čas v regulátoru.

  3. Třetím blokem je grafická reprezentace spínacích hodin SH1, sloužících ke spínání relé K5. Toto relé, jak je ostatně patrno ze schématu na popisované kartě programu není součástí spínací kaskády - není ovládáno PI regulátorem spotřeby. Je ovládané výhradně jen spínacími hodinami a umožňuje zkrátit dobu připojení těch spotřebičů nočního proudu, které nejsou řízené regulátorem GreenBonO, ale sdílejí s regulovanými spotřebiči úložiště energie.
    Konkrétní příklad: akumulační nádrž se dvěma topnými tělesy- první těleso je spínané pouze nočním proudem, druhé je řízené regulátorem GreenBonO a dodává přebytky z FVE. V některých ročních obdobích je žádoucí omezit dobu sepnutí prvního tělesa, a k tomu slouží relé K5 a spínací hodiny SH1.
    Dva spínací intervaly se nastavují posunem modré (start) a hnědé (stop) zarážky, které lze přesouvat myší. Někdy se hodí tlačítko "default" (je součástí obou spínacích hodin, na obr. je viditelné na hodinách SH2), jehož stisknutím se časy přednastaví do výchozího stavu zobrazeného na obr.(odpovídá předvoleným časům všech vlastníků FVE připojených k síti spravované fy. E.On), a pak lze pohodlně upravit nastavení dle potřeb. Spínací intervaly jsou zobrazeny stejnou barvou, jako spínaná relé ve vedlejším schématu. Zároveň je ve spínacích hodinách vyznačen červeně interval nočního proudu, který lze upravit ve spínacích hodinách SH1 poté co se přepne příslušné "radiové tlačítko" volby zadání spínacích časů.
    Tento červený interval nočního proudu slouží k výhradně jen orientaci (ne každý si trvale pamatuje, jak ho má doma nastaven) skutečný interval nočního proudu je určen vnějším signálem od spínacích hodin v analogovém vstupu AI0. Výsledný spínací interval je dán společným průnikem intervalu spínacích hodin SH1 a nočního proudu.

  4. čtvrtým blokem je blok spínacích hodin SH2. Způsob nastavení je shodný s hodinami SH1, smysl těchto hodin byl popsán při popisu horních zaškrtávacích políček schématu (v odstavci 1 této kapitoly).

Zálohování konfigurace

Záloha uvnitř GreenBona

Po úplném nastavení požadovaných vlastností regulátoru, je nutno uložit (zálohovat) aktuální konfiguraci do paměti FLASH regulátoru GreenBonO. K tomu účelu je na záložce konfigurace-proud.snímače v levém dolním rohu blok záloha celé konfigurace do FLASH, s tlačítkem odeslat.
PC-program sám vyzve uživatele k zálohování konfigurace na konci každého sezení, během něhož zaregistroval zásah do konfigurace.

K čemu je to dobré:
Konfigurační data využívaná mikroprocesorem jsou uložena v paměti EEPROM. Tato paměť sice udrží data i bez napájecího napětí, přesto však někdy může data ztratit (stává se to). Mikroprocesor GreenBona proto průběžně hlídá konzistenci dat v EEPROM a pokud zachytí anomálii, automaticky načte do EEPROM záložní data z FLASH. Tuto operaci automaticky provádí také každou půlnoc.
Pokud tedy provedete změnu konfigurace, aniž byste nakonec výslednou konfiguraci zazálohovali, pak se nejpozději o nejbližší půlnoci vrátí konfigurace do stavu před Vaší úpravou.
Máte-li aktuální konfiguraci zálohovanou, případná kolize EEPROM se napraví sama.

Archivace na harddisku PC

Konfiguraci přístroje lze ukládat na harddisk připojeného PC v podobě binárního souboru ve tvaru "*.gbo". Takový soubor lze pak zase kdykoli zapsat zpět do GreenBona. Lze tak mít v PC uloženo více souborů, každý s konfigurací odladěnou pro jiné roční období a ve chvíli, kdy nastane jejich čas, jednoduše nahrát kompletní konfiguraci několika kliknutími myši.

Obsluha regulátoru v běžném provozu koncovým uživatelem

U základní funkce regulátoru (PI-regulace) se žádné zásahy od uživatele již nepředpokládají.

Zato u podpůrných funkcí, souvisejících se spínacími hodinami SH1 a SH2 ( cílená optimalizace spínacích časů nízkotarifních spotřebičů) se dá očekávat potřeba úpravy spínacích časů několikrát do roka. Přitom tyto funkce jsou v zásadě nezbytné v těch případech, kdy použitý spotřebič je závislý na elektřině ze sítě (bojler - po slunečně nepříznivém dnu je třeba doplnit energii ze sítě)

Podpůrné funkce jsou závislé na správné hodnotě reálného času. Regulátor GreenBonO nemá na základní desce hodinové obvody nezávislé na napájecím napětí, takže při výpadku síťového napětí ztratí informaci o čase.

Přídavná karta reálného času

karta reálného času připojená do základní karty regulátoru Tento nedostatek je odstraněn vestavnou přídavnou kartou reálného času se záložní baterií, schopnou udržet chod hodinového obvodu řadu měsíců i bez síťového napájení.
S kartou reálného času jsou všechny funkce regulátoru vůči výpadku napájení imunní. Po obnovení napájení začne vše fungovat tak, jako by ani k žádnému výpadku nedošlo.

Karta je připojena do programovacího konektoru základní desky regulátoru v jeho pravé, horní části.(viz.obr.)

V současnosti plní tato karta další významnou funkci a stala se proto povinnou součástí regulátoru:

Zatuhávání regulátoru

U přístrojů, pocházejících z prvních let výroby GreenBona, dochází v některých instalacích k více či méně častému zatuhnutí regulátoru. Příčinou je jev popsaný v tomto článku časopisu ELEKTRO.

Jak zatuhávání zamezit:

RC člen u cívky stykače
  1. Aktualizovat firmware GreenBona co nejnovější verzí (alespoň 2.036)
  2. Doplnit do GreenBona kartu reálného času Tr056b (pokud tam již není), nebo upravit starší kartu TR056a podle návodu a obrázku níže
  3. zkontrolovat (případně zajistit) že ovládací napětí pro spínání stykačů je ze stejné fáze, jako napájení GreenBona
  4. (toto opatření obvykle již není nutné) přidat RC člen paralelně k cívce každého stykače, ovládaného z Greenbona (viz. obr. vpravo)

Body 1,3 a 4 omezují intenzitu rušení, body 1 a 2 zajistí "probuzení" regulátoru, pokud by přesto došlo k jeho zatuhnutí.

Popis funkce "Externí WatchDog":
Karta reálného času má aktivován časovač, který každou sekundu dekrementuje svůj registr, až nakonec po dosažení nuly v tomto registru vyšle karta krátký impuls, který je přiveden do vstupu "RESET" GreenBona (doplněnou propojkou - viz. úprava karty RČ níže). GreenBonO v normálním stavu pošle každou celou minutu tříminutový odklad pro externí RESET (paketem IIC protokolu nastaví dekrementovaný registr na hodnotu 180). Pokud GreenBonO zatuhne, odklad do karty RČ nepřijde a ta do třech minut vyvolá RESET.

Úprava karty reálného času TR056a (dodané před zářím 2013)

propojka nutná k zajištění funkce 'externí WatchDog' Doplnění propojky mezi PIN3 integrovaného obvodu NA1 a PIN5 konektoru SV2 - na obrázku zeleně.
Pozn.:
Karty RČ distribuované po 1.9.2013 tuto propojku mají už z výroby. (TR056a má drátovou propojku podle obrázku, na novější kartě TR056b [od r.2014] je již součástí obrazce plošného spoje.)

Vyjmutí a vložení karty reálného času
K doplnění propojky je nutno kartu nejprve vyjmout z regulátoru. Karta je mechanicky spojena se základní deskou GreenBona konektorem SV2 (2x5 pin - viz. obr.) a plastovým distančním sloupkem (na obr. díra d=4mm v pravém horním rohu karty). Zejména distanční sloupek drží poměrně pevně, takže k vyjmutí karty je nutné mírné násilí.
Vrácení karty zpět je trochu komplikováno tím, že není vidět na konektory. Správná pozice je následující: pravá hrana karty se opírá o pravou vnitřní stěnu skříňky GreenBona, levý dolní roh karty lícuje s pravým horním rohem relé K4.
Kontrolu správného umístění karty pak lze provést krátkým propojením pinů 5-6 na konektoru SV1 (prostřední piny- třetí zleva i zprava, nad sebou). Pokud je karta reálného času nasazena správně, propojení pinů 5-6 vyvolá hw reset GreenBona s následným světelným hadem na žlutých LED diodách GreenBona. Světelný had je vidět pouze v přítmí.
Pozn:
Piny konektorů SV1 a SV2 na kartě RČ jsou totožné- konektor SV2 je prodloužený vývod konektoru SV1. Konektor SV1 slouží jednak jako normalizované rozhraní SPI pro programování mikroprocesoru, za provozu regulátoru pak k IIC komunikaci GreenBona s kartou RČ. Význam jeho pinů:

  • pin 2: +5V
  • piny 4,6,8,10: GND
  • pin 5: RESET

Reset karty reálného času

lze vyvolat vyzkratováním vývodů krystalu 32kHz na dobu okolo 2 sec.

Jak objednávat

Případnou objednávku pošlete e-mailem:

(Je to obrázek, takže nejde nabrat do schránky a musí se opsat)

V objednávce uveďte:

  • fakturační adresu, příp. dodací adresu
  • Vaše IČ, příp DIČ
  • číslo Vašeho mobilního telefonu (Česká pošta avízuje doručení pomocí SMS)
  • seznam zboží
  • případně i požadovaný firmware (standardně je nahrávána verze "3PI" pro nové 4Q elektroměry, jakoukoli jinou si může uživatel kdykoli nahrát sám. Firmwary jsou volně ke stažení v sekci download.)
Pokud si nejste příliš jisti správností či úplností objednávky, sdělte ještě údaje o své FVE (počet fází a výkon) a spotřebičích, které chcete použít ke spotřebě přebytků (počet fází, výkon, jmenovité napětí).

Zboží, které se týká regulace přebytků, najdete v ceníku na posledních šesti (zelených) řádcích tabulky.

Současná nejobvyklejší sestava (pro 3f FVE s elektroměrem, účtujícím každou fázi zvlášť) obsahuje:

  • 1 ks GreenBonO+ (regulátor s vestavěnou kartou reál. času)
  • 1 ks modul 3f proud. snímačů
  • 3 ks SSR s chladičem
  • 1 ks převodní šňůra USB/RS232

Reference

dokument v pdf formátu.

Dokumentace určená k vytištění

montážní předpis-zapojení a kontrola měřících okruhů .
prohl.o shodě ES prohlášení o shodě.
© Yorix s.r.o. Ing.Richard Trochta
Založení domény yorix.cz: 1998/05
První zveřejnění stránky GreenBonO: 19.11.2010
Poslední aktualizace: 14.07.2015


YORIX-ceník

ceník 2017 (všechny ceny jsou uvedeny v Kč, bez DPH)
Podpůrné moduly pro regulátory domovní regulace¨
název \ počet ks | 1+ | 10+ | 30+
2P10/3 | 1700 | 1600 | 1550
UDO4b | 2100 | 2050 | 2000
UDO6 | 2500 | 2400 | 2300
UDI6 | 1450 | 1400 | 1350
Moduly pro sériovou komunikaci¨
název \ počet ks | 1+ | 10+ | 30+
OP485 | 2200 | 2100 | 2000
OPG485 | 2300 | 2200 | 2100
OPGF | 2300 | 2200 | 2100
AG Black | 2700 | 2600 | 2500
AGF | 2700 | 2600 | 2500
BBM-9600 | 4900 | 4700 | 4500
GreenBonO
název \ počet ks | 1+ | 10+ | 30+
GreenBonO+ (+ v názvu znamená že obsahuje kartu reál.času) | 3400 | 3200 | 3000
GreenBonO+ (1f) (s vestavěným 1f.snímačem proudu) | 3500 | 3300 | 3100
modul 3f snímačů 50A (díra 6 mm) | 700 | 700 | 650
modul 3f snímačů 100A (díra 10 mm) | 900 | 900 | 850
karta reálného času | 150 | 150 | 150
SSR RM1A40D50 s chladičem RHS100 | 1000 | 1000 | 1000
Šňůra USB/RS232 Premium Cord | 230 | 230 | 230

Stanovení ceny (pravidla a podmínky pro poskytování množstevní slevy)

Při stanovení ceny se započítává celkový počet odebraných přístrojů šest měsíců (183 dnů) nazpět, nezávisle na typu přístroje. Započítávají se však pouze výrobky fy Yorix, nikoli obchodní zboží.

příklad: nová objednávka na 5ks UDI6, v posledních šesti měsících odebráno 12 ks UDO4b, 14 ks UDI6.

Celkový odběr je tedy 5(nových)+26(dříve)=31 (=sloupec 30+)

Jednotkovou cenu UDI6 pak hledáme v tabulce ve slouci 30+, tedy 1300,-Kč.

Množstevní slevy

Podmínkou pro uplatnění množstevních slev je včasná úhrada všech předchozích faktur.

Při prodlení platby 30 dnů po lhůtě splatnosti (nebo 10 dnů po písemné upomínce) zaniká nárok na množstevní slevu, další dodávka se uskuteční formou dobírky a v cenových relacích daných sloupcem 1+.

Dodavatel si přitom vyhrazuje právo uskutečnit další dodávku až po vyrovnání všech pohledávek.

Způsob platby

přednostně dobírkou, výjimečně bankovním převodem, faktura bývá uvnitř balíku se zbožím.

Dodací lhůta

nejdéle do 6 týdnů ( zpravidla výrazně dříve, do týdne, ve zvlášť naléhavých případech do 24 hodin)

Doprava zboží

obvykle poštou-obchodním balíkem, nebo jinou spediční službou. V blízkém okolí Českých Budějovic pak často osobní předání v sídle odběratele, méně často v sídle dodavatele.

Záruka a pozáruční servis

Na naše výrobky je poskytována záruka 3 roky od data prodeje. Na obchodní zboží (cizí výrobky-poslední dva řádky ceníku) poskytujeme pouze zákonnou záruční lhůtu.
Ceny pozáručních oprav se pohybují okolo 30% ceny nového výrobku.

©YORIX s.r.o., Ing. Richard Trochta, 10.3.2016


Prohlášení o shodě

Ujištění o prohlášení o shodě

Firma YORIX s.r.o. Adamov 147, 373 71 Rudolfov, ičo: 25163141, ujišťuje tímto prohlášením své odběratele, že na výrobky:
  • UDO6
  • UDO4b
  • UDI6
  • 2P10/3
  • OP485
  • OPG485
  • AG-Black
je vystaveno

ES prohlášení o shodě

Shoda byla posouzena podle §12 (4) a) zákona č. 22/1997 sb.

na základě zkušebního protokolu č. 4.802269-00 z 11.11.98 od EZÚ AO201, Pod Lisem 129, 171 02 Praha 8 - Trója.

Výrobky jsou ve shodě s harmonizovanými českými normami pro elektromagnetickou kompatibilitu:

  • ČSN EN 50081-1/94
  • ČSN EN 55022-B/96
  • ČSN EN 50082-1/94
  • ČSN EN 61000-4-2/97
  • ČSN EN 61000-4-3/97
  • ČSN EN 61000-4-4/97

a nařízením vlády EMC: č. 616/2006 Sb.

Nařízení vlády č. 17/2003 (elektrická zařízení nízkého napětí) se na citované výrobky nevztahuje, neboť rozsahem svých jmenovitých napětí nespadají do kategorie "stanovených výrobků", definované v §1 tohoto nařízení vlády (50V AC, 75V DC).

Prohlášení o shodě je podle §13 zákona č. 22/1997 uloženo u výrobce a připraveno k předložení příslušným kontrolním orgánům.

© Yorix s.r.o. Ing.Richard Trochta 1.8.2007


Zásady připojování modulů fy.YORIX k řídícím centrálám

Úskalí kombinace můstkového a jednocestného usměrňovače! - Nebezpečí zkratu ! -

Technologický celek MaR obvykle obsahuje celou řadu přístrojů, které jsou vzájemně pospojeny na potenciálu GND.
Jednotlivé přístroje mohou být vybaveny jak můstkovým, tak jednocestným usměrňovačem. Problém popsaný v dalším textu nastane, pokud jsou přístroje s odlišným usměrňovačem napájeny ze společného transformátoru.

obr.1: znázornění zkratu
obr.1: znázornění zkratu při propojení můstku s jednocestným usměrňovačem

Nikdy nelze jednoduše kombinovat můstek s jednocestným usměrňovačem na společném napájecím transformátoru, mají-li zároveň společný potenciál na stejnosměrné straně. (zde GND)

Vzájemné propojení takových přístrojů způsobí v jedné půlvlně zkrat (viz. obr.1), který v lepším případě přeruší pojistku, v horším zničí můstkový usměrňovač (diodu D4).

Přehled možných řešení

Pokud tedy mají být moduly UDO (UDI) propojeny s řídící centrálou, která je vybavena můstkovým usměrňovačem, je nutno provést jedno z následujících opatření:
obr.2: řešení s ext. diodou
obr.2: řešení s externí diodou: modrá dioda přeruší cestu zkratovému proudu
  • Použít dva samostatné napájecí transformátory, jeden pro přístroje s můstkem, druhý pro přístroje s jednocestným usměrňovačem. (nebo jedno trafo se dvěma samostatnými sekundáry)

  • Zařadit externí diodu (obr.2) do vstupní svorky 24V_GND každého přístroje s jednocestným usměrňovačem. Dioda je znázorněna modře. Z obr.2 je patrné, že tato dioda přeruší cestu zkratového proudu popsanou u obr.1 a lze pak bez obav propojit GND obou přístrojů .

  • Namísto jedné diody Dext(obr.2) zařadit mezi trafo a modul s jednocestným usměrňovačem úplný můstkový usměrňovač. Modul je v tomto případě napájen oběma půlperiodami sinusovky, což je příznivé pro životnost filtračních elektrolytů přístroje.


Zásady připojování modulů fy.YORIX k řídícím centrálám

Připojení I/O modulů k řídící centrále - přehled možných variant podle použitého napájení

Varianty připojení:

1 - použití samostatného transformátoru pro napájení jednoho, nebo několika I/O modulů;
doporučená varianta: napájecí proud teče jinými vodiči, než řídící signál
2 - použití společného transformátoru pro I/O moduly i řídící centrálu;
! nelze použít vždy, nutno prověřit zapojení zdroje řídící centrály !
3 - využití interního zdroje řídící centrály, pokud takovým obvodem disponuje (Honeywell EXCEL 100)

Varianta 1 (doporučená) - S autonomním napájecím transformátorem (T2)

I/O modul(y) jsou napájeny samostatným transformátorem T2.
Napájecí a signální proud tečou společně vodičem GND pouze v místě propojky mezi I/O moduly (na obr. fialová); moduly proto těsně k sobě, propojka(y) co nejkratší, vodičem dostatečného průřezu.

Vodič GND mezi kontrolerem a I/O moduly (na obr. modrý) není zatížen proudem (kromě nepatrného řídícího signálu; cca 1mA), je použit společný pro všechny I/O moduly.

Propojovací vodič GND (mezi kontrolerem a I/O moduly) je zde pouze signální - není zatížen napájecím proudem =>nevznikají na něm nežádoucí cizí napětí. Důsledná separace napájecích vodičů od signálních je zde základem úspěchu:

  • Napájecí vodiče z transformátoru připojit přímo do příslušných svorek modulu UDO6. Při použití více modulů propojit jejich svorky 24V_GND navzájem co nejkratším vodičem průřezu 1.5 mm2. (Ţ moduly těsně vedle sebe.) Obdobně provést i druhou napájecí svorku (+24V).
  • Ovládací vedení (AO,GND) vést kroucenými vodiči. GND přitom vést jedinou žilou, která je společná pro všechny použité AO (při použití více modulů) .
  • Výkon transformátoru T2 - na každý modul doporučujeme počítat cca 10 VA.

Výhody zapojení s autonomním transformátorem:

  1. Přípustná vzdálenost mezi modulem a kontrolerem cca 20m
  2. Minimální chybové napětí ( na signálním vedení nevzniká úbytek napětí od napájení)
  3. Lze bezpečně aplikovat k jakémukoli kontroleru, aniž by bylo nutné znát jeho vnitřní zapojení (narozdíl od níže popsané varianty 2 (společné trafo), jejíž aplikace na nevhodný kontroler (viz. varování ) může způsobit zničení vnitřních napájecích obvodů kontroleru)

Pozn.:
Lepší, byť komplikovanější obdobou této varianty je použití samostatného zdroje 24V=, případně doplnění transformátoru T2 můstkovým usměrňovačem, ať už s filtračním kondezátorem, nebo bez něho.
Takto provedené napájení snižuje proudové zatížení filtračních elektrolytů uvnitř I/O modulů a prodlužuje jejich životnost.

Varianta 2 - Při využití společného napájecího transformátoru:

 | tak ne!
Správné zapojení: uzel GND je v Excelu, tam vede jištěný přívod z transformátoru Ke každému I/O modulu je veden samostatný vodič GND, který nepokračuje k dalším přístrojům; je tedy zatížen pouze napájecím proudem vlastního I/O modulu. Omezení odporu vodiče pak zajistí krátký drát solidního průřezu. (modul co nejblíž kontroleru) | Odstrašující příklad: uzel GND je na trafu vodič GND mezi Excelem a UDO6 obsahuje pojistky s relativně velkým odporem - chybové napětí řádově stovky mV. N modulů zavěšených paralelně k takto vyvedenému napájení zvýší chybové napětí N-krát...

VAROVÁNÍ: Tato varianta je možná pouze s kontrolery, které mají GND na společném potenciálu s jedním pólem napájecího transformátoru!!! (Honeywell Excel 20, Excel 50)
Pozn.:
Pro kontrolery nesplňující podmínku společné svorky 24V_GND existuje také řešení (s ext.diodami), viz. nebezpečí zkratu. Toto řešení ale není příliš praktické, určitě je vhodnější a bezpečnější použít zapojení podle výše uvedené varianty 1.

Žíla GND mezi kontrolerem a I/O modulem (UDO6 na obr.) je zde zatížena napájecím proudem; napájecí proud vyvolává úbytek napětí na odporu tohoto vodiče. Toto nežádoucí napětí se superponuje k užitečnému signálu a při nedodržení níže uvedených zásad může dosáhnout hodnot, které způsobí chybnou odezvu modulů. Minimalizace chybového napětí lze dosáhnout současnou minimalizací odporu vodiče GND a proudu jím protékajícího.

Ţ Nutné podmínky:

  • GND je rozveden paprskovitě, přičemž uzel je v Excelu nebo jeho těsné blízkosti! Nikdy ne na trafu! Vývod 24V_GND z trafa do uzlu je jištěn společnou pojistkou. (viz.obr.)
    Ovládací vodiče (AO a GND) připojit do svorek kontroleru určených pro příslušný AO, a provést je krouceným párem o průřezu žíly 1.5mm2 , co nejkratším (do 60 cm) (Ţ modul co nejblíž kontroleru), žádné pokračování vodiče 24V_GND k napájení dalších přístrojů!

  • Napájení 24V z druhé svorky transformátoru může být jištěno pro každý přístroj samostatně. Délka, průřez a topologie tohoto vodiče funkci přístrojů neovlivňují.

Zde je ještě odkaz na zjednodušený výklad k této variantě s návodem, jak rychle řešit problém v hotovém rozvaděči.

Varianta 3 - Při využití interního zdroje kontroleru (EXCEL 100, EXCEL 80) určeného k tomuto účelu: UDO6 a XL100

Výše citované kontrolery mají interní zdroj 24V, 300mA (svorky 65,66). Pro připojení modulů zde opět platí:

  • Ovládací vodiče (AO a GND) připojit do svorek kontroleru, a provést je krouceným párem o průřezu žíly 1.5mm2 co nejmenší délky (max. 100 cm).
  • Napájecí napětí +24V pak použít ze svorky 66 kontroleru. Délka, průřez a topologie tohoto vodiče nejsou kritické, nutno mít pouze na paměti omezené proudové zatížení tohoto zdroje.

© YORIX s.r.o., Ing. Richard Trochta, 17.02.1999


Zásady připojování modulů fy.YORIX k řídícím centrálám

Ochrana před elekromagnetickým rušením

Rozvod GND v rozvaděči MaR:

Pro připojení modulů UDO a UDI zásadně použít samostatný, ničím nepřerušený vodič, natažený ze svorky GND EXCELu (obecně jakékoli řídící stanice) do svorky GND UDO(UDI). Nikdy nepokračovat k dalším přístrojům; k nim natahnout nový vodič znovu přímo ze svorky GND EXCELu. Právě k tomu má každý EXCEL svorek GND bezpočet!
Tak je to správně | takhle ne!
Ideální stav. Dopřejte každému přístroji samostatný vodič GND! Je to nejlepší cesta k zajištění spolehlivé funkce. | Špatně! Rozvodem GND "od přístroje k přístroji" bezpečně přivodíte cizí napětí na GND řádově stovek mV. Veškerý napájecí proud ze zdroje 24V ke všem připojeným přístrojům teče jediným vodičem. Tento vodič je naneštěstí současně signálním vodičem, úbytek napětí od napájecího proudu je cizí napětí, superponované k užitečnému signálu.

Co dělat, když už je rozvaděč hotový a GND je špatně.

taky dobře
Minimálně je potřeba zajistit samostatný vodič GND pro moduly UDO,UDI. Není to stav ideální, ale zpravidla vyhovující.

Náprava (změna oproti šedému obrázku vpravo nahoře) je jednoduchá:
stačí přepojit jediný vodič (pokračování GND do zbytku rozvaděče) a to z pravého přístroje UDO6 do svorky GND kontroleru (=uzlu GND)

© YORIX s.r.o., Ing. Richard Trochta, 21.09.2005


Zásady připojování modulů fy.YORIX k řídícím centrálám

Zásady pro připojování I/O modulů k řídícím jednotkám (jak správně rozvádět GND)

teorie
vzory zapojení

Teoretický úvod - vymezení a popis problematiky, způsoby řešení

(Terminologie: Potenciál 24V_GND - napěťová hladina, slučující signální zem (GND) s jedním pólem zdroje 24V.)

Při použití zde popisovaných I/O modulů je nutno mít na zřeteli skutečnost, že moduly mají svorku 24V_GND společnou pro napájecí i signální okruh (obsahují jednocestný usměrňovač).
Takovéto třísvorkové provedení je naprosto běžné, má však své specifické vlastnosti; z nich pak vyplývají zásady používání, které je nutno důsledně dodržovat:

  • 1: - Opatrně se společným zdrojem napájení:

    velkou obezřetnost vyžaduje propojení I/O modulů se zařízením, které nemá ani jednu napájecí svorku společnou s GND (bývá to zpravidla zařízení, které obsahuje můstkový usměrňovač) - Nebezpečí zkratu ! -- podrobnosti zde --

  • 2: - Promyšleným rozvodem vodiče 24V_GND minimalizovat cizí napětí

    Detailním rozborem rozvodu potenciálu 24V_GND můžeme vysledovat tři typy vodičů odlišných funkcí, pro příští text definovaných takto:
    a. - napájecí vodiče 24V_GND, sloužící pouze k přenosu napájecího proudu
    b. - signální vodiče 24V_GND, sloužící pouze k přenosu řídících signálů
    c. - kombinované vodiče 24V_GND, plnící obě výše uvedené funkce současně - právě na tyto vodiče máme zaostřeno v dalšího textu:
    Na kombinovaném vodiči 24V_GND vzniká průtokem napájecího proudu úbytek napětí:

    dU = R * I (1) (viz. obr.- napětí měřené voltmetrem)

    Toto napětí se superponuje k užitečnému signálu, který tím může až znehodnotit. (Podle 2.Kirchhoffova zákona se na vstupních svorkách UDO6 objeví součet výstupního napětí AO EXCELu a úbytku napětí dU z vodiče 24V_GND; úbytek napětí na "živém" signálním vodiči zanedbáváme, teče jím pouze řídící proud max. 1mA.)

    Pro přenos řídících signálů je ideálním řešením používání pouze napájecích a signálních vodičů, a zároveň jejich důsledná separace; někdy to jde (viz. varianta 1 s oddělenými zdroji napájení).

    Při propojení dvou přístrojů, napájených společným zdrojem 24V se ale kombinovanému vodiči 24V_GND vyhnout nelze. Přirozeným požadavkem je pak alespoň minimalizovat nežádoucí cizí napětí dU z výrazu (1).

    Toho lze dosáhnout současným splněním následujících dvou podmínek:

    1. Minimalizací proudu tekoucího vodičem 24V_GND mezi kontrolerem a I/O modulem (omezení na nezbytnou velikost)
    2. Minimalizací odporu vodiče 24V_GND mezi kontrolerem a I/O modulem.(velký průřez, malá délka)

    Několik typických příkladů řešení, členěných podle použitého napájecího zdroje následuje v další kapitole tohoto dokumentu.

    Pozn.:
    Zde je potřeba ještě zdůraznit, že dodržení výše uvedených zásad zajistí omezení chybového napětí hluboko pod kritickou hodnotou, která je u modulů UDO6 a UDI6 cca 50mV.
    Naopak nerespektování těchto zásad lehce způsobí, že chybové napětí překročí hodnotu 500mV a znemožní tak I/O modulům správnou funkci. Rozvod vodiče 24V_GND v rozvaděči by proto nikdy neměl být pouze náhodným pospojením všech svorek tohoto potenciálu, ale vždy by měl být výsledkem pečlivé úvahy, zaměřené na dosažení cíle vymezeného výše.


MUDr.Jolana Trochtová - všeobecný praktický lékař === HOMEPAGE ===

MUDr.Jolana Trochtová - všeobecný praktický lékař

Nové sídlo

Ordinace je od srpna 2014 umístěna v Hradební 28.
Je to vedle papírnictví Tůmová, asi 20m od Krajinské ulice ve směru k ulici U Černé věže.
ordinace zvětšit mapu

Ordinační hodiny

Kontakt

Pondělí | 6:45 - 12:30 |
Úterý | 8:30 - 12:00 | 13:30 - 18:00
Středa | 6:45 - 12:30 |
Čtvrtek | 6:45 - 12:30 |
Pátek | 6:45 - 12:30 |

- telefon +420 387 315 624

- Adresa:

                MUDr.Jolana Trochtová
                všeobecný praktický lékař
                Hradební 284/28
37001    České Budějovice
18.8.2014


Yorix s.r.o. - soubory ke stažení

Soubory ke stažení

xfm2000.zip (15 kB) | sw submoduly XFM pro I/O moduly UDI6,UDO4b a UDO6 k řídícím centrálám Honeywell řady XL5000
 | celé www.yorix.cz zkompilované do jediného souboru typu chm (Microsoft help)
 | GreenBonO_HMI - PC program pro vizualizaci a konfiguraci regulátoru GreenBonO (verze 1.1.0.4 z 1.3.2017) pro OS Widows98 a vyšší, od verze 1.0.3.7 běží i v Linuxu, vybaveném API Wine (jak sériová komunikace, tak i TCP Socket) Program je zpětně kompatibilní ke všem starším verzím firmwaru - pravidelně je aktualizován (kvůli zajištění kompatibility s novým firmwarem). Nově podporuje národní prostředí; je přidán podadresář "language" s textovými soubory pro jednotlivé jazyky. Pro další jazyky lze přidávat nové soubory, odvozené ze stávajících souborů. Omezení je dáno pouze znakovou sadou "ANSI_CHARSET" Nezapomeňte proto spolu s novou verzí vždy aktualizovat i složku Language - s novými funkcemi přibývají nové texty.
montážní předpis | GreenBonO-montážní předpis (zatím nedokončen - obsahuje úplný popis zapojení a přezkoušení měřící části regulátoru)
postup při upgradu | GreenBonO-Postup při nahrávání nového firmwaru sériovým portem pomocí monitorovacího PC-programu
firmware-upgrade aplikační části | GreenBonO - firmware v intel.hex.formátu - pro upgrade aplikační části z verze 2.001 a vyšší (pouze aplikační část firmwaru! - funguje až v součinnosti s neveřejnou a chráněnou částí, která byla do regulátoru GreenBonO natrvalo vypálena při výrobě)
schémata zapojení regulací s GreenBonem | GreenBonO - schémata zip obsahující schémata pro různé typy a velikosti FVE ve formátu pdf dokumentů
dobíjení baterií | GreenBonO a Growatt - ukládání přebytků do baterií ; předpis zapojení pro správnou součinnost GreenBona s Growattem
GreenBonO - připojení k internetu
konfigurace Wiznet WIZ110SR | Wiznet WIZ110SR- návod k nastavení a odkaz na konfigurační soubor (ethernet komunikace GreenBona s PC)
konfigurace Secure iWifi | secure iWifi - návod a konfigurační soubor (wifi komunikace GreenBona s PC)
konfigurace HLK-RM04 | HLK-RM04 - návod k nastavení a odkaz na konfigurační soubor (ethernet i wifi komunikace GreenBona s PC)
implementace protokolu ModBus | GreenBonO - popis implementace protokolu Modbus


instalace virtuálního sériového portu do Linuxu:

1. instalace driveru:

postup instalace zde

2. vytvoření symbolického odkazu pro Wine:

zdroj informací zde
následující příkaz zapíše do skrytého adresáře "wine/dosdevices/" symbolický odkaz "com1 = ttyUSB0"

ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com1
  • ~ (tilda) v symbolickém odkazu je zástupný znak pro domovský adresář uživatele
  • tečka před wine nastavuje tento adresář jako skrytý


Yorix s.r.o. - kontakt

Kontakty

Ing. Richard Trochta - jednatel:

- telefon: +420 387 229 639
- fax:        +420 387 229 639
- mobil:   +420 605 403 886

- Adresa:

             YORIX s.r.o.
             Adamovská 147
37371 Adamov

      p.Rudolfov
    ( okres: České Budějovice )
zvětšit mapu
doktorka
© Yorix s.r.o. Ing.Richard Trochta 15.5.2011
<


Yorix s.r.o. - o firmě

O firmě

Adamov 147

- rok založení: 1996
- ič: 25163141
- sídlo: Adamov 147, 37371 Rudolfov
- okres: České Budějovice
Firma se zabývá se převážně vývojem a výrobou elektronických přístrojů pro oblast měření a regulace. Své výrobky dodává řadě dodavatelských firem MaR do Česka, Slovenska a Rakouska.
Nemá žádné zaměstnance, její činnost zajišťují výhradně majitelé. Zejména v posledních letech je většina výrobních operací zajištěna nákupem u externích firem se špičkovým technologickým vybavením.
© Yorix s.r.o. Ing.Richard Trochta 15.5.2011


Elektroodpad

Firma YORIX s.r.o. řeší elektroodpad kolektivním systémem REMA.
logo REMA

© Yorix s.r.o. Ing.Richard Trochta 31.10.2005


YORIX-UDI6

foto UDI6 (9 kbyte)

UDI6

transformace 6DI đ 1AI

princip funkce | zapojení svorek | technické parametry
software- submoduly XFM |  | Předepsané připojení ke kontroleru

Použití:

Modul UDI6 umožňuje načíst až šest vstupních veličin typu DI jedním analogovým vstupem libovolného Excelu řady 5000. K indikaci změny stavu kteréhokoli vstupu je potřeba dvou cyklů aplikačního programu (EXCEL jako vstupní hodnotu bere průměr posledních dvou načtených vzorků). Předpokládá se proto užití jen takových vstupních signálů, u nichž dochází ke změně stavu v dlouhých časových intervalech (>10sec). Nejběžnější použití modulu bývá k indikaci poruchových stavů.

Princip funkce:

Stav šesti digitálních vstupů se převede v modulu UDI6 prostřednictvím šestibitového převodníku na analogovou informaci (napětí). Toto napětí se přivede do analogového vstupu kontroleru. Sw submodul XFM (UDI6.csd) převede analogovou informaci na zpět šestici digitálních hodnot, které uloží do předepsaných virtuálních datových bodů (VD).

Nejvyšší bit má váhu 48% (4.8V), další pak vždy polovinu předchozího.
Napěťová rozlišovací úroveň modulu (váha nejnižšího bitu) je 150mV.
Všechny vstupní svorky se spínají (buďto kontaktem, nebo tranzistorem s otevřeným kolektorem) proti společné svorce GND.
Sepnutý kontakt na vstupu modulu se na jeho výstupu projeví příslušným napětím, rozepnutý kontakt (stejně jako nepoužitý vstup) má na výstupu nulovou odezvu.
Při sepnutí všech šesti kontaktů na vstupu modulu bude tedy na jeho výstupu:

4.8 + 2.4 + 1.2 + 0.6 + 0.3 + 0.15 = 9.45 V

Modul musí rozlišit 26 = 64 možných stavů.

Toto napětí je pak potřeba vyhodnotit (převést zpět na šestici binárních hodnot) softwarem kontroleru. Algoritmus ve formě vývojového diagramu je k dispozici v souboru udi_alg.pdf (9.262 kB). Velmi důležité je zde použití offsetu pro kompenzaci chyby analogového napětí.

Zapojení svorek:

štítek přístroje (2 kbyte)

je patrné z vyobrazeného štítku přístroje. Na horní straně přístroje jsou 3 svorky pro připojení napájecího napětí 24V a výstupního napětí pro kontroler. Napájecí napětí 24V může být jak stejnosměrné, tak střídavé. Svorka 24V_GND je společná pro napájení i řídící signál (ground).

Důležité ! - pozor na kombinaci můstkového a jednocestného usměrňovače

Připojení UDI6 ke kontroleru

warning Pro správnou funkci modulu je nutné minimalizovat vliv cizího napětí. To vzniká na odporu vodiče GND mezi kontrolerem a modulem UDI6 průchodem napájecího proudu. K jeho omezení je třeba:
  • minimalizovat odpor vodiče GND (vodič co nejkratší, velký průřez, cestou žádné svorky ani pojistky !!!)
  • minimalizovat napájecí proud vodičem GND (autonomní vodič GND od EXCELu k UDI6, žádné pokračování k dalším přístrojům).
Podrobněji je tato problematika popsána u přístroje UDO6.

Připojení čidel k UDI6

Zásadně používat stíněné kabely!
Potlačení rušení při souběhu kabelů je zde nutná podmínka, úzce související s problematikou popsanou v předchozím odstavci!

štítek přístroje (2 kbyte) Na dolní straně přístroje je 12 svorek pro šestici digitálních čidel. Čidla jsou na štítku přístroje znázorněny jako kontakty K1÷K6. Předpokládá se přitom, že čidla mají buďto přímo kontaktní výstupy (viz štítek), nebo mají výstupy s tranzistorem NPN s otevřeným kolektorem, který spíná proti zápornému napájecímu napětí (viz. obr. vedle). | připojení s tranzistorem NPN
Složitější, leč také řešitelná situace nastává u čidel s tranzistorem PNP, spínajícím proti kladnému napájecímu napětí.Tam je třeba doplnit kolektorový zatěžovací odpor vhodné velikosti do vstupních svorek UDI6. Pořadavkům UDI6 i proudovým možnostem čidla by měla vyhovět hodnota zatěžovacího odporu v rozpětí od 1k do 10k. | připojení s tranzistorem PNP

Rušení na vstupu UDI6 při souběhu dlouhých kabelů

Pokud kabel k čidlu je na velké délce v souběhu se silovým kabelem, může se stát, že při rozpojeném kontaktu čidla se do živého vodiče kabelu indukuje střídavé napětí 50Hz s amplitudou >15V. Záporné půlvlny tohoto napětí způsobí pokles napětí na elektrolytu C1 (viz.obr.výše) a UDI6 nesprávně vyhodnotí tento stav jako sepnutí kontaktu čidla. (na výstupu UDI6 se objeví váhové napětí odpovídající sepnutému kontaktu příslušného čidla)
Příklad: na výstupu UDI náhodně kolísá napětí o 0,6V (=váhové napětí DI4), přitom kontakt čidla ve vstupu DI4 je trvale rozepnut.

Protiopatření:

  • Rušení cizím napětím omezit použitím stíněného kabelu, stínění připojovat ke svorce GND UDI6
  • vně přístroje, do svorek rušeného vstupu UDI6 zapojit libovolnou diodu: katodou do živé svorky, anodou do GND; dioda odřízne záporné půlvlny indukovaného napětí, ostatní funkce neovlivní.

Technické parametry

Napájecí napětí | 20÷35V= nebo 16÷24V ~
Odběr ze zdroje 24V | 40mA
Rozsah výstupního napětí | 0÷9.45 V= (podle počtu vstupů v aktivním stavu)
Závislost změny výst.napětí na teplotě | max. ±1mV/1ºC při výst. napětí 9.45V
Vstupy: | 6 x kontakt nebo tranzistor s otevřeným kolektorem
Odpor vstupních svorek jedn.dig.vstupů | > 10 kW
Ochrana před nebezpečným dotykem živých a neživých částí (ČSN332000-4) | bezp.malým napětím:SELV
Doporučené prostředí (ČSN 33 2000-3) | třída AB4 (-5...40°C, 5...95% rel.vlhkosti)
Přípustné skladovací podmínky | -15...70°C, 5...95% rel.vlhkosti
Rozměry: | rozměrový náčrtek přístroje (3 kbyte)

Software - Submoduly XFM

Pro uživatele jiných automatů, než Honeywell Excel5000, je zde alespoň obecný popis algoritmu pro vyhodnocení analogového napětí UDI6.

Submoduly XFM

Oba uvedené submoduly jsou určeny k použití s hw modulem UDI6. Rozdíl v jejich použití je uveden níže.

Název | Funkce | Download
UDI6.csd | Šest digitálních vstupů (6* VD) | xfm2000.zip (říjen 99)
UDI5.csd | Pět digitálních vstupů (5*VD)

Submodul UDI6.csd

Použití submodulu XFM UDI6.csd - jeho připojení v sekci "Control strategy":

XFM 1. Analogový vstup submodulu - vstup "inp" submodulu se připojí na fyzický vstup kontroleru (viz. obr.: - modrá čára)

2. šestice digitálních výstupů submodulu
- kliknout na tlačítko “datapoints...” (viz. obr.) - otevře se seznam šesti virtuálních datových bodů
- kliknout na tlačítka “set” a "OK" ; datové body ze seznamu se automaticky umístí do volných polí dolní lišty sekce “control strategy”, kde je lze dle potřeby přejmenovat (klávesou F5).

Všech šest bodů je rovnou i připojeno, pouze toto připojení není graficky zobrazeno.

Submodul UDI5.csd

Pokud není k modulu UDI6 připojeno všech 6 vstupů, je lépe použít XFM submodul UDI5.csd. Narozdíl od UDI6.csd je vidět připojení vývodů ze submodulu a projekt je přehlednější.
Omezení počtu vstupů modulu UDI6 přináší také zvýšení funkční spolehlivosti (odolnosti vůči cizím a chybovým napětím). Toho lze dosáhnout nevyužitím vstupů s nejnižší vahou při odpovídající úpravě ofsetu (parametru č.2):

Počet použitých vstupů | Vynechané vstupy | Ofset [%] (par.2)
5 | DI6 | 1,5
4 | DI6, DI5 | 3

Pozn:
Úprava ofsetu je sice možná i u submodulu UDI6.csd, ale v aplikaci, která jej používá, nelze smazat nepoužité datové body (jsou k němu nevratně připojeny příkazem SET). Tyto body se pak zbytečně objevují v seznamu bodů typu VD.

Submodul UDI5.csd má svých pět výstupů provedeno klasicky (jako vývody z ikony XFM - viz. obr.), případný nepoužitý výstup z ikony se prostě nikam nezapojí.

ÓYORIX s.r.o., Ing. Richard Trochta, 15.2.1999


UDO - Typické závady

Typické závady modulů UDO4b (a UDO6)

Reléová deska - Vysychání elektrolytického kondenzátoru 220M/50V

Životnost elektrolytických kondenzátorů je obecně nejkratší ze všech běžných elektronických součástek.

Na reléové desce se po cca 5 letech začne projevovat vysychání elektrolytického kondenzátoru 220M/50V, doprovázené ztrátou jeho kapacity.
Tento kondenzátor filtruje napájecí napětí za jednocestným usměrňovačem. V důsledku ztáty jeho kapacity pak dochází k nárůstu zvlnění interního napájecího napětí a současně k poklesu velikosti napájecího napětí. Přístroj pak při napájení střídavým napětím začne chybovat, až přestane úplně fungovat. ( pokud je však připojen na zdroj vyhlazeného stejnosměrného napětí, funguje dál normálně.)

Kondenzátor je nutné nahradit novým. K prodloužení dalšího funkčního cyklu je dobré použít kondenzátor 220M/50V pro teploty do 105°C a zároveň vyměnit i sousední kondenzátor 47M/50V. vysychající kondenzátory

Řídící deska - vysychání elektrolytického kondenzátoru C8

pozn.:
týká se pouze desek z počátečního období jejich výroby: 97/03....99/08

C8 je vlevo od středu desky
C8 je zde již zobrazen jako fóliový
Kondenzátor C8 je v těchto přístrojích elektrolytický (10uF/50V) a vysychá! Rychlost vysychání je přímo úměrná okolní teplotě a velikosti napájecího napětí.
Kondenzátor je součástí obvodu zdroje záporného napětí (nábojové pumpy) pro operační zesilovač a D/A převodník.
Poté, co jeho kapacita klesne pod 0.1 uF, záporné napětí (měřitelné na zenerově diodě VZ1; na obr. je vpravo dole) zanikne, UDO4b přestane zcela fungovat a začnou topit odpory R3 a R12 (na obr. nad kondenzátorem) a odpory R16,R17 (levý horní roh). Krabička přístroje v blízkosti těchto odporů zhnědne.

Náprava:

Nahradit elektrolyt C8 fóliovým kondenzátorem 0,47…1 uF.
V katalogu firmy GM electronic je vhodný typ CF1-470N/K (skl.č. 121-344), nebo CF1-1M0/K (121-340).
Dále je vhodné nahradit Kondenzátor C7 tantalem 22M/10V.
Pozn.: Všechny přístroje UDO4b a UDO6 vyrobené po datu 99/08 jsou řešeny právě takto.

Pozor!
Při vyjímání starého kondenzátoru může dojít k přerušení prokovených děr v plošném spoji. V takovém případě je potřeba zaletovat vývody nového kondenzátoru z obou stran plošného spoje.

Prevence:

Nejlépe je nečekat až do selhání funkce přístroje a provést náhradu na ještě funkčním přístroji. Tuto opravu provádíme za cenu vynaložených nákladů, přesto u řady klientů předpokládáme, že upřednostní výměnu kondenzátoru vlastními silami před balením a odesíláním zásilky nebo dokonce odbavováním celních formalit.


Deska TR040

TR040

nová řídící karta pro UDO6 a UDO4b (2006)

co znamená blikání LED diody na kartě umístění jumperů virtuální trimr

Proč nová karta a co se změnilo

Tato karta plynule nahrazuje v průběhu 1.čtvrtletí 2006 původní kartu TR027. Důvodem je drastický útlum výroby D/A převodníku DAC08, který se tím stává prakticky nesehnatelný.
Mikroprocesor ATTINY26, použitý na nové kartě již v sobě obsahuje řadu obvodů, které byly na staré kartě řešeny externě.
Nová karta, byť působí velmi spoře, obsahuje vše, co měla původní, a ještě něco navíc:
  • autodiagnostiku - prostřednictvím LED diody indikuje některé důležité nestandardní stavy přístroje
  • možnost použití tří jumperů k volbě pracovních režimů
  • možnost doplnění sériové komunikace s okolím
  • univerzální firmware pro UDO4 i UDO6 - karta sama rozpozná, kterou reléovou deskou má připojenou a zvolí požadovaný program.
Významným přínosem nové karty je i nižší vlastní spotřeba, která v konečném důsledku představuje snížení celkového proudového odběru přístroje o 20mA (asi 20%).

Autodiagnostika - význam blikání LED diody

Na kartě, pod mikroprocesorem je umístěna žlutá LED, jejímž úkolem je informovat okolí o neobvyklých stavech přístroje. Činí tak 16-ti taktovou blikací sekvencí, v celkové době trvání cca 2 sec. V současné době umí indikovat následující 4 stavy (animované obrázky GIF níže věrně simulují indikaci):
4blik (4 bliknutí)- není kalibrován oscilátor mikroprocesoru Tyto dva stavy se vyskytují pouze během výchozí kalibrace ve výrobě; u hotového, seřízeného výrobku se s nimi již nesetkáte.
3blik (3 bliknutí)- není kalibrován A/D převodník mikroprocesoru
2blik (2 bliknutí)- chyba řídícího napětí:
Přístroj dá dvojím bliknutím najevo, že řídící napětí na jeho vstupu je nejednoznačné (v časovém horizontu několika sekund nazpět nedrželo úroveň, která by se dala jednoznačně vyhodnotit, ale pohybovalo se nejméně ve dvou různých hladinách) Tento stav vyvolává obvykle střídavá složka napětí, zavlečená do řídícího okruhu nevhodným rozvodem vodiče GND v rozvaděči. Přístroj zůstane paralyzován (neví co udělat, proto jen vyčkává na takové napětí, které dokáže vyhodnotit).

Řešení spočívá v "předrátování" části GND související s řídícím signálem podle doporučeného zapojení.

1blik (1 bliknutí) - výpadek řídícího napětí (pouze v režimu UDO6b, v ostatních režimech je nulové řídící napětí jedním z běžných pracovních stavů)

Jumpery - rozmístění na kolíkové liště

Kolíková lišta 2x5 pinů plní dvojí funkci:
Primárně slouží k sériovému programování (ISP) mikroprocesoru ATTiny26 zaletovaného v desce, význam pinů je shodný s 10pin konektorem vývojového kitu STK500 výrobce mikroprocesoru(ATMEL). 2*5 Za běžného chodu mikroprocesoru je tento konektor využit jako pole tří jumperů a také (v případě potřeby) k RESETu mikroprocesoru.

Funkce Jumperů

Jumper1 - volba pracovního režimu

Má stejnou funkci jako jumper na původní desce TR027 (1997..2005), tj volbu pracovního režimu.
přístroj | režim při rozpojeném jumperu | režim při spojeném jumperu
UDO6 | UDO6b | UDO6
UDO4b | UDO4 | 4.st.kaskáda

Jumper3 - režim virtuálního trimru

Tento režim umožní mírnou úpravu charakteristiky přístoje, podobně jako to umožňoval trimr na původní desce TR027.
Lze zvyšovat nebo snižovat citlivost přístoje v sedmi krocích po 15mV v každém z obou směrů. (Rozumí se konec charakteristiky, nastavený z výroby na 9,45V; ten lze odklonit v rozsahu 9,35..9,55[V] )
LED dioda autodiagnostiky slouží v tomto režimu k indikaci polohy virtuálního trimru. Indikuje pouze absolutní hodnotu pozice - jeden ze sedmi možných kroků.
Neindikuje, kterým směrem (+ / -) se provádí úprava. To však ví technik, který úpravu provádí...
Na šestici LED indikujících stav relé je přitom vidět odezva přístroje na prováděný zásah do charakteristiky.

Tabulka indikace polohy virtuálního trimru: (blikací sekvence)
krok | posun charakteristiky | sekvence blikání led (obdoba Morseovky)
0 | 0 | LED nesvítí
1 | 15mV | .
2 | 30mV | . .
3 | 45mV | . . .
4 | 60mV | . . . .
5 | 75mV | _
6 | 90mV | _ .
7 | 105mV | _ . .
Pozn.:
Blikací sekvence kroků 1..4 je věrně demonstrována animovanými obrázky v tabulce autodiagnostiky.

Jak hýbat virtuálním trimrem

Nastavení se provádí za následujících podmínek:
  1. Modul přepnout do starého režimu "A" (jumper1=ON)!
  2. Na vstup UDO6 připojit napětí 9,37 V= . (Z AO kontroleru nastaveného do režimu manual.)
  3. Při tomto napětí musí na UDO6 svítit pět diod LED zleva, šestá dioda musí být zhasnuta. Pokud tomu tak není, je potřeba nastavit požadovaný stav postupem popsaným níže:
Postup lze shrnout do 3 kroků:
jumpery
  1. spojení Jumperu3- navolení režimu "virtuálního trimru"
    tento krok povolí manipulaci s trimrem včetně zápisu jeho stavu do EEprom mikroprocesoru, a přepne přístroj do režimu UDO6, který je pro nastavování nejvhodnější. (použít propojku dodávanou k Jumperu1, který musí být beztak uvolněný-viz.krok2)
    LED dioda přitom indikuje polohu virtuálního trimru sekvencemi popsanými v tabulce uvedené výše.

  2. nastavení virt. trimru:
    se provádí opakovaným spínáním (= krátkodobým propojováním pinů, lze např. šroubovákem) Jumperu2 nebo Jumperu1:
    • spínání Jumperu2 zvyšuje citlivost (obdoba přidávání na trimru)
    • spínání Jumperu1 snižuje citlivost (obdoba ubírání na trimru)

  3. rozpojení Jumperu3 - uložení nastavení:
    po skončení kroku 2 je nutno Jumper3 vyjmout. Tím se nastavená korekce uloží do EEprom mikroprocesoru a další zápis do EEprom se zakáže.
    Pak už jen zbývá zvolit požadovaný pracovní režim přístroje Jumperem1.
Nastavování lze kdykoli znovu zopakovat.
Tato funkce je implementována u přístrojů expedovaných po 1.6.2007 (lze zjistit podle začátku výrobního čísla - formát rr/mm).
U starších přístrojů spojení Jumperu3 zůstane bez jakékoli odezvy. Upgrade je možný - stačí přepálit firmware.


XFM - podpůrný software pro UDO6

Podpůrný software pro Modul UDO6

popis funkce a použití sumodulů XFM
(pouze pro program CARE - kontrolery Honeywell řady XL5000)

UDO6 - šestice digitálních výstupů
UO6_3V - tři regulační ventily
UO6_2V2D - dva ventily + dva DO
UO6_1V4D - jeden ventil + čtyři DO
UDO6_MPX - multiplexer k postupnému načtení šesti analogových vstupů

Šestice digitálních výstupů

UDO6.csd - původní verze (1997-98)

Submodul pro první verzi modulu UDO6 (ještě bez jumperu).
Dnes je jeho použití opodstatněné pouze u těchto starých modulů, které ještě neměly "béčkový" režim.

UDO6b.csd - odolnější modifikace

Reléový modul UDO6 expedovaný po 15.10.98 má možnost zvolit jumperem bezpečnější režim UDO6b ; s vyšší odolností vůči nepřesnostem nastavení, rušivým napětím apod. K tomuto režimu nutně přísluší stejnojmenný submodul XFM - UDO6b.csd. Svým vzhledem a způsobem použití se tento submodul neliší od submodulu UDO6.csd.

připojení UDO6.csd v control strategy

Způsob použití submodulu UDO6.csd je evidentní z obrázku.

Fyzický výstup je nutno definovat jako Linear Output.

ParametrFile - submodul obsahuje pouze jediný parametr, který nemá žádný vliv na jeho funkci, slouží pouze k identifikaci submodulu v případě prohledávání souborů parametrů.

Tři regulační ventily na jednom AO

UO6_3V.csd

Pro původní moduly bez jumperu.
S novějšími moduly nepoužívat.

UO6B_3V.csd

Submodul stejné funkce pro režim UDO6b.
Výhoda - výrazně vyšší spolehlivost - odolnost vůči cizím napětím.
Nevýhoda - dvakrát hrubší krokování ventilu (časový element = 2 cykly aplikačního programu).
Vnějším vzhledem, ani způsobem použití v CARE se neliší od submodulu UO6_3V.

Použití: Tento submodul umožní ovládat 3 třístavové regulační ventily v režimu simulace spojitého řízení 0...100%.

Chování každého ze 3 ventilů je obdobné režimu, jaký plní třístavový ventil připojený na výstup AO (konfigurovaný jako třístavový) přes reléový modul 2P10/3 (YORIX) nebo MCD3 (Honeywell). Stejně jako v uvedeném případě je i zde nutno zadat přestavnou dobu ventilů. Údaj se zadává do příslušných parametrů.

funkční omezení: Z faktu, že XFM submoduly jsou součástí aplikačního programu (=interpreter), plyne následující funkční omezení - časový element submodulu je roven jednomu cyklu aplikačního programu, nelze tedy sepnou žádné relé na dobu kratší, než je doba cyklu programu. Platí proto zásada- čím delší celková přestavná doba ventilu, tím jemnější je krokování. Od verze 2.1 (99_01) si submodul sám změří dobu cyklu programu a optimálně nastaví pásmo necitlivosti. Nedochází tedy již ke kmitání okolo požadované polohy ani při krátkých přestavných dobách ventilů nebo delší době cyklu jako u předchozí verze.

Kompenzace chyby skutečné polohy ventilu (k níž po čase dochází u každé podobné simulace s 3.stavovým pohonem) probíhá automaticky při povelu do krajní žádané polohy (prodloužení doby chodu ventilu o 50%). Při dlouhodobém setrvání pohonu v blízkosti krajní meze (konkrétně 0,1...2,9% od kraje) startuje pohon k opakované kompenzaci vždy po uplynutí intervalu daného parametrem 3 (doba klidu mezi dvěma kompenzacemi).
Při požadavku na pozici ventilu 0% zůstane trvale sepnuto relé pro zavírání, stejně tak při požadavku na pozici ventilu 100% zůstane trvale sepnuto relé pro otvírání.
Pokud je trvalé sepnutí relé v koncové pozici nežádoucí, stačí omezit rozsah vstupní hodnoty submodulu na interval 1...99%. Pohon také dojede do koncové polohy, relé pak vypne (viz. kompenzace chyby).

Inicializace (sjetí do nuly a poté na žádanou hodnotu) proběhne po každém výpadku napájení delším než 2 minuty. Pokud je v projektu definována logická tabulka pro VD STARTUP viz. níže, proběhne inicializace po každém výpadku, bez jakékoli další podmínky.

Ochrana před lepením kontaktů - submodul brání bezprostřední reverzaci ventilu tak, že změnu směru pohybu ventilu podmiňuje nejméně jedním programovým cyklem ve stavu klid, který v případě potřeby sám vloží. Snižují se tak momentové rázy na převodové ústrojí pohonu i proudové zatížení kontaktů relé. (zamezí se lepení kontaktů relé)

Vstupy submodulu

RV1, RV2, RV3 - každý z nich očekává požadovanou polohu svého ventilu (0...100%) tedy zpravidla výstupní signál PID regulátoru.

STARTUP- tento VD je interně připojen jako další vstup submodulu (tlačítko DATAPOINTS, obr.vedle; po stisku tohoto tlačítka je nutno potvrdit připojení na stejnojmenný systémový VD.). Submodul dostává prostřednictvím tohoto datového bodu povel k inicializaci po výpadku napájení. STARTUP však musí mít k tomuto účelu v sekci Switching logic definovánu následující tabulku: startup

Výstup submodulu

udo - vyvede se na fyzický AO nakonfigurovaný jako linear output 0...100%.

Parameter File

Parametry bez názvu neměnit!
Parametry, u kterých se očekává jejich modifikace jsou v submodulu opatřeny názvem. Parametr_1 slouží opět pouze k identifikaci submodulu, parametr_3 určuje interval po jehož uplynutí se v případě trvalého požadavku programu na krajní polohu ventilu zopakuje sepnutí relé pro tento směr na 50% přestavné doby. Parametry 6,7,8 jsou přestavné doby jednotlivých ventilů pro otvírání, par.11,12,13 pak pro zavírání.

Funkce jednotlivých relé modulu UDO6:
KA1 | ERV1 otvírá
KA2 | ERV1 zavírá
KA3 | ERV2 otvírá
KA4 | ERV2 zavírá
KA5 | ERV3 otvírá
KA6 | ERV3 zavírá

Odvozené submoduly

V projektu se často nenajde plné vytížení submodulů popsaných výše, ale vyvstává potřeba kombinace jejich funkcí. Výčet možných požadavků pokrývají následující dva submoduly:

1 regulační ventil + 4 DO

UO6_1V4D.csd

Submodul pro původní moduly UDO6 bez jumperu.
S novějšími moduly nepoužívat.

UO6B1V4D.csd

Submodul stejné funkce pro režim UDO6b.
Výhoda - výrazně vyšší spolehlivost.
Nevýhoda - dvakrát hrubší krokování ventilu.
Vnějším vzhledem, ani způsobem použití v CARE se neliší od submodulu UO6_1V4D.

Parametr File je obdobou souboru UO6_3V.csd popsaného dříve, pouze parametry 7,8,12,13 jsou nevyužity.

Vstup rv1 submodulu je přirozeně analogový, vstupy di1...di4 digitální. Připojený fyzický výstup kontroleru musí být definován jako linear output 0...100%.

Pro VD STARTUP platí totéž, co u předchozího submodulu.

Opět platí - čím delší celková přestavná doba ventilu a kratší doba cyklu programu - tím jemnější je krokování ventilu.
Funkce jednotlivých relé modulu UDO6:
KA1 | ERV1 otvírá
KA2 | ERV1 zavírá
KA3 | Dig.výstup 1
KA4 | Dig.výstup 2
KA5 | Dig.výstup 3
KA6 | Dig.výstup 4
Důležité!: Všimněte si, že na obrázku je výstup PID připojen nejprve na VA (se jménem příslušného ventilu), a teprve poté na vstup XFM. Teprve tento VA vám zpřístupní ventil na ovládací panel; můžete monitorovat polohu ventilu, ovládat ventil v ručním režimu a zejména kontrolovat chování PID regulátoru při optimalizaci jeho parametrů.

Dva regulační ventily + dva DO

UO6_2V2D.csd

Submodul pro původní moduly UDO6 bez jumperu.
S novějšími moduly nepoužívat.

UO6B2V2D.csd

Submodul stejné funkce pro režim UDO6b.
Výhoda - výrazně vyšší spolehlivost.
Nevýhoda - dvakrát hrubší krokování ventilu.
Vnějším vzhledem, ani způsobem použití v CARE se neliší od submodulu UO6_2V2D.

Vstupy rv1,rv2 submodulu jsou analogové, vstupy di1,di2 digitální. Připojený fyzický výstup kontroleru musí být definován jako linear output 0...100%.
Opět platí - čím delší celková přestavná doba ventilu a kratší doba cyklu programu - tím jemnější je krokování ventilu.

Pro VD STARTUP platí totéž, co u předchozího submodulu.

První čtyři relé modulu UDO6 přísluší ventilům ERV1, ERV2, další dvě pak digitálním bodům. Parametr File je obdobou souboru UO6_3V.csd popsaného dříve, pouze parametry 8 a 13 nejsou využity.
Funkce jednotlivých relé modulu UDO6:
KA1 | ERV1 otvírá
KA2 | ERV1 zavírá
KA3 | ERV2 otvírá
KA4 | ERV2 zavírá
KA5 | Dig.výstup 1
KA6 | Dig.výstup 2

Obdobné submoduly XFM pro UDO4b

Pro reléový modul UDO4b jsou zpracovány zcela obdobné submoduly. Lišící se od submodulů popsaných v tomto dokumentu pouze počtem výstupních datových bodů a není proto pro ně zpracována samostatná dokumentace.

MULTIPLEX-cyklické načítání až 6 analog. hodnot jedním AI, za asistence jednoho AO

multiplex

UDO6_MPX

-společný pro moduly UDO6 i UDO4b
-doporučené použití - s UDO4b
pro UDO6 je lépe použít UO6b_MPX

UO6b_MPX (říjen 99)
pouze pro UDO6 v režimu B - ne pro UDO4b

Výhoda - výrazně vyšší spolehlivost.
Vnějším vzhledem, ani způsobem použití v CARE se neliší od submodulu UDO6_MPX.
Reléový modul řízený jedním AO postupně připojuje k jednomu AI až 6 analogových snímačů stejného typu (užitý fyzický analogový vstup kontroleru je nakonfigurován pro jeden určitý typ snímače), cyklicky načítá jejich hodnoty a ukládá je do datových bodů typu VA (virtual analog). Lze použít u veličin s velmi pomalou časovou funkcí, neboť minimální doba pro aktualizaci vstupní veličiny je cca 20 ... 30 sec. (př.: teploty v bojlerech, venkovní teploty, nebo hladiny a tlaky velkých nádrží snímané čidly stejného typu apod.)

K postupnému připínání čidel (řízení použitého modulu UDO) se spotřebuje 1 AO.

Aby bylo možno v aplikaci použít více než jeden multiplexer při využití jediného AO ke společnému řízení krokování všech modulů UDO, může submodul pracovat ve dvou režimech volených hodnotou parametru č.2:

  • - Režim “master" tohoto submodulu je základní, využívá všechny vnitřní funkce submodulu.
  • - Režim “slave” je doplňkový režim, používá se až při použití více multiplexerů v aplikaci, potlačuje některé vnitřní funkce, které již plní první použitý submodul XFM v režimu master.

Submodul v režimu MASTER - (parametr2 = 1)

mpx Tento režim je nutný vždy u prvního submodulu UDO6_MPX použitého v aplikaci, neboť v tomto režimu submodul generuje:
  • ovládací napětí pro reléový modul na svém výstupu "UDO".
  • synchronizační kód (pro načítání vstupních veličin a jejich ukládání do příslušných VA) pro případné další submoduly typu SLAVE na svém výstupu "CLK".

Vstup "clk" submodulu v režimu master neplní žádnou funkci (synchronizační kód je zde generován interně), CARE však vyžaduje jeho připojení, lze do něho zavést (či zapsat-viz.obr.vedle) jakoukoli analog. hodnotu.

Vstup “inp” je připojen na fyzický AI, do něhož jsou postupně připojována monitorovaná čidla.

Šestice načtených hodnot - výstupy submodulu

- První 3 načtené hodnoty se ukládají do virtuálních analogových bodů mx1, mx2, mx3, generovaných příkazem Set (viz. obr. vedle) při vložení XFM do projektu,

- další tři jsou vyvedeny jako výstupy submodulu mx4...mx6 volně k dispozici programátorovi. (programátor je může i nemusí použít)

Postup při definici prvních tří virtuálních analogových bodů mx1,mx2,mx3:

  • při stavu znázorněném na obr. výše kliknout myší na tlačítko “Datapoints...”. Otevře se okno zobrazené na obrázku vedle.
  • Kliknutím na tlačítko “SET” a poté “OK” se umístí uvedené datové body na lištu virtuálních bodů. Poté je lze přejmenovat (stisknou F5, kliknout myší na VA na dolní liště; otevře se okno s názvem)

Více multiplexerů v aplikaci:

Submodul v režimu SLAVE (parametr2 = 0)

Tento režim se zavádí až při použití druhého (a dalšího) multiplexeru v kontroleru. První submodul (MASTER) již generuje řídící napětí pro UDO, bylo by proto nesmyslné obětovat další AO.

HW: Vstupní svorku dalšího reléového modulu připojíme paralelně k vstupní svorce prvního modulu (při výst. proudu 1mA “utáhne” AO EXCELu 5 reléových modulů UDO). Oba reléové moduly nyní přirozeně krokují naprosto synchronně.

SW:Stejně tak je nutno zajistit synchronní chod i dalších funkcí submodulu SLAVE - to je zajištěno tak, že synchronizační kód si modul SLAVE negeneruje sám, ale dostává ho z výstupu “CLK” submodulu MASTER do svého vstupu “clk”. Výstupy "UDO" a "CLK" modulu SLAVE se nepřipojují jejich funkce přísluší výhradně modulu MASTER.

Na obrázku je znázorněno zapojení modulu MASTER (vlevo) i modulu SLAVE (vpravo). MASTER řídí jak reléové moduly signálem “UDO”, tak i časování modulu SLAVE signálem “CLK”. Na obrázku není vidět pouze vlastní interní nastavení režimu (master/slave) jednotlivých submodulů a to parametrem č.2, blíže viz. následující odstavec.

Parametr File:

  • par1-identifikační číslo XFM modulu;slouží pouze k snazší identifikaci při hledání v seznamu parametrů
  • par2- volba režimu; 1=master, 0=slave
  • par3-počet připojených vstupů; parametr učuje, kolik kroků provede UDO v celém cyklu. Je-li např. nastaven na 4, UDO cyklicky krokuje první čtyři relé. Proto lze tento submodul použít i pro reléový modul UDO4b, nebo UDO4. Lze zvolit i méně než 4 vstupy, je však nutno mít na paměti, že všechny moduly se chovají podle nastavení modulu MASTER (viz pozn. níže).
  • par4- čas.prodleva mezi dvěma kroky, která se přičítá k nezbytně nutnému času představujícímu dobu tří cyklů programu. Slouží ke zpomalení cyklování (životnost relé)
  • par5 - ofset 1.načtené hodnoty (korekce naměřené hodnoty prvniho čidla)
  • par6¸ 10-obdoba par5 pro další čidla
Pozn.: Modifikace parametrů Par3 a Par4 má smysl pouze u submodulu MASTER (ovlivňují funkce, které přísluší výhradně tomuto modulu, moduly slave to musí již pouze respektovat).

© YORIX s.r.o., Ing. Richard Trochta, poslední aktualizace 20.11.1999